Unable to connect to WAN servers after installing on Raspberry Pi 4

I have used this guide to install OpenWrt on my Raspberry Pi 4 behind my ISP router, along with some help from the community.

It installed successfully and I was able to connect to the UI, but I cannot connect to any other outside website or server. It just stops responding.

How can I fix and diagnose this issue?

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have

uci export network; uci export wireless; \
uci export dhcp; uci export firewall; \
head -n -0 /etc/firewall.user; \
ip -4 addr ; ip -4 ro li tab all ; ip -4 ru; \
ip -6 addr ; ip -6 ro li tab all ; ip -6 ru; \
ls -l  /etc/resolv.* /tmp/resolv.*; head -n -0 /etc/resolv.* /tmp/resolv.*
root@OpenWrt:~# uci export network; uci export wireless; \
> uci export dhcp; uci export firewall; \
> head -n -0 /etc/firewall.user; \
> ip -4 addr ; ip -4 ro li tab all ; ip -4 ru; \
> ip -6 addr ; ip -6 ro li tab all ; ip -6 ru; \
> ls -l /etc/resolv.* /tmp/resolv.*; head -n -0 /etc/resolv.* /tmp/resolv.*
package network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd05:c8c9:2e51::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '10.0.0.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth1'
        option proto 'static'
        option ipaddr '192.168.1.2'
        option netmask '255.255.255.0'
        option gateway '192.168.1.1'
        option ipv6 'auto'
        option peerdns '0'
        option dns '8.8.8.8 8.8.4.4'

package wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'platform/soc/fe300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
        option htmode 'VHT80'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'
        option disabled '1'

package dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

package firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

# This file is interpreted as shell script.
# Put your custom iptables rules here, they will
# be executed with each firewall (re-)start.

# Internal uci firewall chains are flushed and recreated on reload, so
# put custom rules into the root chains e.g. INPUT or FORWARD or into the
# special user chains, e.g. input_wan_rule or postrouting_lan_rule.
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
4: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
    inet 10.0.0.1/24 brd 10.0.0.255 scope global br-lan
       valid_lft forever preferred_lft forever
10.0.0.0/24 dev br-lan scope link  src 10.0.0.1 
broadcast 10.0.0.0 dev br-lan table local scope link  src 10.0.0.1 
local 10.0.0.1 dev br-lan table local scope host  src 10.0.0.1 
broadcast 10.0.0.255 dev br-lan table local scope link  src 10.0.0.1 
broadcast 127.0.0.0 dev lo table local scope link  src 127.0.0.1 
local 127.0.0.0/8 dev lo table local scope host  src 127.0.0.1 
local 127.0.0.1 dev lo table local scope host  src 127.0.0.1 
broadcast 127.255.255.255 dev lo table local scope link  src 127.0.0.1 
0:      from all lookup local 
32766:  from all lookup main 
32767:  from all lookup default 
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1000
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
4: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 fd05:c8c9:2e51::1/60 scope global 
       valid_lft forever preferred_lft forever
    inet6 fe80::dea6:32ff:fe59:93f/64 scope link 
       valid_lft forever preferred_lft forever
fd05:c8c9:2e51::/64 dev br-lan  metric 1024 
unreachable fd05:c8c9:2e51::/48 dev lo  metric 2147483647 
fe80::/64 dev br-lan  metric 256 
local ::1 dev lo table local  metric 0 
anycast fd05:c8c9:2e51:: dev br-lan table local  metric 0 
local fd05:c8c9:2e51::1 dev br-lan table local  metric 0 
anycast fe80:: dev br-lan table local  metric 0 
local fe80::dea6:32ff:fe59:93f dev br-lan table local  metric 0 
ff00::/8 dev br-lan table local  metric 256 
0:      from all lookup local 
32766:  from all lookup main 
4200000001:     from all iif lo lookup unspec 12
4200000004:     from all iif br-lan lookup unspec 12
lrwxrwxrwx    1 root     root            16 Feb 13 20:35 /etc/resolv.conf -> /tmp/resolv.conf
-rw-r--r--    1 root     root            32 May 28 23:47 /tmp/resolv.conf

/tmp/resolv.conf.d:
-rw-r--r--    1 root     root             0 May 28 23:46 resolv.conf.auto
==> /etc/resolv.conf <==
search lan
nameserver 127.0.0.1

==> /tmp/resolv.conf <==
search lan
nameserver 127.0.0.1

==> /tmp/resolv.conf.d <==
head: /tmp/resolv.conf.d: I/O error
root@OpenWrt:~# 

your eth1 ( wan ) is not plugged in

1 Like

I plugged in my switch to the Ethernet port of the Pi, and I plugged the Pi to a LAN port of my ISP router using the Pi's USB port using a USB-Ethernet dongle. I then configured the Pi accordingly, set up DMZ on my ISP router to the Pi, and disabled DHCP and Wi-Fi on the ISP router. Is that not how it's supposed to be done?

ifconfig eth1

As you mentioned, yes. But how could I fix it? What is wrong with my setup?


@trendy I need to wait 6 hours before I can reply, for some reason. So I edited this post.

I'm trying to set up my Pi as a router by putting it behind my ISP router, like this:


Assume that there is a modem between the ISP router and Internet.

The "Home Router" is the Pi. The Pi is connected to the switch by the Pi's Ethernet port. The Pi is is also connected to a LAN port of the ISP router using the Pi's USB port using an Ethernet-USB dongle.

You have not explained what are you trying to achieve, so it is hard to answer you.

  1. have you installed the correct kmod driver for your USB ethernet? try

ifconfig eth1
and post the result here

  1. after the driver installed, add the usb lan interfaces in LuCI to WAN and WAN6 (if needed).
root@OpenWrt:~# opkg list-installed | grep kmod-usb-net-rtl8152
kmod-usb-net-rtl8152 - 4.19.101-1
root@OpenWrt:~# ifconfig eth1
ifconfig: eth1: error fetching interface information: Device not found
root@OpenWrt:~#

in the LuCi menu -> network -> interfaces, have you tried "add new interfaces" for wan?

This was already here:

What's the output when you run opkg list-installed | grep kmod-usb

I already posted the output for kmod-usb-net-rtl8152, but in case you need the output for all of them:

root@OpenWrt:~# opkg list-installed | grep kmod-usb
kmod-usb-core - 4.19.101-1
kmod-usb-hid - 4.19.101-1
kmod-usb-net - 4.19.101-1
kmod-usb-net-rtl8152 - 4.19.101-1
root@OpenWrt:~#

maybe the error is in the usb to ethernet device... is the device working on pc / laptop? I have similar RTL-8153 USB 3.0 to Gigabit LAN (use the same kmod-usb-net-rtl8512 driver) on my raspberry pi and it's worked so far the last time I've tried.

what's the dmesg output for the usb device?

The dongle lights up when it detects throughput, so I'm pretty sure it's working fine.

dmesg:


root@OpenWrt:~# dmesg
[    0.000000] Booting Linux on physical CPU 0x0000000000 [0x410fd083]
[    0.000000] Linux version 4.19.101 (builder@buildhost) (gcc version 8.3.0 (OpenWrt GCC 8.3.0 r12230-5715b21f80)) #0 SMP Thu Feb 13 20:35:13 2020
[    0.000000] Machine model: Raspberry Pi 4 Model B Rev 1.2
[    0.000000] cma: Reserved 64 MiB at 0x0000000037400000
[    0.000000] On node 0 totalpages: 1012736
[    0.000000]   DMA32 zone: 3792 pages used for memmap
[    0.000000]   DMA32 zone: 0 pages reserved
[    0.000000]   DMA32 zone: 242688 pages, LIFO batch:63
[    0.000000]   Normal zone: 12032 pages used for memmap
[    0.000000]   Normal zone: 770048 pages, LIFO batch:63
[    0.000000] random: get_random_bytes called from start_kernel+0x8c/0x390 with crng_init=0
[    0.000000] percpu: Embedded 20 pages/cpu s44056 r8192 d29672 u81920
[    0.000000] pcpu-alloc: s44056 r8192 d29672 u81920 alloc=20*4096
[    0.000000] pcpu-alloc: [0] 0 [0] 1 [0] 2 [0] 3 
[    0.000000] Detected PIPT I-cache on CPU0
[    0.000000] ARM_SMCCC_ARCH_WORKAROUND_1 missing from firmware
[    0.000000] CPU features: enabling workaround for EL2 vector hardening
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 996912
[    0.000000] Kernel command line: coherent_pool=1M 8250.nr_uarts=1 cma=64M bcm2708_fb.fbwidth=0 bcm2708_fb.fbheight=0 bcm2708_fb.fbswap=1 smsc95xx.macaddr=DC:A6:32:59:09:3F vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000  console=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=squashfs,ext4 rootwait
[    0.000000] Dentry cache hash table entries: 524288 (order: 10, 4194304 bytes)
[    0.000000] Inode-cache hash table entries: 262144 (order: 9, 2097152 bytes)
[    0.000000] software IO TLB: mapped [mem 0x333ff000-0x373ff000] (64MB)
[    0.000000] Memory: 3838040K/4050944K available (5950K kernel code, 406K rwdata, 1648K rodata, 320K init, 490K bss, 147368K reserved, 65536K cma-reserved)
[    0.000000] SLUB: HWalign=64, Order=0-3, MinObjects=0, CPUs=4, Nodes=1
[    0.000000] rcu: Hierarchical RCU implementation.
[    0.000000] rcu:     CONFIG_RCU_FANOUT set to non-default value of 32.
[    0.000000] NR_IRQS: 64, nr_irqs: 64, preallocated irqs: 0
[    0.000000] GIC: Using split EOI/Deactivate mode
[    0.000000] arch_timer: cp15 timer(s) running at 54.00MHz (phys).
[    0.000000] clocksource: arch_sys_counter: mask: 0xffffffffffffff max_cycles: 0xc743ce346, max_idle_ns: 440795203123 ns
[    0.000006] sched_clock: 56 bits at 54MHz, resolution 18ns, wraps every 4398046511102ns
[    0.000162] Console: colour dummy device 80x25
[    0.000374] console [tty1] enabled
[    0.000405] Calibrating delay loop (skipped), value calculated using timer frequency.. 108.00 BogoMIPS (lpj=540000)
[    0.000427] pid_max: default: 32768 minimum: 301
[    0.000585] Mount-cache hash table entries: 8192 (order: 4, 65536 bytes)
[    0.000649] Mountpoint-cache hash table entries: 8192 (order: 4, 65536 bytes)
[    0.001892] ASID allocator initialised with 32768 entries
[    0.001985] rcu: Hierarchical SRCU implementation.
[    0.002719] smp: Bringing up secondary CPUs ...
[    0.003091] Detected PIPT I-cache on CPU1
[    0.003146] CPU1: Booted secondary processor 0x0000000001 [0x410fd083]
[    0.003591] Detected PIPT I-cache on CPU2
[    0.003629] CPU2: Booted secondary processor 0x0000000002 [0x410fd083]
[    0.004049] Detected PIPT I-cache on CPU3
[    0.004085] CPU3: Booted secondary processor 0x0000000003 [0x410fd083]
[    0.004165] smp: Brought up 1 node, 4 CPUs
[    0.004225] SMP: Total of 4 processors activated.
[    0.004240] CPU features: detected: 32-bit EL0 Support
[    0.004286] CPU features: emulated: Privileged Access Never (PAN) using TTBR0_EL1 switching
[    0.004304] CPU: All CPU(s) started at EL2
[    0.004330] alternatives: patching kernel code
[    0.011024] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.011064] futex hash table entries: 1024 (order: 4, 65536 bytes)
[    0.012812] pinctrl core: initialized pinctrl subsystem
[    0.013644] NET: Registered protocol family 16
[    0.014562] cpuidle: using governor ladder
[    0.014595] cpuidle: using governor menu
[    0.016369] DMA: preallocated 1024 KiB pool for atomic allocations
[    0.016449] Serial: AMBA PL011 UART driver
[    0.018187] bcm2835-mbox fe00b880.mailbox: mailbox enabled
[    0.029981] raspberrypi-firmware soc:firmware: Attached to firmware from 2020-01-30 13:50, variant start
[    0.039996] raspberrypi-firmware soc:firmware: Firmware hash is 8f792e011c8a0ea3c5d47e7cc10172cc10b93c09
[    0.068148] bcm2835-dma fe007000.dma: DMA legacy API manager at (____ptrval____), dmachans=0x1
[    0.069962] SCSI subsystem initialized
[    0.070154] usbcore: registered new interface driver usbfs
[    0.070197] usbcore: registered new interface driver hub
[    0.070260] usbcore: registered new device driver usb
[    0.071108] clocksource: Switched to clocksource arch_sys_counter
[    0.074503] NET: Registered protocol family 2
[    0.075047] tcp_listen_portaddr_hash hash table entries: 2048 (order: 3, 32768 bytes)
[    0.075104] TCP established hash table entries: 32768 (order: 6, 262144 bytes)
[    0.075313] TCP bind hash table entries: 32768 (order: 7, 524288 bytes)
[    0.075859] TCP: Hash tables configured (established 32768 bind 32768)
[    0.076057] UDP hash table entries: 2048 (order: 4, 65536 bytes)
[    0.076123] UDP-Lite hash table entries: 2048 (order: 4, 65536 bytes)
[    0.076338] NET: Registered protocol family 1
[    0.076375] PCI: CLS 0 bytes, default 64
[    0.077452] Crashlog allocated RAM at address 0x3f00000
[    0.077609] workingset: timestamp_bits=46 max_order=20 bucket_order=0
[    0.081370] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.082962] io scheduler noop registered
[    0.082981] io scheduler deadline registered
[    0.083074] io scheduler cfq registered (default)
[    0.114838] brcm-pcie fd500000.pcie: dmabounce: initialised - 32768 kB, threshold 0x00000000c0000000
[    0.114878] brcm-pcie fd500000.pcie: could not get clock
[    0.114928] brcm-pcie fd500000.pcie: host bridge /scb/pcie@7d500000 ranges:
[    0.114964] brcm-pcie fd500000.pcie:   MEM 0x600000000..0x603ffffff -> 0xf8000000
[    0.171121] brcm-pcie fd500000.pcie: link up, 5.0 Gbps x1 (!SSC)
[    0.171317] brcm-pcie fd500000.pcie: PCI host bridge to bus 0000:00
[    0.171338] pci_bus 0000:00: root bus resource [bus 00-01]
[    0.171356] pci_bus 0000:00: root bus resource [mem 0x600000000-0x603ffffff] (bus address [0xf8000000-0xfbffffff])
[    0.171400] pci 0000:00:00.0: [14e4:2711] type 01 class 0x060400
[    0.171474] pci 0000:00:00.0: PME# supported from D0 D3hot
[    0.174091] pci 0000:00:00.0: bridge configuration invalid ([bus 00-00]), reconfiguring
[    0.174246] pci 0000:01:00.0: [1106:3483] type 00 class 0x0c0330
[    0.174336] pci 0000:01:00.0: reg 0x10: [mem 0x00000000-0x00000fff 64bit]
[    0.174530] pci 0000:01:00.0: PME# supported from D0 D3cold
[    0.177045] pci_bus 0000:01: busn_res: [bus 01] end is updated to 01
[    0.177079] pci 0000:00:00.0: BAR 8: assigned [mem 0x600000000-0x6000fffff]
[    0.177103] pci 0000:01:00.0: BAR 0: assigned [mem 0x600000000-0x600000fff 64bit]
[    0.177165] pci 0000:00:00.0: PCI bridge to [bus 01]
[    0.177182] pci 0000:00:00.0:   bridge window [mem 0x600000000-0x6000fffff]
[    0.177340] pcieport 0000:00:00.0: enabling device (0000 -> 0002)
[    0.177464] pcieport 0000:00:00.0: Signaling PME with IRQ 36
[    0.177575] pcieport 0000:00:00.0: AER enabled with IRQ 36
[    0.177694] pci 0000:01:00.0: enabling device (0000 -> 0002)
[    0.178129] bcm2708_fb soc:fb: Unable to determine number of FB's. Assuming 1
[    0.178149] bcm2708_fb soc:fb: FB found 1 display(s)
[    0.178513] raspberrypi-firmware soc:firmware: Request 0x00048003 returned status 0x80000001
[    0.178534] bcm2708_fb soc:fb: Failed to allocate GPU framebuffer (-22)
[    0.178563] bcm2708_fb soc:fb: probe failed, err -22
[    0.178586] bcm2708_fb: probe of soc:fb failed with error -22
[    0.179793] Serial: 8250/16550 driver, 1 ports, IRQ sharing enabled
[    0.180401] vc-mem: phys_addr:0x00000000 mem_base=0x3ec00000 mem_size:0x40000000(1024 MiB)
[    0.180741] gpiomem-bcm2835 fe200000.gpiomem: Initialised: Registers at 0xfe200000
[    0.180915] cacheinfo: Unable to detect cache hierarchy for CPU 0
[    0.186973] brd: module loaded
[    0.189989] loop: module loaded
[    0.191462] libphy: Fixed MDIO Bus: probed
[    0.191701] bcmgenet fd580000.genet: failed to get enet clock
[    0.191722] bcmgenet fd580000.genet: GENET 5.0 EPHY: 0x0000
[    0.191740] bcmgenet fd580000.genet: failed to get enet-wol clock
[    0.191756] bcmgenet fd580000.genet: failed to get enet-eee clock
[    0.191781] bcmgenet: Skipping UMAC reset
[    0.191919] unimac-mdio unimac-mdio.-19: DMA mask not set
[    0.211116] libphy: bcmgenet MII bus: probed
[    0.251497] unimac-mdio unimac-mdio.-19: Broadcom UniMAC MDIO bus at 0x(____ptrval____)
[    0.252333] xhci_hcd 0000:01:00.0: xHCI Host Controller
[    0.252366] xhci_hcd 0000:01:00.0: new USB bus registered, assigned bus number 1
[    0.257464] xhci_hcd 0000:01:00.0: hcc params 0x002841eb hci version 0x100 quirks 0x0000001000000890
[    0.257724] genirq: irq_chip Brcm_MSI did not update eff. affinity mask of irq 37
[    0.258214] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 4.19
[    0.258237] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    0.258255] usb usb1: Product: xHCI Host Controller
[    0.258269] usb usb1: Manufacturer: Linux 4.19.101 xhci-hcd
[    0.258283] usb usb1: SerialNumber: 0000:01:00.0
[    0.258589] hub 1-0:1.0: USB hub found
[    0.258661] hub 1-0:1.0: 1 port detected
[    0.259014] xhci_hcd 0000:01:00.0: xHCI Host Controller
[    0.259038] xhci_hcd 0000:01:00.0: new USB bus registered, assigned bus number 2
[    0.259063] xhci_hcd 0000:01:00.0: Host supports USB 3.0 SuperSpeed
[    0.259317] usb usb2: New USB device found, idVendor=1d6b, idProduct=0003, bcdDevice= 4.19
[    0.259338] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    0.259355] usb usb2: Product: xHCI Host Controller
[    0.259369] usb usb2: Manufacturer: Linux 4.19.101 xhci-hcd
[    0.259383] usb usb2: SerialNumber: 0000:01:00.0
[    0.259666] hub 2-0:1.0: USB hub found
[    0.259735] hub 2-0:1.0: 4 ports detected
[    0.260434] dwc_otg: version 3.00a 10-AUG-2012 (platform bus)
[    0.260521] dwc_otg: FIQ enabled
[    0.260526] dwc_otg: NAK holdoff enabled
[    0.260529] dwc_otg: FIQ split-transaction FSM enabled
[    0.260535] Module dwc_common_port init
[    0.260698] usbcore: registered new interface driver uas
[    0.260777] usbcore: registered new interface driver usb-storage
[    0.260846] mousedev: PS/2 mouse device common for all mice
[    0.261254] bcm2835-wdt bcm2835-wdt: Broadcom BCM2835 watchdog timer
[    0.262159] sdhci: Secure Digital Host Controller Interface driver
[    0.262174] sdhci: Copyright(c) Pierre Ossman
[    0.262425] mmc-bcm2835 fe300000.mmcnr: could not get clk, deferring probe
[    0.262621] Error: Driver 'sdhost-bcm2835' is already registered, aborting...
[    0.262635] sdhci-pltfm: SDHCI platform and OF driver helper
[    0.268593] vchiq: vchiq_init_state: slot_zero = (____ptrval____), is_master = 0
[    0.270063] NET: Registered protocol family 10
[    0.270449] Segment Routing with IPv6
[    0.270481] NET: Registered protocol family 17
[    0.270501] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    0.270509] 8021q: 802.1Q VLAN Support v1.8
[    0.272678] uart-pl011 fe201000.serial: cts_event_workaround enabled
[    0.272735] fe201000.serial: ttyAMA0 at MMIO 0xfe201000 (irq = 19, base_baud = 0) is a PL011 rev2
[    1.222355] console [ttyAMA0] enabled
[    1.229467] bcm2835-power bcm2835-power: Broadcom BCM2835 power domains driver
[    1.236854] brcmstb_thermal fd5d2200.thermal: registered AVS TMON of-sensor driver
[    1.244650] mmc-bcm2835 fe300000.mmcnr: mmc_debug:0 mmc_debug2:0
[    1.250650] mmc-bcm2835 fe300000.mmcnr: DMA channel allocated
[    1.281243] sdhci-iproc fe340000.emmc2: Linked as a consumer to regulator.3
[    1.288215] sdhci-iproc fe340000.emmc2: Linked as a consumer to regulator.4
[    1.310970] mmc1: queuing unknown CIS tuple 0x80 (2 bytes)
[    1.317990] mmc1: queuing unknown CIS tuple 0x80 (3 bytes)
[    1.324979] mmc1: queuing unknown CIS tuple 0x80 (3 bytes)
[    1.330484] mmc0: SDHCI controller on fe340000.emmc2 [fe340000.emmc2] using ADMA
[    1.338669] of_cfs_init
[    1.341169] of_cfs_init: OK
[    1.344508] Waiting for root device /dev/mmcblk0p2...
[    1.352016] mmc1: queuing unknown CIS tuple 0x80 (7 bytes)
[    1.358969] mmc1: queuing unknown CIS tuple 0x80 (3 bytes)
[    1.371108] usb 1-1: new high-speed USB device number 2 using xhci_hcd
[    1.410977] random: fast init done
[    1.466828] mmc0: new ultra high speed DDR50 SDHC card at address 59b4
[    1.473787] mmcblk0: mmc0:59b4 5cMJR 29.9 GiB
[    1.478847]  mmcblk0: p1 p2
[    1.482933] mmc1: new high speed SDIO card at address 0001
[    1.498866] EXT4-fs (mmcblk0p2): mounted filesystem without journal. Opts: (null)
[    1.506393] VFS: Mounted root (ext4 filesystem) readonly on device 179:2.
[    1.513408] Freeing unused kernel memory: 320K
[    1.553747] usb 1-1: New USB device found, idVendor=2109, idProduct=3431, bcdDevice= 4.21
[    1.561289] Run /sbin/init as init process
[    1.561954] usb 1-1: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[    1.573179] usb 1-1: Product: USB2.0 Hub
[    1.578532] hub 1-1:1.0: USB hub found
[    1.582514] hub 1-1:1.0: 4 ports detected
[    1.628131] init: Console is alive
[    1.631689] init: - watchdog -
[    1.727618] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    1.737015] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    1.745870] init: - preinit -
[    1.797164] bcmgenet: Skipping UMAC reset
[    1.802452] bcmgenet fd580000.genet: configuring instance for external RGMII (no delay)
[    1.810830] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[    1.911132] usb 1-1.1: new full-speed USB device number 3 using xhci_hcd
[    2.045140] usb 1-1.1: New USB device found, idVendor=0fe6, idProduct=9700, bcdDevice= 1.01
[    2.053521] usb 1-1.1: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[    2.060837] usb 1-1.1: Product: USB 2.0 10/100M Ethernet Adaptor
[    2.067960] random: procd: uninitialized urandom read (4 bytes read)
[    2.881223] bcmgenet fd580000.genet eth0: Link is Down
[    4.951269] bcmgenet fd580000.genet eth0: Link is Up - 100Mbps/Full - flow control off
[    4.959274] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[    5.863421] mount_root: mounting /dev/root
[    5.867946] EXT4-fs (mmcblk0p2): warning: mounting unchecked fs, running e2fsck is recommended
[    5.878633] EXT4-fs (mmcblk0p2): re-mounted. Opts: (null)
[    5.900588] FAT-fs (mmcblk0p1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.
[    5.911130] urandom-seed: Seeding with /etc/urandom.seed
[    5.946572] procd: - early -
[    5.949509] procd: - watchdog -
[    6.560910] procd: - watchdog -
[    6.564279] procd: - ubus -
[    6.571682] random: ubusd: uninitialized urandom read (4 bytes read)
[    6.617789] random: ubusd: uninitialized urandom read (4 bytes read)
[    6.624354] random: ubusd: uninitialized urandom read (4 bytes read)
[    6.631357] procd: - init -
[    6.635125] uart-pl011 fe201000.serial: no DMA platform data
[    6.728237] kmodloader: loading kernel modules from /etc/modules.d/*
[    6.740791] urngd: v1.0.2 started.
[    6.756303] hidraw: raw HID events driver (C) Jiri Kosina
[    6.760635] random: crng init done
[    6.762298] snd_bcm2835: module is from the staging directory, the quality is unknown, you have been warned.
[    6.765183] random: 6 urandom warning(s) missed due to ratelimiting
[    6.787344] Loading modules backported from Linux version v5.4-rc8-0-gaf42d3466bdc
[    6.795013] Backport generated by backports.git v5.4-rc8-1-0-g368e8c51
[    6.804985] usbcore: registered new interface driver r8152
[    6.811682] usbcore: registered new interface driver usbhid
[    6.817251] usbhid: USB HID core driver
[    6.823701] xt_time: kernel timezone is -0000
[    6.848203] PPP generic driver version 2.4.2
[    6.852946] NET: Registered protocol family 24
[    6.873930] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[    7.039553] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac43455-sdio for chip BCM4345/6
[    7.057839] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4345/6 wl0: Nov 13 2019 04:39:05 version 7.45.198 (r723338 CY) FWID 01-369a6798
[    7.099192] usbcore: registered new interface driver brcmfmac
[    7.107633] kmodloader: done loading kernel modules from /etc/modules.d/*
[    7.992627] bcmgenet: Skipping UMAC reset
[    7.998681] bcmgenet fd580000.genet: configuring instance for external RGMII (no delay)
[    8.007044] br-lan: port 1(eth0) entered blocking state
[    8.012334] br-lan: port 1(eth0) entered disabled state
[    8.017714] device eth0 entered promiscuous mode
[    8.023136] br-lan: port 1(eth0) entered blocking state
[    8.028382] br-lan: port 1(eth0) entered forwarding state
[    8.101664] br-lan: port 1(eth0) entered disabled state
[    9.031312] bcmgenet fd580000.genet eth0: Link is Up - 100Mbps/Full - flow control off
[    9.039900] br-lan: port 1(eth0) entered blocking state
[    9.045160] br-lan: port 1(eth0) entered forwarding state
[ 1379.225174] br-lan: port 1(eth0) entered disabled state
[ 1379.234245] device eth0 left promiscuous mode
[ 1379.238623] br-lan: port 1(eth0) entered disabled state
[ 1379.320264] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 1380.760119] bcmgenet: Skipping UMAC reset
[ 1380.765331] bcmgenet fd580000.genet: configuring instance for external RGMII (no delay)
[ 1380.773567] br-lan: port 1(eth0) entered blocking state
[ 1380.778794] br-lan: port 1(eth0) entered disabled state
[ 1380.784180] device eth0 entered promiscuous mode
[ 1380.789398] br-lan: port 1(eth0) entered blocking state
[ 1380.794647] br-lan: port 1(eth0) entered forwarding state
[ 1380.800142] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[ 1381.831387] bcmgenet fd580000.genet eth0: Link is Up - 100Mbps/Full - flow control off
[ 1381.831473] br-lan: port 1(eth0) entered disabled state
[ 1381.844810] br-lan: port 1(eth0) entered blocking state
[ 1381.850033] br-lan: port 1(eth0) entered forwarding state
[ 1381.855564] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready
root@OpenWrt:~# 

had to find out which chipset my adapter is using and install the appropriate kernel module

Similar problem here seems to indicate hardware problem, either

  • not enough power supply
  • faulty cable or port in switch / router
  • faulty usb to lan adapter
    which need to be tested for each case, maybe try plugging it in laptop / pc first, change the pi adaptor with higher amps, or try the pi using another OS and similar adapter.
1 Like

There is no sign of eth1 in the whole dmesg. Chances are it never got detected.

Do an lsusb to verify the chipset of the ethernet adapter.

I guess I spoke too soon, I also encounter similar problem after testing my USB LAN on raspberry pi 4 (May 30 snapshot). After several minutes got error message link down on system logs and "device not ready" on LuCI, gonna try the USB Ethernet on other box first to confirm the error.

Edit : Found the Problem! ,after testing the usb to ethernet LAN in windows 10 laptop, the same problem also occured and after much searching realtek RTL8152 / RTL8153 r (both linux and windows) have problem with USB autosuspend features, usually involved when using USB 3.0 port (since this is gigabit adapter) and having lot activities in the adapter (high download or upload makes adapter dissapearing and reappearing).
The solution given was to disable the USB autosuspend features in windows device manager, since then the problem reduced altough not missing completely. Then I try installing the latest driver from realtek (2020) and problem gone.

Now the problem is how to get the latest driver (realtek has new 2020 linux driver for the chipset) into openwrt... , so maybe OP has similar problem with said USB to LAN Adapter.