Unable to connect to most websites. Can only connect to google, yahoo, and openwrt.org

I installed Open Wrt on my Netgear R6350 using openwrt-19.07.7-ramips-mt7621-netgear_r6350-squashfs-factory.img. Everything was working before but now I am experiencing problems.

I thought that I was experiencing DNS issues, but now I am not so sure. I can connect to the following websites: gooogle , yahoo , facebook, youtube, and openwrt.org (so basically all of the big name sites).

I am unable to connect to most other websites including but not limited to duckduckgo.com, chase , xfinity , microsoft, citi., twitter, and reddit. The message I get is "The connection has timed out The server at www.reddit.com is taking too long to respond."
So not exactly an http error.

Yes, I have tried in multiple browsers including chrome, firefox, and icecat. I have also tested in links, elinks, and lynx.
Yes, I have tried private browsing or incognito mode.
Yes, I have checked firewall configuration.

Here is where things get weird and why I do not think it is a dns problem. I can ping the above mentioned sites that do work in luci.

PING openwrt.org ( 56 data bytes
64 bytes from seq=0 ttl=44 time=113.669 ms
64 bytes from seq=1 ttl=44 time=113.524 ms
64 bytes from seq=2 ttl=44 time=113.467 ms
64 bytes from seq=3 ttl=44 time=113.948 ms
64 bytes from seq=4 ttl=44 time=113.474 ms

But when I try to ping chase.com from the openwrt router, it fails, however the ip address shows up, so, therefore I believe the DNS is working.

PING chase.com **(**: 56 data bytes

--- chase.com ping statistics ---
5 packets transmitted, 0 packets received, 100% packet loss

I have added my isp dns hosts along with google and cloudflaire to /tmp/resolv.conf.auto.
I have also added dns hosts to the interfaces and none of that worked.

When I run the google speed test, I get 78.7 Mbps download.

Does anyone know why I cannot reach most internet sites. How can I solve this problem?
I would deeply appreciate any help or advice on this as this problem is quite weird and unique.

The working set of domains all have in common that they're also available via IPv6, while I haven't checked all domains of your non-working bin, those seem to be IPv4-only…
While this would hint at potential issues with your IPv4 connectivity, your ping trace suggests that to be working.

Just to be sure, I'd do a another factory reset (firstboot) before debugging much further.


It does look like you are on to something. However, I found an anomaly. While I cannot visit reddit.com from any browser but I can ping it from the openwrt router despite it having no IPv6.



Name:      reddit.com
Address 1:
Address 2:
Address 3:
Address 4:
*** Can't find reddit.com: No answer

PING reddit.com ( 56 data bytes
64 bytes from seq=0 ttl=58 time=8.715 ms
64 bytes from seq=1 ttl=58 time=9.022 ms
64 bytes from seq=2 ttl=58 time=8.453 ms
64 bytes from seq=3 ttl=58 time=8.549 ms
64 bytes from seq=4 ttl=58 time=10.747 ms

--- reddit.com ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 8.453/9.097/10.747 ms

it does look like I am only given a public ipv6 address. I am not given an ipv4 address and I cannot connect to ipv4 websites. Does anyone know how to correct this?

  • Only given by your ISP to the router (as seen on the "Upstream" section of the web managment Status page)?
  • Or only given internally from router to PC / device?

Your text makes it seem like to mean the first of these - but worth checking :).


Thank you for your response, Ian. I am new to networking so I am confused by the fact that the hosts on my network get internal/private IPv4 addresses (192.168.1.**) AND IPv6 addresses.

But when I go to google and type in "what is my ip address?", I get an IPv6 address.

As for the openwrt router. It seems to only get internal IPv4 address.

root@OpenWrt:~# ifconfig -a | grep 'inet ' 
          inet addr:  Bcast:  Mask:
          inet addr:  Mask:

Do you see wan and wan6 interfaces in ifconfig, or on the LUCI Network->Interfaces page? I have wan using PPPoE for IPv4, but you might need to connect to your ISP a different way.

This is normal, If you have both a IPv4 and a IPv6 most sites only show the IPv6 address they started doing this a couple of years ago.

You might have better luck finding your IPv4 by searching Google for "whats my ipv4 address"