Unable to connect to LTE network

My LTE interface suddenly stopped working and I'm not sure what might be wrong.

Here are my log messages


Wed Jun 12 20:11:03 2024 daemon.notice netifd: Interface 'wan_lte' is setting up now
Wed Jun 12 20:11:03 2024 daemon.notice netifd: wan_lte (2528): Waiting for SIM initialization
Wed Jun 12 20:11:04 2024 daemon.warn odhcpd[2289]: No default route present, overriding ra_lifetime!
Wed Jun 12 20:11:04 2024 daemon.notice netifd: wan_lte (2528): Failed to parse message data
Wed Jun 12 20:11:04 2024 daemon.notice netifd: wan_lte (2528): PIN already verified
Wed Jun 12 20:11:05 2024 daemon.notice netifd: wan_lte (2528): Device does not support 802.3 mode. Informing driver of raw-ip only for wwan0 ..
Wed Jun 12 20:11:05 2024 daemon.notice netifd: wan_lte (2528): Waiting for network registration

Does anyone have any ideas what might be wrong?

I'm using ZyXEL LTE5398-M904

Please show the interface configuration, no pictures please, just a fragment of your /etc/config/network

1 Like

here is my /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd2d:31a8:fd1e::/48'
	option packet_steering '1'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan2'

config interface 'wan_eth'
	option proto 'dhcp'
	option device 'lan1'
	option metric '10'

config interface 'wan_lte'
	option proto 'qmi'
	option device '/dev/cdc-wdm0'
	option apn 'telenor.fwa'
	option pincode 'xxxx'
	option auth 'none'
	option pdptype 'ipv4'
	option metric '20'

config interface 'lan'
	option proto 'static'
	option device 'br-lan'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'

config interface 'arlo'
	option proto 'static'
	option ipaddr '172.14.1.1'
	option netmask '255.255.255.0'
	option device 'br-arlo'

config device
	option type 'bridge'
	option name 'br-arlo'

Connect to the modem from a terminal like picocom and send the following commands:

AT+CEREG?
AT+CGDCONT?
AT+CGPADDR
AT+QENG="servingcell"

Show the result.

1 Like

here are the outputs


AT+CEREG?

+CEREG: 0,2

OK

AT+CGDCONT?

+CGDCONT: 1,"IPV4V6","telenor.fwa","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0

+CGDCONT: 2,"IPV4V6","ims","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0

+CGDCONT: 3,"IPV4V6","hos","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0

+CGDCONT: 4,"IPV4V6","sos","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,1

OK

AT+CGPADDR

+CGPADDR: 1,""

+CGPADDR: 2,""

+CGPADDR: 3,""

+CGPADDR: 4,""

OK

AT+QENG="servingcell"

+QENG: "servingcell","LIMSRV","LTE","FDD",242,01,321BD00,75,1450,3,5,5,81AE,-94,-12,-62,12,255,-50,-

OK

means

Not registered, but MT is currently trying to attach or searching an operator to
register to

and

means

UE is camping on a cell but has not registered on the network

Not sure why this happens... That is not related to OpenWrt as I see.
Did you have any customizations with bands, cell lock, etc?

Please check something else:

AT+GMR
AT+QCFG="band"
AT+QMBNCFG="List"
1 Like

I didn't do any changes to modem configuration, it just suddenly stopped connecting :frowning:

here are more responses

AT+GMR

EG18EAPAR01A08M4G

OK

AT+QCFG="band"

+QCFG: "band",0x8d0,0x1a0080800d5,0x0

OK

AT+QMBNCFG="List"

+QMBNCFG: "List",0,1,1,"Telenor_Norway_Commercial",0x08014300,201902181

+QMBNCFG: "List",1,0,0,"ROW_Commercial",0x0801080A,201904121

+QMBNCFG: "List",2,0,0,"ROW_Generic_3GPP_PTCRB_GCF",0x0801FE02,201910231

+QMBNCFG: "List",3,0,0,"Norway_Telia_Commercial",0x08012420,201906131

+QMBNCFG: "List",4,0,0,"Optus_Australia_Commercial",0x08014400,201812291

+QMBNCFG: "List",5,0,0,"Telstra_Australia_Commercial",0x08010F00,201908191

+QMBNCFG: "List",6,0,0,"TIM_Italy_Commercial",0x08012B00,201902181

+QMBNCFG: "List",7,0,0,"France-Commercial-Orange",0x08010B21,201906281

+QMBNCFG: "List",8,0,0,"UK-VoLTE-Vodafone",0x08010426,201908011

+QMBNCFG: "List",9,0,0,"Spain-Non_VoLTE-Telefonica",0x08010C20,201910291

+QMBNCFG: "List",10,0,0,"Telia_Sweden",0x08012400,201902251

OK

Definitely not the latest, I would upgrade.

Let's try to disable this automation:

AT+QMBNCFG="AutoSel",0
AT+QMBNCFG="Deactivate"
AT+CFUN=1,1

Modem will restart, give it a minute then re-check with AT+CEREG?, etc.

do you know how can I upgrade?

Here are the results after I run new commands:

AT+QMBNCFG="AutoSel",0
OK
AT+QMBNCFG="Deactivate"
OK
AT+CFUN=1,1
OK

FATAL: read zero bytes from port
term_exitfunc: reset failed for dev UNKNOWN: Not a tty
root@OpenWrt:~# picocom /dev/ttyUSB3
picocom v3.1

port is        : /dev/ttyUSB3
flowcontrol    : none
baudrate is    : 9600
parity is      : none
databits are   : 8
stopbits are   : 1
escape is      : C-a
local echo is  : no
noinit is      : no
noreset is     : no
hangup is      : no
nolock is      : no
send_cmd is    : sz -vv
receive_cmd is : rz -vv -E
imap is        : 
omap is        : 
emap is        : crcrlf,delbs,
logfile is     : none
initstring     : none
exit_after is  : not set
exit is        : no

Type [C-a] [C-h] to see available commands
Terminal ready
AT+CEREG?
+CEREG: 0,2

OK
AT+CGDCONT?
+CGDCONT: 1,"IPV4V6","","0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0",0,0,0,0

OK
AT+CGPADDR
+CGPADDR: 1,""

OK
AT+QENG="servingcell"
+QENG: "servingcell","LIMSRV","LTE","FDD",242,01,321BD03,108,6400,20,3,3,81AE,-75,-9,-49,15,0,-32768,-

OK

See in OpenWrt support for Zyxel LTE5398-M904

Regarding the registration issue, we will probably need help from someone with local knowledge.
@bmork, any idea?

Sorry, not really. There shouldn't be any magic involved, and no network changes that I know of which would affect registration. Does that SIM still work in other devices? Maybe the subscription was changed for some unknown reason?

I agree that disabling the automatic network config is a good idea anyway. I remember that solved some mysterious issues for me on the NR7101.

1 Like

I haven't verified whether SIM-card works in other devices, yet, but I didn't do any changes with my provider, and sim-card still shows as active and operational on their homepage.

I'll try get hold of a phone with physical SIM-slot and test it there.

Thanks for your help so far @AndrewZ @bmork

Try with "option pdptype 'ipv4v6'".

No need, the modem is already configured like that:

The issue is somewhere else :wink:

updating modem firmware solved the issue, wondering why

ati
Quectel
EG18
Revision: EG18EAPAR01A13M4G
1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.