Unable to connect or change firmware (WRT1200AC)

I have tried to revert to stock firmware on my Linksys WRT1200AC. I get the following error
The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

I have reset the router and pulled the power and network cables for 3 min. ( then plug back in) then go to the logon page enable the wifi with wpa2. after I enable the wifi I save and reboot. I have no connection to the web. I tried to ping and drops all packets. Any advice and help is greatly appreciated,


Currently, to go to something else from from LEDE you will have to scp over an image and ssh in to:

sysupgrade -F -n imagename

From ssh you could also run:


to reset things. Or you could reset to the other partition by this.

1 Like

Is there a guide i could follow to do that.

Here are instructions on how to change the boot partition. I have used this successfully to boot back into the stock WRT1200AC firmware. This allowed me to then upgrade the other partition again to a different version.


1 Like

To do what? All three things I described are on the wiki page I linked. But for scp I prefer this over putty, ymmv. In my own build I use this to control what partition I am on, or which I want to flash. Some like to stay with OEM on one of the partitions, but it is not necessary.

Edit: use /tmp


I tried to copy over the img file and I receive this error;
scp: /root/wrt1200ac.img: No space left on device

What do I do now?

You need to use /tmp/ not root to copy the file

sorry for the delay.
I have tried to scp firmware to /tmp and i get a no space error like i did on the root directory.
I have tried the reset button for 15 seconds and still am unable to flash any firmware except lede.bin only.
I have no internet connectivity on the wired side. I have enabled the wifi and no internet on the wireless.

Your router should be equipped with dual partitions, so when something goes bad, it boots on the second one. Each time you flash your router from one partition, it write on the other then trigger a reboot to that other partition. This allows you to roll-back if anything goes wrong.

If you are actually on LEDE, then it is possible to force a switch to the other boot partition that should contain your stock firmware using the "cut power trick", mentioned in anomeome's post.

Did you try it?

I tried to turn it off and on when the first light comes on then i turn it off and repeat 3 additional times . i did not have any luck on the reset.

Maybe that you've end up with LEDE on both partitions then. Can you post the output of the commands df and free please ?

If you have flashed the same LEDE image to both partitions it is going to look pretty much the same. I assume you can ssh in, if so run:

/usr/sbin/fw_printenv -n boot_part

and see what is reported, try the power switch and look again (1 || 2).

Bigger issue is why there is no space to scp an image over to /tmp, should be plenty of ram to hold one.

I'm in a similar situation (though on a 1900ACSv2):

I was able to flash a LEDE image onto one of the partitions, but I must have made some kind of configuration error because the partition became unbootable/not accessible over the network. I used the triple reset to switch over to the backup partition containing the manufacturer firmware (which works normally). I've read that there's a procedure which allows you to overwrite an unbootable alternative partition on a Linksys device using the bootable one, but the associated instructions weren't specific beyond needing to use the 'factory' image of LEDE.

Could someone in the know say if this is possible?


Both the OEM manufacturer firmware and LEDE/Openwrt always flash the other partition and then switch boot to that partition, so that the current one remains intact and serves as a fallback. That is the standard ops.

As you current run original Linksys firmware, if you now flash LEDE, it will automatically get installed to the alternative partition. (After the flash, your current partition will be the "alternative")