Unable to change IPv4 address using LuCI (solved)

Update: I initially could not find threads that described my problem. I suspected I was using the wrong keywords. I'm very new to this layer of technology. I wrote out the issue as a post here. I then checked out the "Your topic is similar to..." list that appears while I write this post. The 1st result contained the solution.

I'm writing a summary in case someone else faces the same problem. I'm also including the full description (which was my original post) after the break below.

Our problem: We can connect to the OpenWrt device's Web GUI. We cannot connect to the broader Internet.

Solution: The steps in this troubleshooting guide.

We had found the troubleshooting document independently. But we didn't follow the steps exactly. This led to the issue described after the break below.

To avoid the issue we faced initially, we clicked "Apply unchecked". Otherwise, the changes make us lose connection to the LuCI web GUI. (source: TP-LINK Archer C7 v5 LAN address change _ solved)

After the countdown, the message reads "Device unreacheable". At this point, we can't connect using the old IPv4 address or the new.

After this point, our notes are unclear. Either we powered off the device. Or not. But eventually, LuCI can be reached at the new IPv4 address.


Hi folks, we flashed OpenWrt (successfully) onto a TP-Link Archer AC1750 C7 v5. But there was no internet connectivity out of the box. That's fine! We expected some troubleshooting. But now we've hit a wall.

Before we describe the issue:

Yes, mucking about with the new device is how I'm spending an afternoon of what would traditionally be a holiday window for many :wink: So I want to emphasize, there is no urgency to this post´╝Źthe internet works fine with the existing setup. We're just taking the time to make progress on migrating from aging hardware. And hitting some snags.

Continuing with the description of the problem:

We can connect to the OpenWrt device's Web GUI. We cannot connect to the broader Internet.

We tried changing the LAN IPv4 address using LuCI. This failed.

We found this (https://openwrt.org/docs/guide-quick-start/troubleshooting_internetconnectivity) which described the problem accurately.

"you can connect to your OpenWrt router's Web GUI, but cannot connect to the broader Internet (say, www.google.com"

The address of WAN and LAN did start with the same three sets of numbers. We attempted to change the LAN address on the device. We followed the recommended steps in the troubleshooting URL above.

We attempted to save the configuration. This makes a 90 second countdown appear while the new IPv4 subnet is configured. A message appears, at the end of the countdown, saying the configuration attempt has failed. LuCI then attempts to rollback, which never completes.

At this point, we can't connect using the old IPv4 address or the new. We powered off the device to recover. LuCI can be reached at the old IPv4 address when the device is powered back on.

I can replicate the issue and attach a screenshot of the error modal, but I imagined that was a generic message.

Searching through the forum didn't surface a similar thread.
I could be using the wrong keywords, I'm very new to this layer of technology.

I'd be grateful for any leads to what could be a likely solution.

@yPD6aY6tZXXEne6s, welcome to the community!

If you hit "Apply Unchecked" - you also have to make sure that your client device obtains a new IP address in the new LAN subnet via DHCP.

Also, your post rambles and is hard to follow - especially when you:

  • titled it as "solved"; and
  • notes "update" - but it shows no edits

so I hope I covered your issue.

Just curious - who's "we"?

Thank you! :slight_smile: Glad to be here.

I did the migration to OpenWrt as a project with my partner. The router is critical home infrastructure, IMO. I didn't want to be the only person who can troubleshoot.

Thanks for the notes. I arrived here to update the original post to be what I think is more helpful. But I don't think I'm allowed to edit yet. I'll dig into it.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.