Unable to access the printer from the upper office LAN

My network environment is shown in the following image:
ζˆͺεœ– 2023-05-16 δΈ‹εˆ5.03.00

I have route settings correctly. (able to ping the printer, and SNMP works properly. captured using wireshark).
But when I send a document from PC1 to the printer, nothing happened. It seems to unable to get any responses from the printer.

Any idea how to make the printer work in this situation?

you have a double NAT setup
I think it would be better to make the openwrt router into a dump access point / switch
this would mean they are all on the network
you could keep the 2nd subnet but you need to make sure you are not using NAT
and add routing in the main router for the subnet return

Thanks for the reply.

Is it possible to make it work via setting either firewall or port forwarding?
I've tried several settings and none of them worked. Not quite sure if it was the settings were incorrect or if it is impossible to work in this kind of network environment.


maybe first try this from PC1/PC2

snmpwalk -v2c -c public
and open from web browser

this way we could see does PC1/PC2 could communicate with printer and which protocols working

1 Like

you have to know what you want 1st
is there a reason for 2 subnet's
do you need 192.168.1.x & 192.168.2.x ?

192.168.1.x is the office LAN without internet access. And 192.168.2.x is Openwrt which uses mobile phone hotspots.

ok I think you want the separation
in openwrt change the wan interface firewall setting to LAN
it should go green
on the office router add a static route for subnet 192.168.2.x
to what ever 192.168.1.x address is on the old wan interface of openwrt "do make this static"
now they should all able to ping and talk to each other
do note no broadcast data will cross subnets

what do you mean by changing the wan interface firewall settings to lan?

it's removing NAT and making the WAN interface part of the network lan with the other interfaces

  • The OP noted that they "have route settings correctly"
  • Another poster proceeded to say "you have a double NAT setup" and suggested a dumb AP config instead - from the OP's description it seems they had a routed setup, not double NAT
  • Both shouldn't be true

Can we see the configs (network and firewall) to verify - particularly the route you created for via lan src 192.168.1.x.

if i go look to the subnets:

Assuming uses as upstream wan.

I don't think a extra forward rule is needed as the default zone rule for lan does forward to wan anyway.

So i think you may have to play with the dhcp settings a little, im suspecting rebind protection discarding upstream local addresses or a similar setting in dhcp.

Could you show us the firewall configuration and dhcp?

Finally, I got the printer to work. And yes, you are right about the routing.
It is weird I added V4 static route in Openwrt which was assigned from the office LAN ( But with this route, the ack packets were unable to send/receive correctly.
Anyhow, with the correct routing table (removed the route I added), everything works fine.

Really thanks for all your help.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.