Unable to access some sites

I've been using OpenWRT on my ASUS RT51U for a while now, but all of the sudden some essential sites for work refuse to load.
I can remotely connect to my rig at work where the site loads just fine, and connecting my homePC to the wall directly (leaving out the router) works too. But with the router in-between, ever since I had trouble logging into this site at home, it now just returns a timeout error everytime.

So far Ive tried to hard-reset the router (and re-set only the SSIDs and wifi passwords). Disabling the firewall in Startup (which somehow completely disabled any traffic through it).

Did you check the OpenWrt logs? Maybe there might be some debugging possible on dnsmasq (which handles DNS by default)?

If the sites are resolving without your router in between then it sounds very much like DNS.

Im not entirely familiar with all the dnsmasq options. Changing a DNS from google's to cloudfare didn't seem to change anything.
I dont have a hostfile or any domains set up to be blocked and left the dnsmasq untouched from default.

Under diagnostics, the URL seemed to ping just fine and but I'm not entirely sure how to interpret the traceroute:

traceroute to www.visualizeyourscience.com (, 30 hops max, 38 byte packets
 1  0.960 ms
 2  1.520 ms
 3  1.420 ms
 4  1.860 ms
 5  2.220 ms
 6  2.520 ms
 7  10.060 ms
 8  16.560 ms
 9  23.780 ms
10  28.460 ms
11  26.660 ms
12  25.660 ms

What would you suggest to try regarding dnsmasq?

You can log queries by adding logqueries to the configuration.

Where did you set the DNS? To me it seems like you have it for the router but not for the clients.

Try setting it for the LAN interface and see what happens.

I have the DNS ( and set in the LAN interface. But I find it odd that this would do anything.
The site started timing out after trying to log in.

Im not entirely sure how to add that. I'm using the LuCi version.

*EDIT: Seems this issue was resolved on the server's side. Apparently having them reset my account allowed me to load the site again. Not quite sure how any of that worked, but thank you for helping me out!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.