Unable to access 192.168.1.1

Hello,

I managed to install OpenWrt on my TP-Link MR6400 v1, however I can't access to the router using 192.168.1.1 through my web browser. I'm on Windows 10.

I can access the LTE module through http://192.168.0.1/login.html.

I can connect to 192.168.1.1 in SSH, but can not move to directories as I receive the message "Permission denied".

Could someone please help?

Edit : CMD ping works on 192.168.1.1 :
Pinging 192.168.1.1 with 32 bytes of data:
Reply from 192.168.1.1: bytes=32 time<1ms TTL=64
Reply from 192.168.1.1: bytes=32 time=4ms TTL=64
Reply from 192.168.1.1: bytes=32 time<1ms TTL=64
Reply from 192.168.1.1: bytes=32 time<1ms TTL=64

Ping statistics for 192.168.1.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 4ms, Average = 1ms

When you log in with SSH, do you see several lines of OpenWrt banner?

This is what I get. As you can see, I changed the password.

Windows PowerShell
Copyright (C) Microsoft Corporation. All rights reserved.

PS C:\Users\Guillaume> ssh root@192.168.1.1
root@192.168.1.1's password:


BusyBox v1.31.0 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt SNAPSHOT, r10250-016d1eb
 -----------------------------------------------------

Also in the meantime, I tried the commands opkg update and opkg install luci. Since then, going to 192.168.1.1 shows :

/usr/lib/lua/luci/dispatcher.lua:247: /etc/config/luci seems to be corrupt, unable to find section 'main'
stack traceback:
	[C]: in function 'assert'
	/usr/lib/lua/luci/dispatcher.lua:247: in function 'dispatch'
	/usr/lib/lua/luci/dispatcher.lua:144: in function </usr/lib/lua/luci/dispatcher.lua:143>

Probably won't solve it, but it wouldn't harm--did you try logging in using PuTTy?

I just tried, but still have the "Permission denied" message.

Are you saying that a command like cd /etc/config does not work? And what is the exact error message?

An 18.06.4 build exists for the MR6400, you should use that instead of snapshots.

Oh I did not know I had to use a command to access it. (I have absolutely no experience in networking, so I discovered SSH through my searches to get the router web UI).

I used http://downloads.openwrt.org/snapshots/targets/ar71xx/generic/openwrt-ar71xx-generic-tl-mr6400-v1-squashfs-factory.bin linked here https://openwrt.org/toh/tp-link/tp-link_tl-mr6400_v1.0 to get the firmware.
I did not realize it was a snapshot. I will try to flash the router again with http://downloads.openwrt.org/releases/18.06.4/targets/ar71xx/generic/openwrt-18.06.4-ar71xx-generic-tl-mr6400-v1-squashfs-factory.bin and report back here.

When you flash again, use the sysupgrade version.

To upgrade a router that is connected to the Internet, I go to the download page on the PC web browser, and right click the sysupgrade file to choose "copy link location". Then on the router type sysupgrade and a space and paste the URL onto the command line. Use the arrow key to go back and change https to http then execute the command. This will download and install in one operation.

If you've changed settings and possibly broken something, do sysupgrade -n instead this will give you a clean new install. Then you need to re-configure the router from scratch.

4 Likes

Thanks for mentioning this. I have updated the datatable now from snapshot to stable release.

3 Likes

Thank you very much, it appears the snapshot was the cause. I flashed my router again with the stable release, which fixed it, and only then did I see your message about the sysupgrade command. Upon using it, the router and 192.168.1.1 still work like a charm.

1 Like

You installed snapshot version which does not have luci web interface by default. You should either reinstall a stable version, or install luci in snapshots using opkg.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.