I tried to install the Umurmur server .. but it seems not to start, the client does not connect ... you can tell me if this version of openwrt supports Umurmur
Thank you very much
It appears to exist in OpenWrt, therefore it's supported: https://openwrt.org/docs/guide-user/services/voip/umurmur
Did you enable it in the configs?
Thanks for your answer
lleachii
I followed that guide ... but nothing, I'll show you my configuration (Very trivial)
/etc/config/firewall
config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option network 'lan'
option masq '1'
option mtu_fix '1'
config include
option path '/etc/firewall.user'
config zone
option name 'mesh'
option input 'ACCEPT'
option output 'ACCEPT'
option network 'mesh'
option forward 'ACCEPT'
option masq '1'
option mtu_fix '1'
config forwarding
option dest 'mesh'
option src 'lan'
config forwarding
option dest 'lan'
option src 'mesh'
/etc/umurmur.conf
max_bandwidth = 48000;
welcometext = "Welcome to uMurmur!";
certificate = "/etc/umurmur/cert.crt";
private_key = "/etc/umurmur/key.key";
password = "";
# admin_password = "test"; # Set to enable admin functionality.
# ban_length = 0; # Length in seconds for a ban. Default is 0. 0 = forever.
# enable_ban = false; # Default is false
# banfile = "banfile.txt"; # File to save bans to. Default is to not save bans to file.
# sync_banfile = false; # Keep banfile synced. Default is false, which means it is saved to at shutdown only.
# allow_textmessage = true; # Default is true
max_users = 10;
bindport = 64738;
bindaddr = "INADDR_ANY";
# bindport6 = 64738;
# bindaddr6 = "INADDR_ANY";
# bindport6 (64738)
# username and groupname for privilege dropping.
# Will attempt to switch user if set.
# username = "";
# If groupname not set the user's default login group will be used
# groupname = "";
# Log to file option. Default is logging to syslog.
# umurmurd will close and reopen the logfile if SIGHUP is received.
# logfile = "/var/log/umurmurd.log";
# Channel tree definition:
# Root channel must always be defined first.
# If a channel has a parent, the parent must be defined before the child channel(s).
channels = ( {
name = "Root";
parent = "";
description = "Root channel. No entry.";
noenter = true;
},
{
name = "Lobby";
parent = "Root";
description = "Lobby channel";
},
{
name = "Red team";
parent = "Lobby";
description = "The Red team channel";
# password = "redpw";
},
{
name = "Blue team";
parent = "Lobby";
description = "The Blue team channel";
# password = "bluepw";
}
);
# Channel links configuration.
channel_links = ( {
source = "Lobby";
destination = "Red team";
},
{
source = "Lobby";
destination = "Blue team";
}
);
# The channel in which users will appear in when connecting.
# Note that default channel can't have 'noenter = true' or password set
default_channel = "Lobby";
Unfortunately the client tells me connection failed
How can I tell if the server is actually running?
Thank you very much
Hello,
The problem is
bindaddr = "INADDR_ANY";
I know the wiki page says to use that to bind any interface, but if you check logread it will tell you
daemon.crit uMurmurd[21537]: Invalid IPv4 address supplied!
Instead use
bindaddr = "0.0.0.0";
which should allow connections from outside
However I believe you will also need to open the port 64738, since that is not a port forward anymore
For that you will need to run these commands
uci add firewall rule # =cfg2b92bd
uci set firewall.@rule[-1].name='mumble'
uci set firewall.@rule[-1].src='wan'
uci set firewall.@rule[-1].dest_port='64738'
uci set firewall.@rule[-1].target='ACCEPT'