Ultimate SQM settings: Layer_cake + DSCP marks


#121

Now we're getting somewhere. This seems like maybe a problem reaching your gateway or with ARP, or with return packets from your gateway getting squashed until a firewall related connection is established or something. The fact that it eventually works suggests that until "something" happens the packets don't know where to go, then eventually that thing happens (an ARP reply, a conntrack entry, something etc) then it works.

You could try creating a new OpenWRT "interface" place it in the same firewall zone as your LAN and putting the veth0 as the physical interface.


#122

One sec guys. I might have progress here.

Was reading up here:

And at the bottom of page this guy is talking about MAC adress on the bridge interface.

So i went into luci and to bridge and overrode the MAC address to 00:00:00:00:00:00

Since then, so far so good. No issues.

root@OpenWrt:~# ifconfig
br-lan    Link encap:Ethernet  HWaddr 56:B2:C1:03:2B:D3
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::6038:e0ff:fe10:aecf/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:36562 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8086 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2514747 (2.3 MiB)  TX bytes:3437620 (3.2 MiB)

eth0      Link encap:Ethernet  HWaddr 62:38:E0:10:AE:CF
          inet6 addr: fe80::6038:e0ff:fe10:aecf/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:37033 errors:0 dropped:0 overruns:0 frame:0
          TX packets:28052 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:532
          RX bytes:3117405 (2.9 MiB)  TX bytes:83604549 (79.7 MiB)
          Interrupt:37

eth0.1    Link encap:Ethernet  HWaddr 62:38:E0:10:AE:CF
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:34673 errors:0 dropped:0 overruns:0 frame:0
          TX packets:25497 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2214639 (2.1 MiB)  TX bytes:82103451 (78.2 MiB)

eth1      Link encap:Ethernet  HWaddr 60:38:E0:10:AE:CF
          inet6 addr: fe80::6238:e0ff:fe10:aecf/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:62912 errors:0 dropped:0 overruns:0 frame:0
          TX packets:33482 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:532
          RX bytes:86162589 (82.1 MiB)  TX bytes:2799778 (2.6 MiB)
          Interrupt:36

eth1.2    Link encap:Ethernet  HWaddr 60:38:E0:10:AE:CF
          inet addr:192.168.8.2  Bcast:192.168.8.255  Mask:255.255.255.0
          inet6 addr: fe80::6238:e0ff:fe10:aecf/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:21184 errors:0 dropped:0 overruns:0 frame:0
          TX packets:33476 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:83357789 (79.4 MiB)  TX bytes:2665162 (2.5 MiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:112 errors:0 dropped:0 overruns:0 frame:0
          TX packets:112 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:9951 (9.7 KiB)  TX bytes:9951 (9.7 KiB)

veth0     Link encap:Ethernet  HWaddr B6:FF:40:2B:D7:E7
          inet6 addr: fe80::b4ff:40ff:fe2b:d7e7/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:43 errors:0 dropped:0 overruns:0 frame:0
          TX packets:18447 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:4326 (4.2 KiB)  TX bytes:80741872 (77.0 MiB)

veth1     Link encap:Ethernet  HWaddr 56:B2:C1:03:2B:D3
          inet6 addr: fe80::54b2:c1ff:fe03:2bd3/64 Scope:Link
          UP BROADCAST RUNNING PROMISC MULTICAST  MTU:1500  Metric:1
          RX packets:18447 errors:0 dropped:0 overruns:0 frame:0
          TX packets:43 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:80741872 (77.0 MiB)  TX bytes:4326 (4.2 KiB)

wlan0     Link encap:Ethernet  HWaddr 62:38:E0:10:AE:D1
          inet6 addr: fe80::6038:e0ff:fe10:aed1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1890 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2038 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:326310 (318.6 KiB)  TX bytes:2179811 (2.0 MiB)

wlan1     Link encap:Ethernet  HWaddr 62:38:E0:10:AE:D0
          inet6 addr: fe80::6038:e0ff:fe10:aed0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:65 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:8550 (8.3 KiB)

root@OpenWrt:~#

Strangely i dont see mac address changed in ifconfig on the bridge.

Since it seems to work now so far, and my inbound/outbound data seems to go through the veth0/1 interface, I can carry on and apply SQM and adjust iptables to my preference?

In luce my bridge now looks like this tho:

**Protocol:** Static address
**Uptime:** 0h 10m 33s
**MAC:** 00:00:00:00:00:00
**RX:** 3.20 MB (43874 Pkts.)
**TX:** 3.67 MB (9382 Pkts.)
**IPv4:** 192.168.1.1/24

#123

br-lan is using the mac of veth1 in your ifconfig output. I'm not sure what you did, and/or whether it just has to do with maybe forcing the bridge to clear out MAC caches or something, but if it works... The other option would be to generate a random valid mac address and hand that to the bridge:

https://www.hellion.org.uk/cgi-bin/randmac.pl?scope=local&type=unicast

I don't think it makes sense to give all zeros as a mac address, but perhaps that's interpreted in some specific way by the command line?


#124

Well, I think I can confirm its working now.

Just to test, I put SQM on Veth0 and I can control WAN ingress limit, and for eth1.2 SQM I can control the WAN egress limit.

Sounds good no? :smiley:

works!

Receiving UDP packets with Experdited forwarding now from the rules i set as well. WHOOP!


#125

Good. I think what happened was that adding the veth1 to the bridge changed the bridge mac address and then clients on your LAN weren't aware of it and had problems. If you set a proper static locally administered MAC on your bridge that should solve the problem.


#126

Good possibility. Nobody else stumbled on this?


#127

It seems like it might depend on randomness and the model of your hardware, whether the veth is chosen as the bridge MAC depends on if it's the smallest or largest MAC or whatever. not everyone would see this issue.


#128

Ok, so problem partially solved.

What happens is, i run the script at startup. Works bad.
What I need to do at that point is go to LuCi -> br-lan bridge -> advanced settings -> change MAC address
(Im not even sure if its just the fact that it changes or not that makes it work)

Not sure if i have to redo the following though:
ip route add default dev veth0 table 100
ip rule add iif eth1.2 table 100 priority 100

After this, it just keeps working well.


#129

Yeah, something's not right, where do you put the script to set up veth? Post it here please for review. Also /etc/config/network


#130

I started of manual, but no difference to putting it in LuCi -> Startup

# Put your custom commands here that should be executed once
# the system init finished. By default this file does nothing.

./root/net.sh

exit 0

Script:

ip link add type veth
ip link set veth0 up
ip link set veth1 up
ip link set veth1 promisc on

iptables -t mangle -F PREROUTING

ip route add default dev veth0 table 100 ## send everything that uses table 100 to veth0
ip rule add iif eth1.2 table 100 priority 100 ## if it comes in wan interface use table 100 for routing

iptables -t mangle -A PREROUTING -p udp -m iprange --src-range 5.135.129.0-5.135.129.255 -j DSCP --set-dscp-class EF
iptables -t mangle -A PREROUTING -p udp -m iprange --src-range 198.27.85.0-198.27.85.255 -j DSCP --set-dscp-class EF

I already made the bridge in LuCi to veth1 but manual command makes no difference, so doesn't really matter.

/etc/config/network:


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option delegate '0'
	option metric '1'
	option ifname 'eth0.1 veth1'
	option macaddr '00:00:00:00:00:00'

config interface 'wan'
	option ifname 'eth1.2'
	option proto 'static'
	option ipaddr '192.168.8.2'
	option netmask '255.255.255.0'
	option gateway '192.168.8.1'
	option dns '1.1.1.1 8.8.8.8'
	option delegate '0'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'

Note: The 00-00-00-00-00-00 mac is what i have to change in LuCi UI, i pretty much switch it back and forth from this to empty on every reboot, and vice versa.


Working state:

Route:

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         192.168.8.1     0.0.0.0         UG    0      0        0 eth1.2
192.168.1.0     *               255.255.255.0   U     1      0        0 br-lan
192.168.8.0     *               255.255.255.0   U     0      0        0 eth1.2

ARP:

IP address       HW type     Flags       HW address            Mask     Device
192.168.8.1      0x1         0x2         b8:08:d7:d3:06:5c     *        eth1.2
192.168.1.111    0x1         0x2         94:10:3e:30:b6:8d     *        veth0
192.168.1.101    0x1         0x2         28:3b:82:cb:48:93     *        veth0
192.168.1.101    0x1         0x2         28:3b:82:cb:48:93     *        br-lan
192.168.1.130    0x1         0x2         d4:a3:3d:29:43:ba     *        veth0
192.168.1.100    0x1         0x2         2c:4d:54:4d:b9:ff     *        br-lan
192.168.1.130    0x1         0x2         d4:a3:3d:29:43:ba     *        br-lan
192.168.1.111    0x1         0x2         94:10:3e:30:b6:8d     *        br-lan
192.168.1.249    0x1         0x2         ac:cf:23:66:f1:6a     *        br-lan
192.168.1.100    0x1         0x2         2c:4d:54:4d:b9:ff     *        veth0

(note 192.168.1.100 is my main windows client i do all testing on, but intermittent/bad routing also happens on Wireless so)

ifconfig:

root@OpenWrt:~# ifconfig
br-lan    Link encap:Ethernet  HWaddr 62:38:E0:10:AE:CF
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::6038:e0ff:fe10:aecf/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:101957 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1653 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:5465158 (5.2 MiB)  TX bytes:307035 (299.8 KiB)

eth0      Link encap:Ethernet  HWaddr 62:38:E0:10:AE:CF
          inet6 addr: fe80::6038:e0ff:fe10:aecf/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:100419 errors:0 dropped:0 overruns:0 frame:0
          TX packets:42955 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:532
          RX bytes:7113924 (6.7 MiB)  TX bytes:84470511 (80.5 MiB)
          Interrupt:37

eth0.1    Link encap:Ethernet  HWaddr 62:38:E0:10:AE:CF
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:99946 errors:0 dropped:0 overruns:0 frame:0
          TX packets:42421 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:5253588 (5.0 MiB)  TX bytes:84066378 (80.1 MiB)

eth1      Link encap:Ethernet  HWaddr 60:38:E0:10:AE:CF
          inet6 addr: fe80::6238:e0ff:fe10:aecf/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:83115 errors:0 dropped:0 overruns:0 frame:0
          TX packets:101665 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:532
          RX bytes:88378022 (84.2 MiB)  TX bytes:7032264 (6.7 MiB)
          Interrupt:36

eth1.2    Link encap:Ethernet  HWaddr 60:38:E0:10:AE:CF
          inet addr:192.168.8.2  Bcast:192.168.8.255  Mask:255.255.255.0
          inet6 addr: fe80::6238:e0ff:fe10:aecf/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:43242 errors:0 dropped:0 overruns:0 frame:0
          TX packets:101660 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:85278140 (81.3 MiB)  TX bytes:6625038 (6.3 MiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:180 errors:0 dropped:0 overruns:0 frame:0
          TX packets:180 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:16238 (15.8 KiB)  TX bytes:16238 (15.8 KiB)

veth0     Link encap:Ethernet  HWaddr 4A:67:F0:B2:05:7D
          inet6 addr: fe80::4867:f0ff:feb2:57d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:622 errors:0 dropped:0 overruns:0 frame:0
          TX packets:42121 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:70380 (68.7 KiB)  TX bytes:84996134 (81.0 MiB)

veth1     Link encap:Ethernet  HWaddr F2:0D:43:D8:0E:82
          UP BROADCAST RUNNING PROMISC MULTICAST  MTU:1500  Metric:1
          RX packets:42121 errors:0 dropped:0 overruns:0 frame:0
          TX packets:622 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:84996134 (81.0 MiB)  TX bytes:70380 (68.7 KiB)

wlan0     Link encap:Ethernet  HWaddr 62:38:E0:10:AE:D1
          inet6 addr: fe80::6038:e0ff:fe10:aed1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2026 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2117 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:232750 (227.2 KiB)  TX bytes:1354977 (1.2 MiB)

wlan1     Link encap:Ethernet  HWaddr 62:38:E0:10:AE:D0
          inet6 addr: fe80::6038:e0ff:fe10:aed0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:259 errors:0 dropped:0 overruns:0 frame:0
          TX packets:388 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:21900 (21.3 KiB)  TX bytes:57435 (56.0 KiB)

#131

Non-working state, right after a router reboot

Route:

root@OpenWrt:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         192.168.8.1     0.0.0.0         UG    0      0        0 eth1.2
192.168.1.0     *               255.255.255.0   U     1      0        0 br-lan
192.168.8.0     *               255.255.255.0   U     0      0        0 eth1.2

Arp:

root@OpenWrt:~# arp
IP address       HW type     Flags       HW address            Mask     Device
192.168.1.111    0x1         0x2         94:10:3e:30:b6:8d     *        veth0
192.168.8.1      0x1         0x2         b8:08:d7:d3:06:5c     *        eth1.2
192.168.1.249    0x1         0x2         ac:cf:23:66:f1:6a     *        br-lan
192.168.1.100    0x1         0x2         2c:4d:54:4d:b9:ff     *        veth0
192.168.1.100    0x1         0x2         2c:4d:54:4d:b9:ff     *        br-lan

ifconfig:

br-lan    Link encap:Ethernet  HWaddr 56:B9:CF:1A:4D:7E
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::6038:e0ff:fe10:aecf/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:338 errors:0 dropped:0 overruns:0 frame:0
          TX packets:454 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:42848 (41.8 KiB)  TX bytes:52245 (51.0 KiB)

eth0      Link encap:Ethernet  HWaddr 62:38:E0:10:AE:CF
          inet6 addr: fe80::6038:e0ff:fe10:aecf/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:676 errors:0 dropped:0 overruns:0 frame:0
          TX packets:686 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:532
          RX bytes:66296 (64.7 KiB)  TX bytes:139582 (136.3 KiB)
          Interrupt:37

eth0.1    Link encap:Ethernet  HWaddr 62:38:E0:10:AE:CF
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:644 errors:0 dropped:0 overruns:0 frame:0
          TX packets:653 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:51760 (50.5 KiB)  TX bytes:132926 (129.8 KiB)

eth1      Link encap:Ethernet  HWaddr 60:38:E0:10:AE:CF
          inet6 addr: fe80::6238:e0ff:fe10:aecf/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:775 errors:0 dropped:0 overruns:0 frame:0
          TX packets:431 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:532
          RX bytes:800763 (781.9 KiB)  TX bytes:40296 (39.3 KiB)
          Interrupt:36

eth1.2    Link encap:Ethernet  HWaddr 60:38:E0:10:AE:CF
          inet addr:192.168.8.2  Bcast:192.168.8.255  Mask:255.255.255.0
          inet6 addr: fe80::6238:e0ff:fe10:aecf/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:382 errors:0 dropped:0 overruns:0 frame:0
          TX packets:424 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:766749 (748.7 KiB)  TX bytes:37774 (36.8 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:26 errors:0 dropped:0 overruns:0 frame:0
          TX packets:26 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2458 (2.4 KiB)  TX bytes:2458 (2.4 KiB)

veth0     Link encap:Ethernet  HWaddr 5A:26:0D:25:4E:F3
          inet6 addr: fe80::5826:dff:fe25:4ef3/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:496 errors:0 dropped:0 overruns:0 frame:0
          TX packets:190 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:48794 (47.6 KiB)  TX bytes:72833 (71.1 KiB)

veth1     Link encap:Ethernet  HWaddr 56:B9:CF:1A:4D:7E
          UP BROADCAST RUNNING PROMISC MULTICAST  MTU:1500  Metric:1
          RX packets:190 errors:0 dropped:0 overruns:0 frame:0
          TX packets:496 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:72833 (71.1 KiB)  TX bytes:48794 (47.6 KiB)

wlan0     Link encap:Ethernet  HWaddr 62:38:E0:10:AE:D1
          inet6 addr: fe80::6038:e0ff:fe10:aed1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:80 errors:0 dropped:0 overruns:0 frame:0
          TX packets:82 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:14696 (14.3 KiB)  TX bytes:18116 (17.6 KiB)

wlan1     Link encap:Ethernet  HWaddr 62:38:E0:10:AE:D0
          inet6 addr: fe80::6038:e0ff:fe10:aed0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:21 errors:0 dropped:0 overruns:0 frame:0
          TX packets:89 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3250 (3.1 KiB)  TX bytes:20104 (19.6 KiB)

Sadly the way i need to fix it through constantly changing mac of br-lan is tedious, and apparently i also have to re-enable SQM after this otherwise they wont work either -_-


#132

i think you need to enable STP into /etc/config/network:

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option igmp_snooping '1'
	option stp '1'
	option mtu '1500'
	option ifname 'eth0.1 veth1'

i think it should work without changing mac address!
EDIT:
I tried to disbale stp and igmp, then yeah i have the same as your problem.
what is the output of :
brctl show


#133

Interesting, lets see if it works!

root@OpenWrt:~# brctl show
bridge name     bridge id               STP enabled     interfaces
br-lan          7fff.6238e010aecf       yes             eth0.1
                                                        veth1
                                                        wlan1
                                                        wlan0

Rebooted, etc... the issue persists... This is becoming tiresome :frowning:

Ill try again on a snapshot, see if it improves matters.


#134

Hmm
make this changes to your /etc/config/network
instead of:

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5t'

make like this:

config switch_vlan 'eth0_1'
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '0 1 2 3 5t'

instead of
config switch_vlan
option device 'switch0'
option vlan '2'
option ports '4 6t'

make like this:

config switch_vlan 'eth1_2'
option device 'switch0'
option vlan '2'
option vid '2'
option ports '4 6t'


#135

Nope. Still same issue. Im back to fresh snapshot too, no change :C

Perhaps try STP/IGMP in globals to apply on all interfaces?


#136

oh,so the only way to get it to work is by change mac address:
what will happen if you add this to luci startup page

sleep 5
/etc/init.d/network restart
sleep 8
./root/net.sh
/etc/init.d/sqm restart

#137

try and see


#138

My idea didnt work, restarting network and then script , or vice versa, or even back to back doesn't work either. (I think i actually tried fiddling around with restarting network yesterday)

Gotta change MAC then restart script lol.

Mhh. Perhaps I should give FireQOS a go.


#139

it will be the same for fireqos!


#140

Will it? i thought it used different approach, not Veth?

Mhh what about a startup script that changes br-lan to random mac, then restart interface and rerun script. Ill have to try this then. Then I'd also need a script to restart the SQM instances.