Uhttpd interfairing with tornado/webthing

I built my own openwrt with standard uhttpd luci and python3 for target linkit-smart-7688.
Now after installing mozilla-iot webthing and starting the example I get a 403 Forbidden.
I tried to edit /etc/config/uhttpd and set the list listen_http&s ports to something different than 80/433 but I still get 403 Forbidden.
If I do the same on my local laptop I get a devtools-JSON-view.
Is that related to the uhttpd server blocking the tornado server upon webthing is built?

You typically can't run two servers on the same interface and same port.

Im running uhttpd on port:8080/8443 and tornado/webthing on port:8888 so its a different port on same interface. Is that problematic?

Unless they share the same resources, such as the webroot or CGI-like interfaces, it should be OK.

I would try disabling the "custom" service to make sure something isn't wrong at the start.

I think you got me wrong. I try to implement a separate webservice called webthing beside the uhttpd/Luci webconfig panel which is in fact working as normal. The webthing is not available.
It wold be nice to have Luci on port 8080 and webthing on port 8888.
But you gave me a idea, I tried now to kill -9 the PID of uhttpd but still get a 403:Forbidden, because it comes up again right away.

So if uhttpd is not running, it seems the problem is with webthings.

uhttpd is running and can not be killed. It restarts all the time.

Disable it with something like

/etc/init.d/uhttpd disable
/etc/init.d/uhttpd stop

(I run nginx, so I'm not sure of the proper init script name)

ok that did it. now its stopped. but still i get 403:Forbidden. Where does that come from?

You'll have to "debug" your webthings code/config -- as far as I know, it's not "standard" OpenWrt code and is "experimental".

Its python 3.7.4 on my local machine and python 3.7.4 on the openWRT device.
The installation was made on both machines with pip3 install webthing.
Can it behave different on my local machine than on openWRT?

Yes, OpenWrt is not a "full-on" Linux-based distro with a full-on Python distribution by default. If it is expecting some "standard" Python libraries, you may need to install those packages as well. Especially if webthing is not a "pure Python" package you may not have a self-consistent install.

ah, i did that! CONFIG_PACKAGE_python3=y

and webthing is a pure python-package

I don't believe that is a "full" Python install, as you would get with a "desktop" or "server" distro.

You'll have to debug with Python tooling then, or it is how you've configured the web server and its interactions with Python.

But it works over MDNS the webting is presenting it self in the mozilla-gateway perfectly.
The RESTfull api is not displayed because something is blocking port 8888.
What can block a port else?

Tells me the server is running, but either misconfigured itself, the file system permissions are not right, the linkage to the application, or the application is not properly configured.

If uhttpd is listening on a different port, what makes you think it is interfering?

I asked what it could be. In the meantime i got a hint over in the mozilla-iot forum.
Over IP i can get the source. It somehow checks for hostname. My hostname is without a .tld end.
How do i add a .local tld?

em sorry. seamy as my device is available over .local tld. perfect. thanks for the sorting out...