uHTTPd authentication don't work

I 'm installing a second web service in addition to luci on port 81 from WAN.
The service works fine but I can't get authentication to work.
When accessing the service, the password is not requested.
That could be happening?

etc/config/uhttpd:


config uhttpd 'main'
	list listen_http '192.168.1.2:80'
	list listen_https '192.168.1.2:443'
	option redirect_https '1'
	option home '/www'
	option rfc1918_filter '1'
	option max_requests '3'
	option max_connections '100'
	option cert '/etc/uhttpd.crt'
	option key '/etc/uhttpd.key'
	option cgi_prefix '/cgi-bin'
	list interpreter '.cgi=/bin/sh'
	list lua_prefix '/cgi-bin/luci=/usr/lib/lua/luci/sgi/uhttpd.lua'
	option script_timeout '60'
	option network_timeout '30'
	option http_keepalive '20'
	option tcp_keepalive '1'
	option realm 'huaTOR'
	option config '/etc/httpd.conf'

config cert 'defaults'
	option days '730'
	option bits '2048'
	option country 'ZZ'
	option state 'Somewhere'
	option location 'Unknown'
	option commonname 'OpenWrt'

config uhttpd 'sol'
	list listen_http '0.0.0.0:81'
	list listen_http '[::]:81'
	option redirect_https '1'
	option home '/www/sol'
	option index_page 'index.php'
	option rfc1918_filter '1'
	option max_requests '3'
	option max_connections '100'
	option cert '/etc/uhttpd.crt'
	option key '/etc/uhttpd.key'
	list interpreter '.php=/usr/bin/php-cgi'
	list interpreter '.cgi=/bin/sh'
	option script_timeout '60'
	option network_timeout '30'
	option http_keepalive '20'
	option tcp_keepalive '1'
	option realm 'sol'
	option config '/etc/httpd.conf'
	option cgi_prefix '/cgi-bin'


/etc/httpd.conf

/sol/:user:$1$$87bAa7aDGF.
/:user:Password

Your example works for me. I immediately get a password prompt when accessing either port 80 or 81.

Yes that's so strange...

More info. Please ask if you want more printouts.

DISTRIB_ID='OpenWrt'
DISTRIB_RELEASE='18.06.8'
DISTRIB_REVISION='r7989-82fbd85747'
DISTRIB_TARGET='brcm63xx/generic'
DISTRIB_ARCH='mips_mips32'
DISTRIB_DESCRIPTION='OpenWrt 18.06.8 r7989-82fbd85747'

Clean browser cache, try with private mode, or try another browser.