UF896 - Qualcomm MSM8916 LTE router ~384MiB RAM/2.4GiB flash, Android: OpenWrt?

This is great! Just saw, that the Onedrive folder is gone by now.
But it seems like the access to the folder is restricted.

Don't know if I can help you, but what's your exact problem, and what did you do with the modem so far?

I'm sorry. now opened common access. I have a problem next my friend on my hmuf02-V05 device removed the firmware dump from memory flash on direct helplessness of special tools and software. I strolled my device, tried all firmware versions. Copied all files with modem.img even changed modemst1.bin, modemst2.bin, put the right to files and directories, but nothing helped SIM card not determined and modem 4G disconnects, wifi and openwrt works correctly

Using the UZ801 flash.sh script resulted in this:

./flash.sh
Erasing 'boot'                                     OKAY [  0.110s]
Finished. Total time: 0.117s
Sending 'boot' (334 KB)                            OKAY [  0.014s]
Writing 'boot'                                     OKAY [  0.046s]
Finished. Total time: 0.071s
Rebooting                                          OKAY [  0.004s]
Finished. Total time: 0.054s
< waiting for any device >

-> bricked

it seems like the fastboot flash boot lk2nd.img step is not successful.
For anyone struggeling with that too: you can just place in your fsc.bin, fsg.bin, modemst1.bin and modemst2.bin dumps made with edl beforehand directly to the folder and comment out all lines above the # Now We Got All Of Them To Rock Linux! comment.

can anyone give me an edl dump of the hmuf02-V05 full firmware? please urgently needed

You meant this modem.bxx files right?
Only these files or (also) other files?

Is there a chance that you still have the list of files you copied or the command you used or something like that?

I am still fighting with the SIM recognition..

And is there something else to do besides copy, reboot, hope?

im so close to get it working. The sim gets recognized, but i am not able to get a connection to the network.

I have the 123pan openwrt UZ801 installed and tried multiple combinations of loading the stockOS files of the modem.bin file to the /lib/firmware folder in the new OS

this seems to be the error message:
Error: Modem bearer teardown in progress.

and `mmcli -m any shows:

  Status   |                   lock: sim-pin2
           |         unlock retries: sim-pin (3), sim-puk (10), sim-pin2 (3), sim-puk2 (10)
           |                  state: enabled
           |            power state: on
           |         signal quality: 91% (recent)

and

  3GPP     |          enabled locks: fixed-dialing
           |           registration: idle
           |   packet service state: detached

and

mmcli -v -m 0 --simple-connect="apn={{name}}" results in:

error: couldn't connect the modem: 'Timeout was reached'

and avoiding this timeout with --timeout=300 as a parameter results in:

error: couldn't connect the modem: 'GDBus.Error:org.freedesktop.ModemManager1.Error.MobileEquipment.NetworkTimeout: Network timeout'

@jackadam1981 and @cashin you passed this point if i read your comments correctly. Which step am i missing?

also:

is there a way to get back into edl mode after openwrt is flashed?

In Luci under interfaces => modem try to add your ISP APN, for some reason authentication type as NONE didn't work for me so I I had to change it to CHAP and inserted my correct ISP username and password.

for adb If you have it already enabled in openwrt you can enter EDL mode by typing : adb reboot edl

Hm, okay will try that once again. Did'nt work the first time, but maybe it was just due to a typo or something.

adb reboot edl just reboots the stick normaly, but i found out, that adb reboot bootloader boots it to fastboot. Have'nt tried it yet, but i read, that it should be possible to use it similar to edl to flash the backup made with edl.

Thanks :slight_smile:

After touched the top antenna (the patch one on the plastic cap) my dongle stopped working (solid red led).
Which antenna is for WiFi and which for 4G ?

Or use Fastboot to boot into edl with: fastboot reboot-edl I think

1 Like

Does anybody know how the onboard Button could be used for some action like restarting the Wi-Fi? I think it would be great to be able to use it since it is there.

/sys/kernel/debug/gpio seems to show no information about status changes when pressing or releasing the button.

You could look here: https://github.com/hyx0329/openstick-failsafe-guard/tree/dev/openstick-button-monitor
I found this recently, but I have not personally tested it.
It overrides the reset behaviour for long press. You should be able to tweak it to be useful to you.

Also I have had luck with adb reboot bootloader

seems like this is for the Debian version of Openstick. The key commands seem to be unavailable in OpenWrt.

In native OpenWrt, button presses trigger action scripts at /etc/rc.button. See:

https://openwrt.org/docs/guide-user/hardware/hardware.button