Ubuntu 20.04 LTS exfat-nofuse-.../exfat_core.o] Error 1

I have seen other posts - other people having no issues on Ubuntu 20 LTS.
Recently upgraded the system and I am trying to build master of CONFIG_TARGET_ipq806x_generic_DEVICE_netgear_r7800=y getting the error

make[5]: *** [scripts/Makefile.build:266: /owrt1907_r7800/build_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/linux-ipq806x_generic/exfat-nofuse-2018-04-17-01c30ad5/exfat_core.o] Error 1
make[4]: *** [Makefile:1700: /owrt1907_r7800/build_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/linux-ipq806x_generic/exfat-nofuse-2018-04-17-01c30ad5] Error 2
make[3]: *** [Makefile:55: /owrt1907_r7800/build_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/linux-ipq806x_generic/exfat-nofuse-2018-04-17-01c30ad5/.built] Error 2
make[2]: *** [package/Makefile:113: package/feeds/packages/exfat-nofuse/compile] Error 2
make[1]: *** [package/Makefile:107: /owrt1907_r7800/staging_dir/target-arm_cortex-a15+neon-vfpv4_musl_eabi/stamp/.package_compile] Error 2
make: *** [/owrt1907_r7800/include/toplevel.mk:224: world] Error 2

Did anyone else encounter this issue? I have tried 4-5 times with V=s and j 1 but now I need to ask this "beginner-question". I dont see any further information in the logs.

Thanks and cheers,

Your actual error is higher up. You're just posting the tail of the error output. You need to use '-j1' (no spaces) to use a single thread. You still have at least five make instances in that paste.

I am confused: Master or 19.07 ???

That has significance, as exfat-nofuse should be used in 19.07, while master has in-tree exfat from Linux sources that needs to be used.
Exfat-nofuse can only be built for kernel 4.14 or 4.19, while ipq806x/R7800 has kernel 5.4 in master...

Ps. I am building ok with Ubuntu 20.04 for both master and 19.07

Yeah, I have seen your posts, noticing that you build on 20.04 too. Interesting what you write about "exfat-nofuse"
Yes, it is confusing, I need to cleanup the build environment. My build script creates that directory laso if "-v master"... this is because of the move from 18 to 19, to make a clear difference.... I need to do some homework - yes.

But triple checking the script, it shows that:
Actually, I am doing

git clone https://git.openwrt.org/openwrt/openwrt.git owrt1907_r7800
make -j 1 V=s

I do not

git checkout v19.07.2

:smiley: (happy about that understanding)

Doing some additional own thoughts and not just asking, the process of my thoughts lead to the understanding that I cant have extfat enabled.
Which means, I need to disable the respective kmod extfat


Is that correct?
My overall goal is to (also) build with Kernel Smith ehhh Kernel 5.4

Cheers, Frood

Kernel 5.4. is only in master, and 19.07 still has the old 4.14.
Checkout nothing related to 19.07 if you want master.

You can have exfat in both 19.07 or in master.
Just look at my build configs, if you want hints.

Disabling/commenting/removing the line CONFIG_PACKAGE_kmod-fs-exfat=y removes that package from the config, yes.

Thanks!! :ok_man:



:ok_hand: :+1: :construction_worker_man: