Ubootwrite fails with "Found an error, so aborting" MR33

Hi All,

a bit of guidance please... I've googled/forum'd - sure its simple, just cant get it working.

I have a MR33 trying to get OpenWRT onto.

Setup:
Fedora 22 machine with Ethernet connection to the MR33, and serial port setup.
Wireless port enabled on the Fedora22 machine to download updates/configs etc as required.

The USB adapter I ordered is "Yizhet 2PCS CP2102 USB to TTL Serial Converter with 5 PIN Jumper Wire Cable Chip Compatible with Arduino, Windows 7, 8, 10, Linux, Mac OS X"

If I connect to the MR33 from the Fedora22 machine with wifi, i.e. connecting to 'Meraki Scanning' and access 10.128.128.128 via a browser, my Fedora22 gets the IP 10.118.117.35 and I can connect. I can download the support data (no option for f/w upload) but the DAT file is binary, and not sure how to extract this.

Attached putty log shows serial port is fine.... But

If I try the serial u-boot approach, I get this:

[root@localhost tmp]# ./ubootwrite.py --write=mr33-uboot.bin
Uploading image
Prompt is 'RNING! THIS CONSOLE IS LOGGED! UNAUTHORIZED ACCESS FORBIDDEN!
<Meraki> '
Found an error, so aborting
Uploading image

Or a similar variation like

[root@localhost tmp]# ./ubootwrite.py --write=mr33-uboot.bin
Uploading image
Prompt is 'eraki> '
Found an error, so aborting
Uploading image

Sample putty log

^@
Format: Log Type - Time(microsec) - Message - Optional Info
Log Type: B - Since Boot(Power On Reset),  D - Delta,  S - Statistic
S - QC_IMAGE_VERSION_STRING=BOOT.BF.3.1.1-00096
S - IMAGE_VARIANT_STRING=DAACANAZA
S - OEM_IMAGE_VERSION_STRING=CRM
S - Boot Config, 0x00000025
S - Core 0 Frequency, 0 MHz
B -       261 - PBL, Start
B -      1338 - bootable_media_detect_entry, Start
B -      2609 - bootable_media_detect_success, Start
B -      2623 - elf_loader_entry, Start
B -      4031 - auth_hash_seg_entry, Start
B -      6182 - auth_hash_seg_exit, Start
B -     73774 - elf_segs_hash_verify_entry, Star

etc

hello,

I also set the serial port as follows.

stty -F /dev/ttyUSB0 115200 cs8 -cstopb -parenb

same error as the original post.

Any solutions/ideas to test pls?

Paul.

hmmm.... I tried another PC (just in case) with a liveCD image, no serial support by default so installed - but serial support still not active.

any ideas?

tia

[root@localhost ~]# ls -al /dev/ttyU*
crw-rw----. 1 root dialout 188, 0 Nov 25 05:36 /dev/ttyUSB0
[root@localhost ~]# stty -F /dev/ttyUSB0 115200 cs8 -cstopb -parenb
[root@localhost ~]# ./ubootwrite.py --write=mr33-uboot.bin
Traceback (most recent call last):
  File "./ubootwrite.py", line 22, in <module>
    import serial
ImportError: No module named serial
[root@localhost ~]# pip install pyserial
bash: pip: command not found...
[root@localhost ~]# pip3 install pyserial
You are using pip version 6.0.8, however version 21.3.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
Collecting pyserial
  Downloading https://files.pythonhosted.org/packages/07/bc/587a445451b253b285629263eb51c2d8e9bcea4fc97826266d186f96f558/pyserial-3.5-py2.py3-none-any.whl (90kB)
    100% |################################| 94kB 716kB/s 
Installing collected packages: pyserial

Successfully installed pyserial-3.5
[root@localhost ~]# ./ubootwrite.py --write=mr33-uboot.bin
Traceback (most recent call last):
  File "./ubootwrite.py", line 22, in <module>
    import serial
ImportError: No module named serial