Uboot web page is gone after flashing openwrt ... was [Glinet_gl-x750 new version (?)]


I got glinet_gl-x750, the sticker on the back of the device says "X750C4" and there is a FCC from 2019-06-19

Flashing Openwrt or LTE Openwrt (rooter) GoldenOrb is not possible
("Device gl-x750 not supported by this image
Supported devices: glinet,gl-x750")

I was brave and tried sysupgrade -F (force) but it (luckily?) did not work.
Any idea? I would be glad to help with further information.



Check on the GL.iNet forums. Their technical staff frequently posts there.

Thanks, I did post in their forum.



Problem is solved, see https://forum.gl-inet.com/t/x750c4-new-hardware-version-of-x750-solved/8322/4



be careful, uboot web page is gone after flashing openwrt (goldenorb, rooter), so no way back to stock firmware for me (yet)

It might be that “goldenorb, rooter” replaces U-Boot, which is not something OpenWrt does.

please don't change OpenWrt Wiki page about this device to add information about Rooter. It is a downstream project, not OpenWrt official releases.

Also don't link whole forum threads when you can write a concise sentence instead.

FIxed the page for you.

I also find very strange that Rooter touch uboot in any way. There is no reason to alter it. OpenWrt does not touch it.

Hi, thanks for wiki info. I suppose a device page would be better to be published. I (mis)used the techdata page for that, shame on me.

On topic: Maybe it is a "feature" of flashing a custom firmware through uboot on that device. I don't know if the outcome would have been different when flashing openwrt instead of ROOter on that device. I am new to that, and don't know if partitions are handled differently in sysupgrade vs uboot.

In the Rooter forum user LOM says, that "The ROOter firmware does not overwrite uboot"

I used uboot because it was not possible to flash ATH79 over the running AR71XX image through sysupgrade.



the uboot bootloader for this device is made by GL.Inet (using uboot project as a base), and OpenWrt does not touch it. You would need to ask them.

I think it is strange because on other GL.Inet devices I have (BL1300 and some yellow mini routers) the uboot recovery web page always works, even after I installed OpenWrt.

1 Like

No U-Boot impact on the GL-AR300M series or GL-AR750S either when flashing firmware.

shame on me, i fooled myself. What happened? Entering "" in firefox adressbar got autofilled to The uboot webserver correctly said "page [cgi-bin/luci] not found". I was not able to go to plain (firefox feature or my illiteracy). Opened page in chrome and the main page of uboot was shown.

Sorry folks for being in chicken mode. Everything went well and I am back on stock firmware.




not just firefox... tripped me up before as well...

Also Chrome does that (tries to reconnect to the same full URL link even if you type only the IP).
They also try to cache the page and this can be an issue when upgrading the firmware as they keep the old Luci interface cached and then fail to login or do other stuff with weird errors.

It helps if you close the old tab and use a new tab or close Firefox/Chrome and open it again.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.