UBNT-ERX Switch Issue


I have a Ubiquiti ER-X router, running OpenWrt 19.07.7.
I am using it as router/firewall/DNS forwarder/DNS adblocker. I have configured several VLANs (tagged and untagged). One of the LAN ports is used just for my PC (untagged), others are providing connection to 2 switches (also running OpenWrt).
Everything works fine until I unplug the PC LAN cable. It seems that DHCP is still working, but no other connection (to other devices or Internet) is possible.
I have tried following:

  • Change LAN ports.
  • Turn firewall off.
  • Reboot router.

but the behavior is the same - once I unplug my PC from the router, connection for other hosts is lost. Once I plug it back in, everything is working again.
Have you ever experienced similar issue? I have no idea what is causing the issue...

How is the pc connected to Ethernet? Is it a direct connection or does it go through an accessory like a usb-c docking hub or monitor? Are you disconnecting the actual Ethernet connection or are you unplugging a usb-c cable from your computer (or similar situation)?

If you have a usb/accessory device between the computer and the er-x and that is the thing that is actually disconnected, try removing the actual Ethernet cable instead. Some usb-c docking hubs/monitors have a firmware bug that will cause the Ethernet adapter to produce a broadcast storm when the usb-c is disconnected.

The PC is connected via PCIe LAN card. The described situation arises when the UTP cable is disconnected.

Ok... thanks for verifying.

I'm not sure why you're experiencing the issue. However, you stated that the PC is using the untagged network. Is that on port LAN1? If so, what happens if you turn VLAN5 off on that port (currently it is tagged). (conversely, if it is on any of the other ports, turn off all the tagged networks and see what happens, both when the cable is connected and when it is disconnected from the PC).

Have you verified that your downstream switches (which you said are running OpenWrt) are properly configured for all of the relevant VLANs and that any/all non-VLAN aware devices are only connected to ports that are configured with a single network (i.e. an access port: 1 untagged network, 0 tagged networks)?

1 Like

A port connected to a PC must be untagged in exactly one VLAN and tagged in no VLANs. This is called an access port.

A port connected to another router should be untagged in no VLANs and tagged in some or all VLANs. This is called a trunk port.

Combining tagged and untagged on one cable is something to do only when you have to connect to an existing network that works that way and you can't change it. This often does not work on consumer grade equipment.

1 Like

Thanks for your advice. I am aware of the combining of tagged/untagged VLANs is not ideal, but it worked with no issues on my previous setup (using TP-Link TL-WR1043ND).
I have tried to configure ports to not use tagged/untagged combination but the router behaves the same. I have no idea how disconnection of one port can cause the whole device stucked. Maybe faulty device?

Which port is the PC connected to?

When you disconnect the ethernet from the PC, how are you testing that the router appears to be unresponsive? Can you draw a diagram of your network and where your tests are happening?

Wired connection is used by PC and server connected to VLAN 8. Other clients are using Wireless connection.
My test:

  • Disconnect PC from LAN.
  • Reconnect my phone's wireless connection -> IP address is assigned but no connection possible outside the LAN (I've tried ping to either domain or IP address in the internet).
  • Connect the PC to LAN -> Outside connection from my mobile is working normally.

Use a ping tool on one of your wireless devices. Then, after you disconnect your PC, ping the following:

  • gateway address (on the respective VLAN)
  • google.com

Report back on the results.

  • gateway address (on the respective VLAN) -> Normal response
  • -> 20 tries, 6 - 9 response OK, others no response/timeout (strange).
  • google.com -> Failed to resolve IP address.

Does the timeout on the ping only happen when the PC is unplugged? (or asked another way, is there a noticeable difference in timeouts with and without the PC plugged in)?

Is your PC serving as your DNS resolver? For example, is PiHole or some other software running on that system that is being used for DNS? Or do you have a outbound VPN connection that is handled by the PC?

PC is just plain client, no service is running there. I have tried some more things, like disconnect the other devices but it didn't help.
For me it seems that it is some combination of used hardware that causes the behavior. I have decided to use another device as a router and it works OK (TP-Link TL-WR1043ND) for now.
I also want to try the EdgeRouter with a new OpenWrt version (21.x.x) once I have some time.
Thank you guys for your help :slight_smile: