Ubiquity EdgeRouter X Major Problem

I have a Ubiquity EdgeRouter X which I believe I loaded OpenWRT on years ago.
I dug it out today, needing to use it in my shop.
Starting it up, I could not contact it. Only Eth0 would light up when I pugged my ethernet cable into it, and no others. It must have lost some configuration, because I would have had all ports open last I used it.
I resorted to the reset button, and tried both ways described by Ubiquity (with power on, and upon connecting power). With power on, the reset does nothing. With reset upon connecting power, Eth4 will flash, then light up, and then only Eth0 wil be lit and flash with supposed traffic.
I've tried the default subnet of 192.168.1.x from Ubiquity and the subnet I would have used (192.168.0.x), but no luck. I've ran an IP scan on both of these subnets.

So I found out that the EdgeRouter X has a serial interface which is available from the circuit board, and I connected a USB to RS232 device to this, where a serial console supposedly can be opened at 57600. Other devices use 115200, but ER-X uses this lower baud rate.

As I connect here, and power up the router, I get a bunch of junk on my screen, but obviously information which is generated by the system.
So I've tried the 115200 baud rate, and all baud rates down to 9600.
I've tried 8,None,1 and 7,Even,1 and 7,Odd,1 with 57600 and 115200.
From looking at the junk I get, 57600 seems to be the correct baud rate.
I've tried swapping Tx/Rx/GND in case I had that wrong, but the only way I get any data is the way I started off, and which should be correct.

So the device doesn't respond to any Ethernet ports, and the serial port gives me garbage.

Have anyone ever seen this, or have a clue what I could try next?
Could OpenWRT change the functioning of the serial port as well, or should this work as Ubiquity describes regardless of whether I run OpenWRT or OEM firmware?


What happens with eth1-4? Did you try other cables?

1 Like

It's 3.3 volt serial not RS-232. Besides the voltage issue, the data polarity is inverted and you'll only see garbled data using the wrong one.


I'll just add to what psherman said already - try eth 1-4 at after a reset.

It's been a while since I've run an ER-X on OpenWrt for my gateway, but I do sort of recall there being something wonky about its default configuration not presenting etho on for a lan connection. Not much help I know - good luck with it.

With Eth1 through 4 I get no lights on when I plug in the ethernet cable. Neither on the laptop or the ER-X.

I've now ordered a 3.3 volt device from China, and will try hooking this up when it arrives. Thank you guys! I will try to update you with results when I get it. Excellent, swift replies. I haven't given up the device entirely yet. Still wondering what would cause this, though...