Ubiquiti UniFi AC Lite - my experience flashing OpenWRT

I have a couple of these UniFi AC Lite APs, older versions from 2016-2017 (before they supported PoE 802.3af, in case various hardware revisions behave differently).

I tried installing OpenWRT according to the instructions here which recommend downgrading to stock firmware v3.7.58 first. That version did not work at all for me. I flashed it via TFTP, then using fwupdate.real -m again, no matter what the unit would come up to the solid white light but would not have the typical IP, it was nowhere to be found on the network, the UniFi Controller could not find it either to adopt it.

I have no idea why but I wasted a lot of time on it, on 2 units. I hope this will save someone else some time.

What worked for me is downgrading to firmware v3.4.7, downloadable from here.
Use fwupdate.real -m to make sure the bootloader is downgraded also.

That of course will end up with bootloader BZ.v3.4.7 but that shouldn't really matter.
From here, I could ssh in and mtd write OpenWRT just fine.

One other note, make sure to mtd erase kernel1 -- I initially did not and instead put the same OpenWRT image on the kernel1 partition also and didn't realize the bs partition first byte was 0x80 so it booted from this partition. This was fun when I moved to a new version of OpenWRT (from 19.07.3 to master snapshot) and I was scratching my head why the kernel was still 4.14 instead of 5.4 and it complained it could not find the modules for that kernel.