Ubiquiti Rocket m2 "upper fs does not support temp file"

Hello all, I'm about a week into this install attempt and am completely out of my depth.
I have 2 rocket M2 units, both XM boards. I'm attempting the same process on both with the same result.
Hardware setup is a windows laptop connected to a simple ethernet switch. M2 is connected to switch and POE box, POE box plugged into wall. Laptop has a static IP set of 192.168.1.21.
Also have a serial connection to the M2 via USB/serial cable
With the stock firmware I can access the web GUI at 192.168.1.20, all looks normal. getting the unit into TFTP mode works fine (either by booting while holding hardware button or by using "urescue" command over serial.
I have tried flashing several different versions of the open WRT firmware (confirming I was using the "factory.bin" file)
Once flashed I no longer can access the web GUI at 192.168.1.20 (expected) nor can I access 192.168.1.1 (which is where I expected to have something) IP scan doesnt show any devices other than my laptop on the network
Over the serial connection I can see the boot up is occuring with the openWRT firmware.
The last message is "overlay fs: upper fs does not support tmpfile"
but, I can hit enter in my serial terminal at that point and the little open wrt splash comes up and I have access to what looks like a pretty normal linux CLI. I've tried effectively every ubiquity firmware I can find, combo'd with openwrt software 22.03.2 and 22.03.5
The goal here is to follow this set of instructions https://atakhq.com/en/manet/openwrt

but I have firmly hit the limits of my knowledge. Can anyone point me in the right direction? searching has not located this exact situation as far as i can find.

That message is normal. It appears that OpenWrt is installed correctly.

Since it has two ports, OpenWrt firstboot sets up one as WAN and the other one will be LAN. You are probably connecting the PC to the WAN port instead of LAN.

ok, well thats good to know.
so about this connecting to the wrong port issue. how can i tell if thats the case, and if so, correct for it
i can see in ifconfig that i have an address of 192.168.1.1 in the 'br lan' area but thats all that really sticks out. any tips on how to correct.

after a little time I've realized (at least i think) you were talking about the ports on the little ethernet switch. Both the cable from the M2 and from the PC are in LAN ports. only have a single ethernet port on each device.

yes I don't have that model though it does look like I was wrong, it only has one port.

Leave the port connected to the PoE box and watch the serial as you connect a laptop to the "lan" side of the POE box. Does it show the port going up and back down when you unplug it?

sorry for the delay here, just getting back to the hardware. Using the "netstat" command over serial and I can't see any difference when the laptop is plugged into the POE lan port vs unplugged. attaching a screenshot of the output im getting. hopefully im not doxxing myself posting this
edit: also, the "LAN" status light on the POE box never lights up when plugged in either

The System Log should show when an Ethernet port goes up or down. The log can be dumped with dmesg. Usually on serial Ethernet up/down events are broadcast to the console.
Are you using the 24 volt PoE box that came with it, which usually looks like this:
image
The only light that box has is the one on the top that means that AC power is coming in. It doesn't indicate any status of the connection.

So my POE box is different, see below. I leaned towards that not being a problem because everything functions as expected on the stock firmware. This stuff is all second hand, didnt even realize this wasnt the stock box. Maybe im oversimplifying it. going to try watching the plug in/unplug via DMESG like you mentioned and will post results momentarily
Note: this picture shows the "lan" led lit, this is connected to my second unit which currently is running the stock firmware

Just confirmed, no change when unplugging the laptop from "lan" side of POE box. no message to serial terminal, and nothing showing in DMESG. Also lan led on poe box and the m2 itself are out. (this is on the M2 running the openwrt software)

I've never seen one of those. The typical box simply shunts the Ethernet signals through between the jacks. On this passive 10/100 system the orange and green pairs aren't involved with power at all, while the blue and brown pairs are only power. It could be a faulty box, or maybe this box interacts with the stock firmware in a way that OpenWrt doesn't.

Ok, the second M2 did have a different POE box with it, will try that when I get back home. If that fails I have 2 more M2's arriving tomorrow, can try those. If all of those still fail, will check back. I appreciate all the help so far.

got home, swapped out the POE boxes, this second one looks like the one you posted with the single LED. same issue though, even though everything i look at for configs on the M2 is calling 192.168.1.1, i have no connectivity between the laptop and the m2 via ethernet. only serial connection works unless i interrupt the boot or send into tftp mode.

have swapped all the ethernet cables, tried with and without a switch between the m2 and laptop. im completely stuck. this has to be something simple, plenty of people have gotten this to work, not sure what im doing that wont work for either of these radios

Does ip link show show that there is an eth port? Are you using the ubnt_rocket-m ath79 build?

Yes, trying both the 22.03.2 and 22.03.5 version of the -ath79-tiny-ubnt_rocket-m-squashfs-factory.bin file. attached below is the output of ip link show. it looks like it sees the ethernet port, just nothing else can