Ubiquiti Loco M5 USB TTL connecting

Hello everyone,
I'm trying to connect USB TTL to Nanostation Loco M5 but no luck. Device is running stock firmware, but friend of mine broke reset bottun, disabled factory reset in settings and of course forgot password.

I did solder header pins to GND, TX and RX. Everything is proprely connected, I did measure resistances between GND, RX and TX and they are 2M and 10M so it should be it.

Connecting using minicom or picocom on linux, tried on different PCs and settings: 115200, 8N1

I get only junk as output in console. Tried different baud rates, but no luck.
Wires are about 20cm in lenght.

When USB is connected and wires plugged into radio and THEN power up radio, I get line of junk and sometimes between i can spot "1" and "Feb" which makes me believe it's date that it shows at boot. Not every time, just sometimes.
Then it hangs for long time and nothing happens, echo doesn't work, nor radio responds to anything i type in.

Another metod is to plug RX and TX, power up radio and wait for a minute or two THEN connect GND.
That way I also get junk, but only few characters which seems to be username in console, eg. "XM.v6.3.1>" or whatever firmware is inside. I'm able to type in, i get (junk) output and sometimes in between junk i can see "help" which would be "unknown command, type --help" or something similar.
Echo kinda works, if i turn it on, it sometimes return ?, but usually works.
For example with echo I type and this shows in console:

I did try to connect RX and TX on USB TTL directly and GND to radio and echo works perfectly.

Feels like I'm trying to bang my head against wall last 2 days, trying to find any info on internet, but nothing helps. Hopefully someone can show me right direction, thank you.

What kind of cable/adapter are you using? Is it CH340 based by chance?

Make sure your USB adapter is operating at 3.3 volts. Check with an ohmmeter that the ground pin is really grounded in the router, it should be zero ohms to ground points like the shield box. Always connect the ground pin. Then check all the way through from the shield box to the USB ground.

yes, this one:

then try to find the alternative

basing on your first post, something is wrong with them usually or..?

thanks for answer, i did it already and seems to be fine

They are just bad. I've seen this myself with USB-Serial cables (w/o TTL) and also seen suggestions like "use xxx but not ch340" in various instructions.
I currently use cp2102 based cable. If you have a RPi or similar device you can probably use it for your purpose.

thanks, gettin' cp2102 cable in next few days then i'll post results.

My apologies, I'm currently using PL-2303, but with this one you will spend some time looking for working Win10 driver (if you're on Win).
CP210x should be good, as well as FTDI chips.

Getting console to work is of course fun by itself. But if the point is to revive this AP then why not just fix the reset button? Adding some (temporary?) way to short the pads cannot be harder than the soldering you already did.

1 Like

good idea.
but i fell into rabbit hole already and want to make sure what i'm doing is right (i have bad TTL adapter) or learn something new.

Understandable. I would be there too :slight_smile:

I've ended up measuring the IO voltage on new TTL adapters before trying them out on a router. I have a number of different adapters with different chips claiming to support both 5V and 3.3V, where the IO voltage is more or less constant and more than 4V. This could fry a 3.3V device, where you should consider 3.6V absolute max.

Don't think the type of chip matters that much..You will get a fake unless you buy from a reputable source. I was. So far I've been lucky FTDI232R fakes. They are certifiable fake, but still seem to implement the level shifter the real chip has. I have mixed experience with PL2303. Got one batch that worked. Bought another one looking more or less like the first one, and got 4.2V IO. The first batch I got of (fake) CP2102 were faulty so I stopped buying those. I also have some working CH340 ones, but I guess that's pure luck.

FWIW, anything FTDI232R based from a reputable source should always work, since it would be very hard to mess up the module having an internal level shifter in the chip. This includes 1.8V routers if the module has a setting for that.

seems like everything is fine with new adapter, thank you very much

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.