Ubiquiti EdgeRouter X, Loading OpenWrt and performance numbers


#62

Connecting to a typical DB-9 will likely fry your router, as most computers and USB adapters with DB-9 connectors work either at TTL levels (5 V), or RS232 levels (nominally +/- 15 V). The latter will almost certainly fry your SoC's serial port at best, potentially your entire SoC. Even TTL levels can be deadly to SoCs.

Only use an adapter that uses 3.3 V logic levels. Many need to be configured with a jumper or solder bridge to set 3.3 V. Others are TTL- or RS232-only and are not appropriate.

Do not connect +3.3V, V+, Vcc, Vss, or the like between the router and the serial adapter; RX, TX, and ground are sufficient.

https://openwrt.org/toh/ubiquiti/ubiquiti_edgerouter_x_er-x_ka#serial


#63

Hi.

I have previously flashed an ERX using the process described on OP.
I just tried to flash another and now I can't connect to it in any way after reboot.

Here is the last logs:

ubnt@ubnt:/tmp$ add system image /tmp/erx-initramfs-factory.tar
Checking upgrade image...Done
Preparing to upgrade...Done
Clearing directory /var/cache/apt (332.0K)...Done
Copying upgrade image.../usr/bin/ubnt-upgrade: line 569: [: too many arguments
Done
Removing old image...Done
Checking upgrade image...Done
Copying config data...Done
Finishing upgrade...Failed to move new image

Any idea what can be done?

Nothing happens from eth1 to 4.
eth0 lights up if I insert cable, but I can't find which IP it is running on if there's any at all.


#64

use tftpboot image using the serial console then write the sysupgrade again


#65

Hi, I found this thread from the EdgeRouterX OpenWrt wiki page. A big thank you to dingbatca for making the openwrt-ramips-mt7621-ubnt-erx-initramfs-factory.tar bootstrap image available and the great instructions. The steps worked perfectly for me yesterday to set up an EdgeRouterX and then upgrade it to 18.06.2. This device is showing great performance using SQM on a 100/100 fibre internet connection. My previous device didn't have the CPU resources to shape traffic at this level.

I was wondering if the OpenWrt file kernel.bin file e.g. "openwrt-18.06.2-ramips-mt7621-ubnt-erx-initramfs-kernel.bin" can be used in the initial EdgeOS "add system image" step? It would be nice to use that file if it works for that purpose. I didn't want to possibly brick the device by just trying!

Thanks,
Tim


#66

Another happy user here. Thanks @dingbatca for the great walkthrough!

On a gigabit cable connection (Comcast). With hardware offload, hitting in the mid 900's for download, right around 40 upload. Bufferbloat on downloads is staying under 20ms, and uploads ranges between 30 and 100.

With SQM enabled, hitting right at 200/40 but bufferbloat numbers aren't much better than the above (20-40 on average). So for now, staying with hardware offload.


#67

For testing SQM you must set the speeds low enough that you have at least a little CPU idle time, try 180/35 and see what the delay under load looks like...


#68

Try leaving the download shaper set at zero and keep using offloads for that, but try an upload only shaper; given your bufferbloat results this might both give better upload experience and still maintain high download bandwidth.


closed #69

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.