Ubiquiti Edgerouter install failed. What do I do now?

Thanks for anyone reading this first of all.

Just installing Openwrt on my ubiquiti edgerouter X SFP.
There one extra step to install per the device page (https://openwrt.org/toh/ubiquiti/ubiquiti_edgerouter_x_er-x_ka), and that is to install a specially created .tar file first and then upgrade to normal openwrt.
I did everything by the book, but after the file was uploaded I got a ubiquiti "router disconnected" message, and since then I got nothing.
No ubiquiti OS response, No Openwrt response.
What should I do now?

*made sure to wait a few minutes after uploading the firmware
*made sure to switch the cable from eth0 to eth 1

Really Really appreciate any help, first time with a failed install not sure how to proceed.
Thanks.

You probably just forgot to switch your lan cable from eth0 to eth1. Just plugin eth1 to your PC (setup with static IP e. g. 192.168.1.100/255.255.255.0) and access to webinterface 192.168.1.1. Then upload the final firmware.

1 Like

That was my first instinct, but no, doesn't help.
Still Can't access ubiquiti OS or Openwrt.

What should I try? Failsafe mode? Reverting to Stock Firmware?
I'm stuck.

Thanks you very much for any help in advance

How did you flash?

I guess you don't have an USB-to-TTL adapter*. This make things for me a bit difficult because I've no experience with other methods then USB-TTL method.

Basically you have two methods: Either Ubiquity TFTP recovery or OpenWrt recovery.

But now it is getting nasty because there is no direct route back from OpenWrt to EdgeOs. So the changes are significant.

The Ubiquiti EdgeOS distributions cannot be directly re-installed by OpenWrt.

We don't know the state of the device and we/I don't know if the Ubiquity TFTP recovery can fix the changes made by OpenWrt.

I would first try Ubiquity TFTP recovery:

Please choose the file according to your branch (v1/v2) you had before you tried to flash. This may be important!

If that is failing you could try to create the image referenced under "Reverting to Stock Firmware" and try to flash this first and in a second step the original firmware.

*
  • If you have USB-TTL just follow the steps under "Debricking".
1 Like

This will sound trivial, but I don't know the firmware version (branch), or how to find it.
I have the box and the router, any way to gather that info from those things?
Tried the ubiquiti discovering tool, doesn't do a thing.

P.S.
Can't ping the router (nothing comes back)
Can Put it into TFTP recover mode with the reset button

Thanks a lot

If you can't get the lights to flash indicating TFTP recovery is active, you must have an old version of the bootloader which doesn't support that feature. Only recently Ubiquiti added the TFTP recovery, I don't know if many or any units shipped with it already installed.

In that case you will need a serial connection.

1 Like

Thx for pointing this out @mk24! I forgot about already. The wiki device page is confusing and includes outdated informations.

So your lights lighten up like described here: https://help.ui.com/hc/en-us/articles/360019289113-EdgeRouter-TFTP-Recovery#4

If so then you are running a newer bootloader and you should be able to recover.

Sry. I don't know how to gather that information without access to the device itself. Did you make a backup of the original firmware? If so you will find the build version within the mtd0 partition image (~ at hex address: 0001ad90) e. g. U-Boot 1.1.3 (UBNT Build Version: e50_002_4c817) May 27 2019 - 06:37:33. If it is dated before 08/2018 you have the older bootloader.
But if you cannot use the reset button method to flash I would assume it is an older version. So firmware version 1.10.5 and older.

I would recommend to get a serial adapter. It costs about ~10€ here in Europe. If you have a raspberrypi or arduino you could use them also.

1 Like

If nobody updates the devicpage, it will stay outdated.

1 Like

Well, that's true. I could try to update it. But I don't have any clue about editing those pages nor what is allowed to do (I would delete a lot to keep it tight :smiley: ). And I don't even know what is expected to be in thoses pages because every page looks different in layout and content. E. g. I would not put in pictures about the packaging like done at the page in discussion here. Beside that I don't own the SFP nor RP version and I'm lacking deeper knowledge about this device in general (e. g. PoE). I'm using it since a few weeks now only.

If wished I could try to write sth. for the EdgerouterX in particular.

1 Like

What is expected: Everything that helps other users to install OpenWrt, and possibly how to get back to stock firmware.

If you would like to contribute to the wiki, but don't know how, just drop me a PM and I will assist. :slight_smile:

1 Like

OK, here where I'm now:
I'm trying to upload the firmware from the software (tftp 2) to the router. I can get a ping to the router too.
But when I upload the firmware, about 10 second later the process stop and I get a " unable to connect" message. It stops halfway
Everything else seems fine. Any suggestions?

Thanks you all again

What software do you try to flash? Are you running a serial connection now? I guess so.

If you want to go back to ubiquiti firmware you need to revert the changes first (that's why direct write to flash is not working (I guess so). Follow the steps under section: "Reverting to Stock Firmware" of the Wiki page.

But there is a clip where I'm unsure. As we don't know what Bootloader version you have I would verify the Bootloader version first and go with either 1.xx or 2.xx for creating this image (according to your bootloader version). You don't need the exact version mentioned in the wiki. I did it with two different 2.xx versions already (because I upgraded the bootloader) and it worked.

If you still want OpenWrt use the option "1" and load the firmware into RAM. Therefore use this file: http://downloads.openwrt.org/releases/19.07.4/targets/ramips/mt7621/openwrt-19.07.4-ramips-mt7621-ubnt-erx-initramfs-kernel.bin
After it is loaded into RAM swap your LAN cable to eth1 and access https://192.168.1.1. There should be a plain upload page where you upload final image: http://downloads.openwrt.org/releases/19.07.4/targets/ramips/mt7621/openwrt-19.07.4-ramips-mt7621-ubnt-erx-squashfs-sysupgrade.bin

No, I'm trying TFTP with normal Ethernet cable.
I Tried to flash Openwrt/ubiquiti offical firmware/ that TAR file from open wrt - same exact result - 5 seconds in the software (tftp2, ddwrt gui) stop the gives me "unable to connect".
The Ip is 192.168.1.20
password is blank (tried root and ubnt too)

P.s.
It's a 2020 router, it's probably V2 boot-loader in my opinion.
Tried to verify with ubiquiti discovery tool, it doesn't recognize the router

nothing seems to work.
I'm really disppointed at this point.
Any suggestion?
Can I use the warranty on it? return it?

Should I try to TFTP over the windows built in tool?
I really don't care if the router has Openwrt or ubiqiti OS, just trying to get it to not be a brick

Don’t assume this. That may ship with ancient firmware and boot loader files because of the nature of the manufacturing process (changing these things can affect the end of line testing and a few other process steps). If you did not explicitly check the firmware and boot loader versions prior to making modifications, you really cannot know for sure. Opinion doesn’t really help here, unfortunately.

1 Like

Well, if Ubiquiti TFTP Recovery is not working for you, you can either assume that the bootloader is older then that is needed for this process or assume that there is a more severe error.

My device is a few month old and came with v1.10.10. I would assume the same for you. But it is very difficult to diagnose without serial connection.

Your best bet you can have the error is (as mentioned in recovery section):

Addendum: above procedure did not work on an Edgerouter X SFP as somehow the version information did not get set; any attempt to upgrade from the EdgeOS caused kernel panic. But found another way on the Ubnt forum, so all credits there. Have put it in the form of a script.

The important part here is (IMO): "ubimkvol /dev/ubi0 --vol_id=0 --lebs=1925 --name=troot"
I had a similar issue on my non sfp device. I was not able to flash directly. I had to format before flash. So this can happen to all devices (IMO). Because of this:

ubi0: good PEBs: 1981, bad PEBs: 1, corrupted PEBs: 0

If you have bad/corruped flash cells on your device. But I'm not an expert when it comes to flash devices.

You cannot repair your device without a serial connector.

1 Like

You can only flash a device with a serial connector? Just want to make sure

Not in general. The design (esp. Ram and Flash) of EdgerouterX is limited. In the past it wasn't even possible to make a tftp recovery without serial.
In your case you cannot (for whatever reason) flash with the usual methods described on device' wiki or desribed by Ubiquiti.
You have three options:

  • ask for support in the official Ubiquiti forum (they have better knowledge than I have)
  • ask for a "repair" by Ubiquiti (rma)
  • buy a serial connector and try to fix it by yourself

Thanks a lot pwned, for everything.

I was talking with ubiquiti support the all along, they don't have any better suggestion (SSH didn't worked either).
Seems like a lost cause right now.
The only thing I didn't try is to use the windows built in TFTP tool to recover, But I can't fine a good how to for it, any suggestions?

Don't forget to disable your firewall!