Ubiquiti AP Mesh - OpenWrt Mesh over 5GHz

Hello,

I am trying to set up a l2 mesh over 5 ghz frequency. There is a backery next to me and they want to extend this free wifi project.

I tryed to go throw the documentation on openwrt.org.

https://openwrt.org/docs/guide-user/network/wifi/mesh/80211s

But didnt get the wifi interface up. Then I read the logs and searched for raw mode. Within this topic I get the Mesh Up and running.

But only with the default channel 36 and width 80 mhz. But in germany there I have to use channels over 100 with dfs in outdoor areas.

When I switch to channel 100 width 20 mhz I got these messages...

root@FreeWiFiPepitaAP01:~# logread -f | grep wpa
Mon Jul 20 13:57:02 2020 daemon.notice wpa_supplicant[6970]: wlan0: DFS-CAC-COMPLETED success=1 freq=5500 ht_enabled=1 chan_offset=0 chan_width=1 cf1=5500 cf2=0
Mon Jul 20 13:57:02 2020 daemon.err wpa_supplicant[6970]: Using interface wlan0 with hwaddr 74:83:c2:ce:1b:5f and ssid ""
Mon Jul 20 13:57:02 2020 daemon.notice wpa_supplicant[6970]: wlan0: interface state DFS->ENABLED
Mon Jul 20 13:57:02 2020 daemon.notice wpa_supplicant[6970]: wlan0: AP-ENABLED
Mon Jul 20 13:57:02 2020 daemon.notice wpa_supplicant[6970]: wlan0: joining mesh FreeWifiPepitaMesh
Mon Jul 20 13:57:02 2020 daemon.notice wpa_supplicant[6970]: wlan0: CTRL-EVENT-CONNECTED - Connection to 00:00:00:00:00:00 completed [id=0 id_str=]
Mon Jul 20 13:57:02 2020 daemon.notice wpa_supplicant[6970]: wlan0: new peer notification for 74:83:c2:38:dc:d5
Mon Jul 20 13:57:02 2020 daemon.notice wpa_supplicant[6970]: wlan0: Mesh MPM: failed to send peering frame
Mon Jul 20 13:57:02 2020 daemon.notice wpa_supplicant[6970]: wlan0: Mesh MPM: failed to send peering frame
Mon Jul 20 13:57:02 2020 daemon.notice wpa_supplicant[6970]: wlan0: Mesh MPM: failed to send peering frame
Mon Jul 20 13:57:02 2020 daemon.notice wpa_supplicant[6970]: wlan0: Mesh MPM: failed to send peering frame
Mon Jul 20 13:57:02 2020 daemon.notice wpa_supplicant[6970]: wlan0: new peer notification for 74:83:c2:38:dc:d5
Mon Jul 20 13:57:02 2020 daemon.notice wpa_supplicant[6970]: wlan0: Mesh MPM: failed to send peering frame
Mon Jul 20 13:57:02 2020 daemon.notice wpa_supplicant[6970]: wlan0: Mesh MPM: failed to send peering frame
Mon Jul 20 13:57:02 2020 daemon.notice wpa_supplicant[6970]: wlan0: Mesh MPM: failed to send peering frame
Mon Jul 20 13:57:03 2020 daemon.notice wpa_supplicant[6970]: wlan0: Mesh MPM: failed to send peering frame
Mon Jul 20 13:57:03 2020 daemon.notice wpa_supplicant[6970]: wlan0: new peer notification for 74:83:c2:38:dc:d5
Mon Jul 20 13:57:03 2020 daemon.notice wpa_supplicant[6970]: wlan0: Mesh MPM: failed to send peering frame
Mon Jul 20 13:57:03 2020 daemon.notice wpa_supplicant[6970]: wlan0: Mesh MPM: failed to send peering frame
Mon Jul 20 13:57:03 2020 daemon.notice wpa_supplicant[6970]: wlan0: Mesh MPM: failed to send peering frame
Mon Jul 20 13:57:03 2020 daemon.notice wpa_supplicant[6970]: wlan0: Mesh MPM: failed to send peering frame
Mon Jul 20 13:57:03 2020 daemon.notice wpa_supplicant[6970]: wlan0: new peer notification for 74:83:c2:38:dc:d5
Mon Jul 20 13:57:03 2020 daemon.notice wpa_supplicant[6970]: wlan0: Mesh MPM: failed to send peering frame
Mon Jul 20 13:57:03 2020 daemon.notice wpa_supplicant[6970]: wlan0: Mesh MPM: failed to send peering frame
Mon Jul 20 13:57:03 2020 daemon.notice wpa_supplicant[6970]: wlan0: Mesh MPM: failed to send peering frame
Mon Jul 20 13:57:03 2020 daemon.notice wpa_supplicant[6970]: wlan0: Mesh MPM: failed to send peering frame

This is my Wireless Config in HQ AP

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option country 'DE'
        option txpower '20'
        option htmode 'VHT20'
        option channel '100'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/ahb/18100000.wmac'
        option htmode 'HT20'
        option channel '9'
        option country 'DE'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option mode 'ap'
        option encryption 'none'
        option short_preamble '0'
        option isolate '1'
        option ssid 'Free WiFi Pepita'
        option network 'PAN'

config wifi-iface 'wifinet1'
        option mesh_rssi_threshold '0'
        option encryption 'none'
        option device 'radio0'
        option mode 'mesh'
        option mesh_fwding '1'
        option mesh_id 'FreeWifiPepitaMesh'
        option network 'PAN'

Backery AP

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:00.0'
        option txpower '20'
        option country 'DE'
        option htmode 'VHT20'
        option channel '100'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/ahb/18100000.wmac'
        option htmode 'HT20'

config wifi-iface 'wifinet1'
        option mesh_rssi_threshold '0'
        option encryption 'none'
        option device 'radio0'
        option mode 'mesh'
        option mesh_fwding '1'
        option mesh_id 'FreeWifiPepitaMesh'
        option network 'MESH mesh'

config wifi-iface 'wifinet2'
        option ssid 'OpenWrt'
        option encryption 'none'
        option device 'radio1'
        option mode 'ap'
        option network 'mesh'

Within channel 36 and width 80 mhz all is fine....

I found a table at ctaas.de

I tried a lot channels but nothing worked.

Can you support me ?

I found this today

https://bugs.openwrt.org/index.php?do=details&task_id=3214&openedfrom=-1+week&order=id&sort=desc&order2=severity&sort2=desc

With US code DFS is activated on channel 100 and it works fine. I hope in new firmware this bug is fixed.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.