UART - wrong char echo[SOLVED]

Hello!

I have 4 USB->UART converters, on chips: FTDI232, CP2102, pl2303 and ch341.
Linux understand well all 4 converters, with out any problems.
And I have: 6 different TP-Link routers and one Netis.
All this converters works well with all routers except one: TP-Link Archer C5 HW ver 4.0

On TP-Link Archer C5 HW ver 4.0 I see normal system output, but when input see wrong chars.
For example my input: 12345
Terminal answer is: 1g233f4^Y5e
The same result in putty and screen programs.

P.S. PC system: Kubuntu 18.04 x64
User ttyUSB0 115200n8 for TP-Link
User ttyUSB0 38400n8 for Netis

The TX data on the board potentially needs a pull-up

Edit: At least I think it was the TX on the board = the RX on the adapter -- my test unit isn't immediately available. Though my last post in the preview-boxed thread suggests that I ended up pulling up the RX pin on my TP-Link

See, for various references:

https://openwrt.org/toh/tp-link/archer-c5-c7-wdr7500#recovery_using_serial_connection

https://openwrt.org/toh/tp-link/archer-c5-c7-wdr7500#serial

https://lists.openwrt.org/pipermail/openwrt-devel/2016-November/003774.html

1 Like

Thanks a lot, it works!

I am not a electronic engineer.
But I have a tester and luckly I have 120MB HDD manufactured in 1992.
On that HDD I found required resistor :grinning:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.