UAP AC-IW mostly working

Yep, I found the IW section you added to the UniFi AP AC page, and thanks to that, all ports work perfectly.

Sure, if you're interested in disabling passive PoE by (literally) hacking PCB traces, I'll post here if & when I figure that out.

For others experimenting the first time & worried (like me) about rendering their device non-returnable: Along the way, I did get locked out; N.B.: the UAP PRO and the UAP AC PRO are NOT the same firmware. :stuck_out_tongue: I was all ready to solder in headers, but it turned out the device was happy to let me start all over again with the TFTP method to flash the OEM firmware & install the correct OpenWRT firmware from there, so no headers needed to unbrick.

Now that the device is proven & I know it's a keeper, I'll solder in headers when I have it open for the PoE mod experiment.

One other issue I wasted an HOUR on (maybe applicable to all ath10k devices, and maybe more beyond that!): For some reason, the 2.4GHz radio1 comes up very quickly, but the 5GHz radio0 takes 1-2 minutes. When the latter didn't come immediately, I thought something must be wrong, and started a rapid cycle of tweak/reboot/check-radio0/repeat. Only after starting to run out of ideas did I slow down enough that hostapd could finally finish its business, and everything worked perfectly after that. To those buzzing along at warp speed like me, just be patient: sometimes slow is fast!

Edit: Added untested initial support in my OpenWRT GH fork

I would be interested in learning how to disable the passive POE if you ever do find out about it

And I should edit that post on the wiki page and note that, yes, it's very hard to brick these devices and you can always revert back to stock if you're not happy with it. I did that a number of times when I was first experimenting with it

Would you be able to dump the output of

BZ.v3.7.58:# cat /dev/mtd0 | md5sum

For some reason my UAP-AC-IW is refusing to boot with both 19.07.5 ath79 and ar71xx AC PRO binaries, I do not have the serial dongle with me at the moment so I am not sure what is happening during boot process. ar71xx will response to 192.168.1.1 ping from port 3 during boot for like 1-2 times before it stop working, ath79 will give a solid blue led and not responding to anything.

I may be able to in a few days when I get a chance to plug in one of the units I have already updated to openwrt

Port 3 in your description is the one on the bottom without the passive poe? The behavior you're describing seems like what I see on the port on the backside where you power the device and that's the one I'm calling Port 1 earlier in here.

I tried both ports, port 3 is the one that give me the 1-2 ping response to 192.168.1.1, the rear port does not response at all. My serial ttl is busted, I guess I will try again once Zultron patch is approved and merged.

Hi, I've just followed the instructions and installed 19.07.8 on my AC-IW. The behaviour I see is slightly different however. Access is only available on Port 2 (PoE - left hand from top) nothing on Port 3. I have made the changes in 'network' but I think I'm still missing something. Should it be possible to configure this as if the Port 1 (rear PoE in) is a WAN interface (NAted)? Any clues would be much appreciated.

Answered my own question, always happens as soon as I ask on a forum!

image

yes, this is normal. The forum serves as a rubber duck. See https://en.wikipedia.org/wiki/Rubber_duck_debugging

I have a UniFi AP AC IW Pro so UAP-AC-IW-PRO

Not UAP-AC-IW

Should I be able to get this to work?

Yes, I have two Pro versions set up this way and they work fine. No differences that I remember in the setup.

@zultron Can you get your patches pushed upstream as the device is the "same but different" than the actual AC Pro? For now, I will just pull in your commits from your repo and deal with them locally.