U-boot bootdelay=0 am i hardbricked?

Hey fellas, i might have made a big mistake i tried to install openwrt on my device by following the guide on wiki.
after flashing from the stock updater the device restarted and went into a bootloop so i soldered in a serial port... but uboot bootdelay is set to 0 and i cant interrupt or choose tftp flash.
Do i have any chance of a recovery or all thats left is a full flash reprogram?

Have you tried the usual BIOS SOP=push the button a trillion times during the whole boot until it stops?

which device and version it is?

The device is a Belkin F5D8235-4 v2

I used this bin:

I tried holding reset and wps buttons while powering up the device but doesnt make a difference it just goes to option 3 (boot from flash) in uboot really quickly fails to boot and its stuck in an infinite reboot loop. Tried sending ctrl+c and space over serial aswell but nothing.

Usually you are supposed to press esc or “any key” on the keyboard on the computer connected to the router with serial.

Actually just as it say on the countdown line in the serial terminal.

Theres no countdown, thats how i came to the conclusion that the bootdelay is 0 in uboot config

It could be one second countdown but the serial connection is to slow to catch it as a countdown.
That is why you hit the button all the time, to send out the interrupt no matter what is displayed.


Yeah i get it, but i tried, i was holding the button down while it was booting, but it instantly just goes to the default option (3)
Why would any build have bootdelay=0 without any failsafe makes no sense to me.

Ok, i found the problem thanks to you, you were right its still possible to interrupt the boot even with low bootdelay...
It turns out i had TX on the wrong pin all along.... i have no words.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.