Type mismatch trying upgading ZBT-WE3526

i'm trying to upgrade my ZBT-WE3526 which is a 16M (FLASH) and 512 (DRAM) (I guess because the dmesg did not give something relevant) and the overview page did not give me this information (except maybe architecture MediaTek MT7621 ver:1 eco:3, the firmware version installed OpenWrt 19.07.9 r11405-2a3558b0de / LuCI openwrt-19.07 branch git-22.115.68448-712bc8e) to the last version of openwrt (22.03).
The problem is the message "Device zbtlink,zbt-we3526 not supported by this image Supported devices: zbtlink,zbt-we3526 - Image version mismatch: image 1.1, device 1.0." I'm not able to clearly understand and see the consequence (brick the router or not, lose my configuration or not, etc etc)

Does anyone has done it with success ? Am I using a wrong version of firmware ?
If someone can helps ? Thank you

19.x > 22.x is a major change.

Do a backup and start from zero.

Thank for answering. I guess I can copy the previous system files such like /etc/config/* ?

You can copy them, and use for reference, but you shouldn't copy them back, at least not blindly.

1 Like

No, please do not copy /etc/config/* -- this will almost certainly soft-brick your router.

How complex is your configuration? In many cases, it is easy enough to setup from scratch (using the backup as a human-readable reference, when needed) in ~10 minutes. If you have a really complex config, you may be able to copy some files (or more safely, certain 'stanzas' of the config files) over. But this needs to be done with care. The network and wireless files should not be copied over, but you could grab things like a wireguard configuration or static routes and copy those through.

The firewall file may or may not be compatible, depending on what rules you have in there.

So what specific files are you trying to copy over?

1 Like

Oooooppppsss I did it :wink:
Actually, the first time I tried to copy the dhcp, firewall, ddns files the router was stuck
So I finally compare each defintion inside each file, and the difference was on the rules which forward ports in the firewall file and now it works fine
To be honest, I have 15 NAT rules, and over 20 static IP so I didn't imagine to copy them manually
Thanks for help and advice. I managed to migrate my router to the last version of OpenWrt

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.