Two WLAN networks won't enable

Hello,

I've created two wireless networks, one is meant as a guest network.
However, one networks works fine.
If I add another one and also associate it with device "br-lan", both show as "disabled" but shows a BSSID and Encryption info.
The 2nd one says "Wireless is not associated" (both under /cgi-bin/luci/admin/network/wireless the "wireless overview").

What did I miss...?

We would need to see your config to get info about what is wrong.

In general, though, you want to follow the guest WiFi tutorial.

https://openwrt.org/docs/guide-user/network/wifi/guestwifi/configuration_webinterface

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
2 Likes

Well, I first followed these instructions when trying to setp a printer via WPS (no display, cannot teach it a PW so WPS the only option but it won't work).

Now my 1st network is also "disalbled" and despite restarting/disable-enable actions, it remains at status "disabled" in the GUI (and in fact). Earlier the 1st wireless worked when I disabled the guest network (using the GUI in that case).

The wireless config file looks as follows (comments added here, not in the file):

config wifi-device 'radio0'
        option type 'mac80211'
        option path '18000000.axi/bcma0:7/pci0000:00/0000:00:00.0/0000:01:00.0/bcma1:1'
        option channel 'auto'
        option band '2g'
        option txpower '20'
        option cell_density '0'
        option legacy_rates '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'SSID-name'
        option encryption 'sae-mixed'
        option key 'desiredPW'
        option ieee80211w '1'
        option wps_pushbutton '1'  #added manually

config wifi-iface 'wifinet1'
        option device 'radio0'
        option mode 'ap'
        option ssid 'GUEST'
        option encryption 'sae-mixed'
        option key 'desiredPW'
        option network 'lan'
        option disabled '1'  #deliberately disabled

The network config file looks like this:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fa1a:dc42:1c72::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan1'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr 'IP.ADDRESS'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'wan'
        option macaddr 'MAC:ADDRESS'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

Here's the DHCP config file:

config dnsmasq
        option domainneeded '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '30d'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config host
        option name 'NAME-1'
        list mac 'MAC:ADDRESS'
        option ip 'IP.ADDRESS'
        option leasetime 'infinite'

config host
        option name 'NAME-2'
        list mac 'MAC:ADDRESS'
        option ip 'IP.ADDRESS'
        option leasetime 'infinite'

And the firewall config:

        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-IPSec-ESP
        option src              wan
        option dest             lan
        option proto            esp
        option target           ACCEPT

config rule
        option name             Allow-ISAKMP
        option src              wan
        option dest             lan
        option dest_port        500
        option proto            udp
        option target           ACCEPT

Update:

I removed

option wps_pushbutton '1'

and et voila, the wireless network came back on!

So adding another wireless network, linked to br-lan as well as adding an explicit WPS option seems to kill it. There must be a conflict somwehere.
I'll work through the guest network instructions tomorrow, but unfortunately this also means at the moment that I cannot connect the printer as WPS seems the only way to integrage it into the network (without a display or any way to teach the printer the network PW).
To be continued...