Two ssid's, two networks

I've two ssid's let say one of them charlie, other is delta. if a wireless device connects on charlie, I want this device to get ip from 192.168.4.x network or if connects on delta, get ip from 192.168.5.x. network.

how can I do this?

You bridge it to the accordingly configured networks.

Yes, I would seperate this with different vlans:

/etc/config/network

config interface 'homeone'
	option device 'switch0.40'
	option proto 'static'
	option ipaddr '192.168.4.x/24'


config interface 'hometwo'
	option device 'switch0.41'
	option proto 'static'
	option ipaddr '192.168.5.x/24'

/etc/config/wireless

config wifi-iface 'radio0_if0'
	option device 'radio0'
	option network 'homeone'
	option mode 'ap'

config wifi-iface 'radio0_if1'
	option device 'radio0'
	option network 'hometwo'
	option mode 'ap'

Something like that.

The example is conceptually correct, but will not work because the device would actually need to be a bridge if the networks would be used on both wired and wireless physical interfaces. If the networks would be wireless only, the option device ... line could simply be removed and it would work.

In most cases, it is desirable to setup a DHCP server, and also assign the networks to a firewall zone with appropriate forwarding allowances and rules to set the desired level of inter-network routing (from completely forbidden to completely open).

1 Like

Really great video to help you (two actually), although there were made under an older version of OW:

This is a more recent one that covers the same concepts on OW 20 I believe:

1 Like

thanks for the help. :smiley:

here is what I did;

I had a default setup at intefaces;
lan (br-lan)
wan (wan9
wan6 (wan)

device br-lan had lan1 and lan2 in bridged ports option. I removed lan2 from bridged ports so lan2 is no longer connected to any interface.

I've created a new device named br-lan2 and I've selected lan2 in bridged ports menu and save it.

then I've created a new interface named lan2. I've selected br-lan2 from device option, selected static address from protocol option and defined static ip address 192.168.5.1 and selected lan at firewall tab and enable dhcp from dhcp server tab. you can create a new firewall zone and select it from firewall tab if you want to seperate 192.68.5.0/24 network from other networks.

then I've edit ssid delta and from general tab I've selected lan2 from network option.

that's all. when I select ssid charlie from wireless device, I've joined 192.168.4.0 network and if I selected ssid delta, I've joined 192.168.5.0 network.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.