Two SSIDs cannot be up at the same time

Running snapshot from 28-Aug-2021 on Archer A6 V3 and am unable to bring up two SSIDs at once. When I try, both go offline.

One of these is mapped to my guest interface and the other mapped to my lan interface. In tern, these are on different VLANs via DSA tagging; lan uses VLAN1 and guest uses VLAN3 as you see below. Port 3 physically connects this AP to the primary router.

Could a misconfiguration in the DSA VLAN tagging cause this or is something else at work? Note the image came with wpad-basic-wolfssl installed and I also tried using hostapd-basic-wolfssl but got the same result.

/etc/config/network
config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fddc:3583:2589::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option proto 'static'
	option ipaddr '10.9.8.3'
	option gateway '10.9.8.2'
	option netmask '255.255.255.0'
	option device 'br-lan.1'
	list dns '10.9.8.2'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

config bridge-vlan
	option device 'br-lan'
	option vlan '1'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config bridge-vlan
	option device 'br-lan'
	option vlan '3'
	list ports 'lan3:t'

config interface 'guest'
	option proto 'static'
	option device 'br-lan.3'
	option gateway '172.17.2.2'
	option netmask '255.255.255.0'
	option ipaddr '172.17.2.3'
	list dns '172.17.2.2'
/etc/config/wireless
config wifi-device 'radio0'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option disabled '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
        option channel '36'
        option band '5g'
        option htmode 'VHT20'
        option cell_density '0'

config wifi-iface 'wifinet0'
        option device 'radio1'
        option mode 'ap'
        option ssid '5GHz-primary'
        option encryption 'sae'
        option key '4jxK3k.adPm3.'
        option ieee80211w '2'
        option network 'lan'

config wifi-iface 'wifinet1'
        option device 'radio1'
        option mode 'ap'
        option ssid '5GHz-guest'
        option encryption 'sae'
        option key 'Welcom3H0m3_2021'
        option ieee80211w '2'
        option network 'guest'

And a few screenshots from luci:
85.i

Here is bringing up the two one-at-a-time:

Sat Aug 28 17:45:33 2021 daemon.notice hostapd: Configuration file: /var/run/hostapd-phy1.conf (phy wlan1) --> new PHY
Sat Aug 28 17:45:33 2021 kern.info kernel: [  472.690705] br-lan: port 5(wlan1) entered blocking state
Sat Aug 28 17:45:33 2021 kern.info kernel: [  472.696088] br-lan: port 5(wlan1) entered disabled state
Sat Aug 28 17:45:33 2021 kern.info kernel: [  472.702117] device wlan1 entered promiscuous mode
Sat Aug 28 17:45:33 2021 kern.info kernel: [  472.797380] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
Sat Aug 28 17:45:33 2021 kern.info kernel: [  472.804003] br-lan: port 5(wlan1) entered blocking state
Sat Aug 28 17:45:33 2021 kern.info kernel: [  472.809414] br-lan: port 5(wlan1) entered forwarding state
Sat Aug 28 17:45:33 2021 daemon.notice hostapd: wlan1: interface state UNINITIALIZED->ENABLED
Sat Aug 28 17:45:33 2021 daemon.notice hostapd: wlan1: AP-ENABLED
Sat Aug 28 17:45:34 2021 daemon.notice netifd: Network device 'wlan1' link is up

But when I bring up the 2nd one:

Sat Aug 28 17:49:00 2021 daemon.notice hostapd: Remove interface 'wlan1'
Sat Aug 28 17:49:00 2021 daemon.notice hostapd: wlan1: interface state ENABLED->DISABLED
Sat Aug 28 17:49:00 2021 daemon.notice hostapd: wlan1: AP-DISABLED
Sat Aug 28 17:49:00 2021 daemon.notice hostapd: wlan1: CTRL-EVENT-TERMINATING
Sat Aug 28 17:49:00 2021 daemon.notice hostapd: nl80211: deinit ifname=wlan1 disabled_11b_rates=0
Sat Aug 28 17:49:00 2021 kern.info kernel: [  680.281600] device wlan1 left promiscuous mode
Sat Aug 28 17:49:00 2021 kern.info kernel: [  680.286324] br-lan: port 5(wlan1) entered disabled state
Sat Aug 28 17:49:00 2021 daemon.notice netifd: Network device 'wlan1' link is down
Sat Aug 28 17:49:01 2021 daemon.notice hostapd: Configuration file: /var/run/hostapd-phy1.conf (phy wlan1) --> new PHY
Sat Aug 28 17:49:01 2021 kern.info kernel: [  681.309845] br-lan: port 5(wlan1) entered blocking state
Sat Aug 28 17:49:01 2021 kern.info kernel: [  681.315199] br-lan: port 5(wlan1) entered disabled state
Sat Aug 28 17:49:01 2021 kern.info kernel: [  681.321335] device wlan1 entered promiscuous mode
Sat Aug 28 17:49:01 2021 kern.info kernel: [  681.326431] br-lan: port 5(wlan1) entered blocking state
Sat Aug 28 17:49:01 2021 kern.info kernel: [  681.331794] br-lan: port 5(wlan1) entered forwarding state
Sat Aug 28 17:49:01 2021 kern.info kernel: [  681.356549] br-lan: port 5(wlan1) entered disabled state
Sat Aug 28 17:49:02 2021 kern.info kernel: [  681.436312] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
Sat Aug 28 17:49:02 2021 kern.info kernel: [  681.443025] br-lan: port 5(wlan1) entered blocking state
Sat Aug 28 17:49:02 2021 kern.info kernel: [  681.448426] br-lan: port 5(wlan1) entered forwarding state
Sat Aug 28 17:49:02 2021 kern.info kernel: [  681.463074] br-lan: port 6(wlan1-1) entered blocking state
Sat Aug 28 17:49:02 2021 kern.info kernel: [  681.468681] br-lan: port 6(wlan1-1) entered disabled state
Sat Aug 28 17:49:02 2021 kern.info kernel: [  681.474819] device wlan1-1 entered promiscuous mode
Sat Aug 28 17:49:02 2021 daemon.err hostapd: Could not set interface wlan1-1 flags (UP): No such file or directory
Sat Aug 28 17:49:02 2021 kern.info kernel: [  681.526818] device wlan1-1 left promiscuous mode
Sat Aug 28 17:49:02 2021 kern.info kernel: [  681.531499] br-lan: port 6(wlan1-1) entered disabled state
Sat Aug 28 17:49:02 2021 daemon.err hostapd: Failed to add BSS (BSSID=ce:32:e5:01:eb:bf)
Sat Aug 28 17:49:02 2021 daemon.err hostapd: Interface initialization failed
Sat Aug 28 17:49:02 2021 daemon.notice hostapd: wlan1: interface state UNINITIALIZED->DISABLED
Sat Aug 28 17:49:02 2021 daemon.notice hostapd: wlan1: AP-DISABLED
Sat Aug 28 17:49:02 2021 daemon.err hostapd: wlan1: Unable to setup interface.
Sat Aug 28 17:49:02 2021 daemon.notice hostapd: nl80211: deinit ifname=wlan1 disabled_11b_rates=0
Sat Aug 28 17:49:02 2021 kern.info kernel: [  681.790083] device wlan1 left promiscuous mode
Sat Aug 28 17:49:02 2021 kern.info kernel: [  681.794831] br-lan: port 5(wlan1) entered disabled state
Sat Aug 28 17:49:02 2021 daemon.notice hostapd: wlan1: CTRL-EVENT-TERMINATING
Sat Aug 28 17:49:02 2021 daemon.err hostapd: hostapd_free_hapd_data: Interface wlan1 wasn't started
Sat Aug 28 17:49:02 2021 daemon.notice hostapd: wlan1-1: CTRL-EVENT-TERMINATING
Sat Aug 28 17:49:02 2021 daemon.err hostapd: hostapd_free_hapd_data: Interface wlan1-1 wasn't started
Sat Aug 28 17:49:02 2021 daemon.notice netifd: radio1 (8624): Command failed: Invalid argument
Sat Aug 28 17:49:02 2021 daemon.notice netifd: radio1 (8624): Device setup failed: HOSTAPD_START_FAILED

Maybe the BSSID issue per FS3904

Very similar...

I also didn't see the following errors reported there, so could be different:

daemon.err hostapd: Could not set interface wlan1-1 flags (UP): No such file or directory
daemon.err hostapd: Failed to add BSS (BSSID=ce:32:e5:01:eb:bf)
daemon.err hostapd: Interface initialization failed

I did add that line to define different macaddr values but that didn't work. I don't understand how to change the BSSIDs.

I have a very similar issue on my WRT3200ACM.

See WRT3200ACM + 21.02.0-rc4: multiple Wifis on a single radio?

On previous Openwrt versions (e.g. 19.7.8) I could operate several Wifis on a single radio. Now I upgraded to 21.02.0-rc4 and it is not possible to operate more than a single Wifi on a radio.

As soon as I disable one of the two Wifis (it does not matter which one), so that only one Wifi is active, radio1 starts to operate correctly. Whenever I enable the second Wifi again, radio1 falls back to "Wireless is disabled".

I could resolve the issue by deleting all lines containing "option macaddr" from /etc/config/wireless. Now multiple SSIDs/Wifis work well.

See WRT3200ACM + 21.02.0-rc4: multiple Wifis on a single radio? - #2 by hnyman

I think your issue is not related this mine in this post. I do not have any option macaddr lines in wireless and am hit with the bug.

EDIT: If I define it for just one of the two 5 GHz SSIDs, I still get the bug. Guess I am stuck on 2.4 GHz for now.

Solution: remove kmod-mt7663-firmware-sta and reboot.

Acknowledgement to @ptpt52 for figuring this out.

Reference: https://github.com/openwrt/mt76/issues/572
PR to fix this in OpenWRT: https://github.com/openwrt/openwrt/pull/4523

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.