Two routers connection problem

Hey guys i am new on openwrt and need some help.

I want to build a network with two openwrt routers (TP-Link W940n v4 and TP-Link Archer C7 v2).
The W940n is behind my modem (connect with wan port) as dhcp server for lan(192.168.1.1/24) and wifi (192.168.2.1/23).
The C7 is in an other room and connect to the W940n with an lan cable.

Now my problems:

  1. I can't open the webGUI from the modem (192.168.1.254/24).
  2. The wifi of the C7 don't work.

Can anyone help me?

https://openwrt.org/docs/guide-user/network/wifi/dumbap

Thanks but it don't work. If i try to connect a client, it has problems to become an IP adres.

I'd suggest posting your /etc/config/network from both devices, ls -l /etc/rc.d/, as well as how you've got the cable connected. You should redact sensitive information, but there needs to be enough so that people understand the subnets you have assigned. If you use the </> button in the editor, it will be easier to read.

image

That is all the stuff from the W940n, this router works good but i can't open the webGUI of the modem(192.168.254/24). The modem pluged into wan.

root@W940n:~# vi /etc/config/network
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd8a:73d2:8542::/48'

config interface 'lan'
option type 'bridge'
option ifname 'eth1'
option proto 'static'
option ip6assign '60'
option gateway '192.168.1.254'//my modem
option netmask '255.255.255.0'//lan subnet
option ipaddr '192.168.1.1'//IP of W940n Lan

config interface 'wan'
option ifname 'eth0'
option _orig_ifname 'eth0'
option _orig_bridge 'false'
option proto 'static'
option ipaddr '192.168.1.3'
option gateway '192.168.1.254'
option dns '8.8.8.8'
option ip6assign '64'
option netmask '255.255.255.0'

config interface 'wan6'
option ifname 'eth0'
option proto 'dhcpv6'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 3 4'

config interface 'WLAN_Zuhause'
option proto 'static'
option ipaddr '192.168.2.1'
option type 'bridge'
option _orig_ifname 'WLAN_ZUHAUSE radio0.network1'

root@W940n:~# ls -l /etc/rc.d/
lrwxrwxrwx 1 root root 21 Oct 17 2017 K10gpio_switch -> ../in it.d/gpio_switch
lrwxrwxrwx 1 root root 18 Oct 17 2017 K50dropbear -> ../init. d/dropbear
lrwxrwxrwx 1 root root 16 Oct 17 2017 K85odhcpd -> ../init.d/ odhcpd
lrwxrwxrwx 1 root root 13 Oct 17 2017 K89log -> ../init.d/log
lrwxrwxrwx 1 root root 17 Oct 17 2017 K90network -> ../init.d /network
lrwxrwxrwx 1 root root 20 Oct 17 2017 K90sysfixtime -> ../ini t.d/sysfixtime
lrwxrwxrwx 1 root root 14 Oct 17 2017 K98boot -> ../init.d/bo ot
lrwxrwxrwx 1 root root 16 Oct 17 2017 K99umount -> ../init.d/ umount
lrwxrwxrwx 1 root root 20 Oct 17 2017 S00sysfixtime -> ../ini t.d/sysfixtime
lrwxrwxrwx 1 root root 14 Oct 17 2017 S10boot -> ../init.d/bo ot
lrwxrwxrwx 1 root root 16 Oct 17 2017 S10system -> ../init.d/ system
lrwxrwxrwx 1 root root 16 Oct 17 2017 S11sysctl -> ../init.d/ sysctl
lrwxrwxrwx 1 root root 13 Oct 17 2017 S12log -> ../init.d/log
lrwxrwxrwx 1 root root 14 Oct 17 2017 S12rpcd -> ../init.d/rp cd
lrwxrwxrwx 1 root root 17 Oct 17 2017 S19dnsmasq -> ../init.d /dnsmasq
lrwxrwxrwx 1 root root 18 Oct 17 2017 S19firewall -> ../init. d/firewall
lrwxrwxrwx 1 root root 17 Oct 17 2017 S20network -> ../init.d /network
lrwxrwxrwx 1 root root 16 Oct 17 2017 S35odhcpd -> ../init.d/ odhcpd
lrwxrwxrwx 1 root root 14 Oct 17 2017 S50cron -> ../init.d/cr on
lrwxrwxrwx 1 root root 18 Oct 17 2017 S50dropbear -> ../init. d/dropbear
lrwxrwxrwx 1 root root 16 Oct 17 2017 S50uhttpd -> ../init.d/ uhttpd
lrwxrwxrwx 1 root root 14 Oct 17 2017 S95done -> ../init.d/do ne
lrwxrwxrwx 1 root root 13 Oct 17 2017 S96led -> ../init.d/led
lrwxrwxrwx 1 root root 21 Oct 17 2017 S98gpio_switch -> ../in it.d/gpio_switch
lrwxrwxrwx 1 root root 17 Sep 19 15:30 S98sysntpd -> ../init.d /sysntpd
lrwxrwxrwx 1 root root 22 Oct 17 2017 S99urandom_seed -> ../i nit.d/urandom_seed

I crashed the C7 now, so I must configured new.

At least on that point, the modem is on the same subnet as your LAN but plugged into the WAN, so you'll "never" be able to connect. To be able to access the modem, you'll need to, at a minimum:

  • Define another interface/address on the WAN port for 192.168.1.0/24
  • Change your LAN to something else, as you generally can't have two interfaces with the same subnet

You can then port-forward using SSH through your OpenWrt box to access the modem. Something like

desktop $ ssh -L8080:192.168.1.254:80 you@your.openwrt.router

If you want to access the modem from elsewhere directly, then you'd additionally need to set up forwarding rules and firewall rules around what hosts on what networks have access. When I set up this type of thing, access to the modem and the OpenWrt box, both being "critical systems", are constrained to a very limited VLAN.

I'm not sure why you're using static addressing on your WAN, especially as it conflicts with your LAN subnet. In my opinion, you should get your modem into "pass-through" or "transparent" mode and set your WAN for DHCP. If you can't do that, and it's very much worthwhile taking the time to find out how to do so, then you've got "double NAT" and can deal with that later.

Your configuration of a static address on your wireless is also confusing to me. What was your thinking behind doing that?

Also, what version of OpenWrt are you running? The _orig_ifname and _orig_bridge temporary storage was moved out of /etc/config/network some time ago, as I recall.


I'd personally take the path of abandoning your current config, and starting fresh.

Step 1 -- Get "main" OpenWrt box working properly with DHCP on WAN, and some subnet that is not 192.168.1.0/24 on its LAN. Except for the LAN subnet, this should be close to "stock" config.

Step 2 -- Get "dumb AP" connected as per the previous link. LAN <= cable => LAN. No DHCP server, no DNS, basically just the wireless bridged and a unique IP from your chosen LAN network on its LAN bridge so that you can manage it.

Step 3 -- Deal with access to the modem's management interface

I using this version of OpenWRT: LEDE Reboot 17.01.4 r3560-79f57e422d.
I want to have all lan devices on 192.168.1.1-192.168.1.254 and all wireless devices on 192.168.2.1-192.168.2.254.

What modem are you using? Many can be set or auto-detect "pass-through" or "transparent" mode. Without that, you've got quite a mess on our hands.

The Genexis Titanium 54 it's the official router of the "Deutsche Glasfaser (German Fiberglass)".

http://support.buerger-fuer-glasfaser.de/showthread.php?tid=206 might be helpful, "bridged" mode is likely what you are looking for when I stated "pass-through" or "transparent".

Basically, you ideally want your OpenWrt box to get the DHCPv4 and DHCPv6 assignments, not the modem itself.

Some modems have a setting in the UI for this.

With the equipment that I use, it will automatically go into bridged mode if it has been turned off for a while (a couple minutes) and my client is up and running. If your modem doesn't have a setting in the UI or one of its many ports already in bridged mode, then what I'd try would be:

  • Turn off the modem
  • Reset your OpenWrt box to defaults (good time to flash 18.06!)
  • Boot your OpenWrt box, set the LAN to 192.168.NNN.1/24, where NNN is not 1 (so it doesn't conflict with your modem's network, if it doesn't come up in bridged mode) and reboot (perhaps easier from the command line, since changing it in LuCI will probably disconnect you)
  • Confirm that you can connect to your OpenWrt box on 192.168.NNN.1/24
  • Turn on your modem
  • Check to see if the OpenWrt box gets a DHCP-assigned address on its WAN interface that is "public" (rather than 192.168.1.MMM)

For reference of anyone else trying to assist, I believe the OP's device is close to that described by


So on both devices running now OpenWRT18.06.
I called the support of "Deutsche Glasfaser" and they say that i can´t running "bridged" mode, because both of my devices dosn´t support a phone. So I must run the modem for the phone. I try the other methode later, maybe this running. I reports later or tomorrow if it works.

Thanks for your support jeff!

When you can't set up the ISP modem to bridge over a public IP to your router, you have two choices:

  1. Make everything in your network "dumb" and layer 2 bridge to the ISP box. The ISP box does all DHCP assignments, routing, and firewalling.

  2. or 'double NAT' where your main router routes back to one private IP obtained from the ISP box. The ISP box then NATs this again to the Internet. The intermediate WAN IP must be in a different subnet than your LAN.

It sounds like you were trying to do case 1 but also having routing and DHCP active in your boxes. That will not work.