Two radios on separate interfaces


I have upgraded my OpenWRT device to TP-Link Archer C7. It has 2.4 and 5 MHz radios. First time for me using dual radios with OpenWRT. I was able (via Luci) to bridge my lan with the 5 MHz radio. Under Interfaces >> Physical Settings looks like this:

Interface [ eth1.1 | wlan0 ]

Now, I'd like to bridge my glan (guest lan) with the 2.4 Mhz radio. The UI lets me do it, or at least it seems so:

Interface [ eth1.3 | wlan1 ]

But after I hit , no change is detected, and going back to the page, the interface has reverted back to being bridged over both wifi-s:

Interface [ eth1.3 | wlan0 | wlan1 ]

I can't shake wlan0 off.

Is it possible at all to have the two wifi-s on separate vlan-s?
Is Luci currently unable to handle it? Should I go change config files directly?

Any comments or suggestion would be appreciated.

tjk :slight_smile:
OpenWRT 19.07.3

Change it on the wireless page not the network page.

It works the same way when editing config files directly. Do not put wireless network names in /etc/config/network, because the names are generated at runtime. If you add an interface the names of the existing interfaces may change. Instead use the option network setting in /etc/config/wireless to attach each radio interface to a network.

1 Like


Thank you for the quick reply. I tried to set via wireless page, but the outcome was the same. I did not troubleshoot completely to find the root of the problem, but I think it was in the switch setup. I deleted and re-added the guest VLAN, and then things worked as expected. Now my setup is as I intended.

Thanks again!
tjk :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.