I get DHCP error at this point

Connect it to the router (B) by accessing the URL:;stok=<STOK>/api/misystem/extendwifi_connect?ssid=<SSID>&password=<PASSWORD>.

Did you try the set static ip?

Finally I did with this method


Hi, at first, thank you for your amazing guide!
I was able to SSH into Redmi AX6 long time ago, I needed to set LAN tagging and MTU. However, not able now as for the newer firmware. Downgrading seems quite easy and straightforward, so no problem with this.

I still have a few questions, though.

  1. Why do I need to flash OpenWRT onto both the partitions?
    As I understand your guide, I should first flash onto the other to active partition, then when it reboots, flash it again to the other one (meaning, I would do both steps - "if it's 1" and "if it's 0" - sequentially, just depending on which one is active during the installation? Why is this not emphasised here: https://www.youtube.com/watch?v=sYXm-T5yhU0 and why he actually stressed that now we have a different system on different partitions, so we can switch between them anytime? Is that not true? Would it make troubles?

  2. Any idea on how to patch bdata? Would I just change contents of a file and set uart_en=1/ boot_wait=on, telnet_en=1, and ssh_en=1? This would be actually really helpful now if I have done this before as I wouldn't have to downgrade now. :man_facepalming:

Also for everyone here. Have you noticed any issues with OpenWRT on AX6?
And why is robimarko's release (https://github.com/robimarko/openwrt/releases/tag/ipq807x-2022-05-30) much smaller (11.8 MB) than the compiled firmware in the video before (15 MB) when he left the settings on default?

Thanks a lot!

Successfully flashed. There have been a few glitches, but SSH is omnipotent :slight_smile:

Now, I have an issue. It seems that WLAN is caped at around 650-680 mbps, taking down everything behind it – 5GHz AX, LAN, with almost 0% load on the CPU. I have also OpenWRT Asus AC58U, so I will try it with it, but I have never ecountered this issue. Maybe might have something to do with my VLAN tagging on WLAN (lan0.10).

I might figure out how to test just LAN to LAN, to see if it is something general, or if it is really WLAN, but I don't even have any nas here now, so I will have to find something.

Has anyone had the same issue?

Thanks! :slight_smile:

Why do I need to flash OpenWRT onto both the partitions?

From my experience not flashing both partition result in a bricked router when doing a sysupgrade as stated here

After the router boots it should be running the OpenWrt image, but now you need to flash the other partition to be able to sysupgrade without soft-bricking your router by replacing the mtd number with the one of the opposite partition with the command. If you flashed /dev/mtd13 then you'll now flash /dev/mtd12 and vice versa.

Any idea on how to patch bdata?

Unfortunately no I'm not sure.

Have you noticed any issues with OpenWRT on AX6?

Some versions of robimarko contains bug since it's not yet official, downgrading is easy so it's not really an issue. As for your size question, I don't know.


any easy guide in English to follow ?? since i not advance tech guy.


Hi, I think the guide mentioned here is the easiest guide you could find. No stress, all works. (Just downgrade the firmware first).

Keep us updated if you get stuck somewhere.

1 Like

yes u right sir.

done now my AX6 already Openwrt, but some issue don't how to solve it
i can't isntall mwan3, i use openwrt because i have second isp for backup, before i use mi4a openwrt, it works very well.

bellow some issue i found

any idea how to solve it?


Yes, it is because OpenWRT for AX6 has not yet been officially released. You would have to compile the firmware (from robimarko's depository) with the packages already in.

Do you know how to compile the firmware?

(I can help you with this, or just send you some of my packages. Though, I am not sure I have all these "not available" dependencies included (I know I have the iptables there. I might recompile for you, or you can do it yourself).

after i read the guide, i think i need you help to compile, my monkey brain not good enough

I will compile it for you, check your messages messages...

thanks a lot

Hi @vic1707, do you have any idea how to switch back to the stock Xiaomi firmare? I tried the "debrick" guide, tried even to change the LAN IP on OpenWRT to, but the recovery tool always just falls after the last button, and OpenWRT firmware remains.

So I managed to recover using tftp. Then I applied the bdata patch. Two issues now:

  1. I still didn't manage to access SSH, but telnet works fine. I think telnet is enough, so nothing so crucial. Moreover, if I switch back to OpenWRT, it is not a big deal at all.

  2. Channels not shown in the Xiaomi firmware, but wifi works alright (including all the channels, files, etc.). I guess it was messed up by the bdata patch? :thinking:

  3. Miwifi app is not able to find the router, neither is Xiaomi Home. That's not such a big deal, but I wonder if it affect meshing in any way. I wonder if another Xiaomi router will be able to mesh together with this one. Again, it wouldn't matter if I switched back to OpenWRT, but I wanted to buy another Xiaomi router and compare meshes between Xiaomi firmware and WDS, Batman, 802.11s on Openwrt. Well, we will see.

To fix those issues I would probably try to downgrade the firmware and re-update it later to see if it helps.
If you plan on staying with Xiaomi's firmware remember that the router has two partitions, try restoring Xiaomi's firmware on both partitions

Thanks, I will try.

Does it need to be .ubi when I rewrite the partitions by the firmware, or can it be just the stock .bin or .img? How would I get .ubi from the stock .bin?

I am surprised that the recovery mode doesn't check all the partitions (if it really does not, and if it really recovers only the actuve partition).

What I suggested is just a supposition not necessarily true :sweat_smile:
I can't help you about the file format I have no clue.

So when I boot from the other partition, the stock Xiaomi firmware is there. Which means the tftp recovery mode does recover both partitions. :thinking:

Sorry for panic, it was a different region in bdata. Though, SSH still not working, only telnet.

tftp recovery and bdata patch, both working. Thanks.

Interestingly, OpenWRT was about 50 % faster on 2.4 GHz than Xiaomi rom. Unfortunately, I have no rigorous test results saved.

What am I doing wrong?

I'm trying to follow all the steps, but I must be missing something cause as soon I change the IP, my router doesn't connect nor respond anymore.

First step, change IP

Second step, disable DHCP (I believe is this option)

(*) I'll post separated (new user limitation)

I tried too Ignore interface - Disable DHCP for this interface in General Setup.

Third one, configure IP on my machine (cable or wifi)

(*) I'll post separated (new user limitation)

And can't really do anything else. All the other steps I tried without problem, but being unable to change the IP doesn't let me many options to advance.

Sorry if I'm asking something really stupid, but can someone bring me some light to my darkness. I'm feeling so dumb right now.

PS: the router I'm using as "B" is a GL.Inet in case that matters.