Turris Omnia 2019

Hi, I recently bought an Omnia 2019 and I regret it bitterly. I come from the beloved Linksys WRT3200ACM, which unfortunately has the disgrace of the wifi card with closed source firmware and in a state of abandonment, as you all know. After the immediate disappointments with Turris OS, the Turris Omnia proprietary system based on OpenWRT, I tried to install pure OpenWRT on this toy. But the procedure shown on the page dedicated to the device on openwrt.org (https://openwrt.org/toh/turris/turris_omnia method 1 usb medikit) does not work. In fact I manage to install the temporary image of OpenWRT (I tried with the 19.07 rc), but then I can't update to the standard version and I find the 8 GB disk reduced to a 1 GB image in /tmp.
Meanwhile, if I try to mount the USB stick I get an error: mount usb failed: invalid argument.
If I try to flash the image cznic_turris-omnia-sysupgrade.img.gz via LuCI or by copying the file via scp and giving the command sysupgrade -F, the file is flashed (I know because it changes the fingerptint for ssh and everything resets itself) , but I always find myself in the disk image mode as in the preliminary file (omnia-medkit-openwrt-mvebu-turris-omnia-initramfs.tar.gz). Can someone help me? I do not feel like throwing this thing that I paid 320 euros and I feel my ass burning!

1 Like
  1. The first OpenWRT image you loaded does not include all file systems, so the USB does not get mounted. You can either use ext4 or you can scp the second image and run sysupgrade from the command line.

  2. To go back to Turris firmware you need to connect serial console and run some commands to revert OpenWrt specific changes. I do not have them handy, but you should be able to find by googling.

Thanks for the reply. As written above I did sideload with scp and started sysupgrade -F with the second image, which is flashed, but still appears to be a temporary system. I am sure of the procedure performed. For the second method you propose to me, I can't put it into practice, because the serial cable is missing.Anyway, I managed to get back to Turris OS simply with the USB auto flash mode. The fact remains that the sysupgrade file has the same outcome as the medikit. Maybe I'm wrong, but I follow the steps explained on the OpenWRT project page to the letter.

TurrisOS is opensource :-/
but yea, its a shame that installing openwrt is not straight forward.
back in the days i settled for disabling all the additional services (foris, updater, the ids thing ...) to get something more like plain openwrt.

1 Like

I know perfectly well that Turris OS is open source. But this doesn't make it perfect, in fact I find it very shabby. Of course I could contribute, but it is not my intention, because it does not fall within my competence. I just want something that works and I find OpenWRT much more functional. Is it possible that there is no way to use it on this useless hardware?

That sounds very weird. I followed method 1 and had no issues a few months back. Maybe something broke in the build?
Just in case: Is it an Omnia or a MOX?

Omnia, that now, although it is at revision 2019 , is passed to prehistory, because there is MOX, which is the same scrap metal as Omnia, but torn to pieces and more expensive. The only difference is that MOX has less RAM, but a 64-bit processor.

Maybe this revision is not supported yet? Do you want to ask on their forum what the issue might be?

Unless mistaken OpenWrt does not support NAND-MTD partitions in excess of 1 GB out of the box whilst TOS supports the full 8 GB.

You really are everywhere. Sometimes I think you can appear next to me at any time. However I read that with gparted you can use a theoretically infinite disk space. But it's sad that there isn't a firmware already modified by the team that produces Turris in order to have OpenWRT and at the same time use the whole disk. This product is a pain. So far, only two work in the last five versions of the proprietary system. I myself have experienced immediate bootloop or subsequent activation of WiFi on Turris OS 3.11.9, 3.11.10, 4.0.2. I hope someone can explain to me how to put OpenWRT using images in the official repo.

1 Like

this!
ppl that dont want anything "better than openwrt" on their routers were at the core of their target market. but there was probaly a political thing within cz.nic preventing it.
i backed the project early but gave up on insisting on this marketed and imho essential feature as it became more clear that the hardware is not particularly powerful anyways.

I have a Gigabit connection and those ridiculous processors (both the 32-bit Marvell of Omnia and the 64-bit of MOX) are incapable of correctly managing such a speed on multiple LANs, not to mention WiFi. I immediately understood that the project is a great marketing job and that's it, with characters very close to a kind of totalitarianism (woe to speak ill of Turris!). My attention is now turned to something else, we hope it is not a new failure. Meanwhile, for my Omnia from an inter-national distributor of the Czech Republic I paid 330 euros and it does not seem to me little for a box that is nothing more than a kind of raspberry with a case and 3 antennas.

Well, there you have it :wink: Doing anything besides plain routing at that speed is simply hard and requires ship-loads of CPU cycles. The turris team sure could better mange expectancies there, but I have tested my omnia to reliably traffic shape with bidirectionally saturating traffic at 550/500 Mbps (gross shaper setting) which by far exceeds what I expect from a home router, but that still is well short of 1 Gigabit.

??? The main promise of the omnia pitch from my perspective was managed automatic updates, which they delivered, but that also means differences to upstream OpenWrt. I think that over time the amount of differences actually decreased...

Any substantiation for that claim?

This I disagree with, at least for traffic shaping with sqm the omnia punches pretty much way above its weight class. Sure, that is not all there is to networking, and I have a singular obsession with traffic shaping, but still only few non-x86 devices can compete. (I exclude any hardware accelerators here as these typically restrict generality quite a lot and often do not work with traffic shaping at all).

3 Likes

Oh well, the usual hole in the water. I just wanted to install OpenWRT on this thing with a calculator processor, but it's better supported on TP-link or any other.

Curiosity: @moeller0 and @n8v8R are you brothers? You persecute me whatever I write to tell me how good Turris is, but don't convince me. Help would be appreciated on what I ask, for example here, how to install OpenWRT without having to compile a custom build.
There are also cards with case at the same pprize of Omnia, not to mention MOX, but with 2, 4 or more Giga of RAM, a minimum of 16 Giga of memory and quad-core x86_64, fully supported by OpenWRT.
I don't mention any names or someone may think they pay me, but I'm just a private person.

Well, you are certainly entitled to your opinion..., and I have empathy for your situation having spent a considerable amount of money and then not getting what you expected (or were made to expect from the omnia's sale's literature).

Look, I am not trying to convince you of anything, all I did here was to add some modicum of fact-based information to your ranting assessment of the omnia. It certainly has its short-comings, but lack of performance is simply not among them.

I see that it could be simpler, but with OpenWrt building your own is part of the experience, as far as I am concerned.

Sure, and if you need to do lots of processing at >= Gbps rates, that is what you should buy. As I said, the omnia punches well above its weight class, but that does not make a flyweight device into a heavyweight champion. It is a common misconception that cheap home routers can actually sustain tricked-out routing/firewalling/NAT/QoS at Gbps-speeds, that is fueled by the fact that ISPs deploy such toy devices to end-users that achieve the Gbps-class speeds only by exercising hardware accelerators that typically do not work under upstream Linux or OpenWrt. That is unfortunate, and no side is at fault IMHO, but it leads to situations like yours.

But since I can not offer a solution to your actual problem, I will keep a low profile.

1 Like

There seems to be some sort of misconception since I do not advocate any particular brand/device. There might be a difference in perspective and yours is certainly respected and if that being somewhat disenchanted with a particular device I would be the last trying to convince its owner otherwise.

Worthy epilogue: I performed the procedure again, this time with the openwrt files 18.06.5 and no longer 19.07. Everything went smoothly, I managed to mount the USB key and do sysupgrade without the -F option, because the sysupgrade.img.gz image was recognized for that platform. Restarting. Result? Fabulous brick. Finally he can go back to doing what he was born for: the paperweight. Or alternatively I need to get a serial cable.

In the end he always saves my ass <3
Google Photos

I have an omnia here and I am very satisfied with it. I was able to clear 900 Mb per second and 700 Mb per second on the Wi-Fi. It does help if you have 3 x 3 mimo . While the tourist firmware is not quite as full featured as openwrt The unit run circles around any consumer stuff out there. I also like the fact that you could change the lights. I had a friend who installed vanilla openwrt without any problems so I don’t exactly know where you’re coming from.