Turning off the power returns the old version

I installed the openwrt (I like this version) on the Linksys WRT1900ACS. Every time there is a power outage or physically disabled the router returns to the old version Linksys WRT1900ACS. True, I heard that there is a possibility to restart by shutdown etc.

But my goal is that she go back to openwrt.

Linksys wrt1900acx series has a dual firmware feature, where you always have a fallback-firmware in case the new one does not work. The router switches back to the old one if boot fails three times.

Your symptoms sounds a bit like the router reverts back to the fallback firmware, but that should happen only after three failing boots.

Do I get you right that after flashing OpenWrt, the router first boots ok, and you have OpenWrt available?
Which version? The official stable 18.06.2 ? hopefully so.

If you after the flash and boot then (without making any changes to the openwrt config) reboot, the router reverts to Linksys OEM firmware? Right?
(wrong config changes might prevent successful reboot, so

If yes, the it sounds strange. Sounds like the alternative firmware toggling mechanism misfires. Possibly the toggling flags do not get set properly, or something like that. You might try flashing Openwrt 18.06.2 again from the running OpenWrt via sysupgrade, so that also the alternative firmware is OpenWrt and the toggling flags should be reset in connection of the flashing.

Please use first the normal stable 18.06.2, instead of any trunk/master/private build, so that the known good version is in use.

Depending on the reason for the power outtage, the power returning might not be a clean/ clear cut power-on event (electronics in general don't like this at all). If you do get a 'stutter' while your power goes down/ comes back (have a look at a light bulb during that time), that might very well trigger the three-incomplete-boots fallback.

Just to reconfirm from the other side, you can also yank the PSU from mains power after the router has fully booted up (≥5 minutes after power up) and then applying power again, this shouldn't trigger the fallback.

2 Likes

I would definitely try what @slh suggested to test the revert feature. if it reverts on a clean power off and clean back on... then something is definitely wrong.

1 Like

Yes, no problem at all. It returns to its previous state (Linksys wrt1900acx) once the electricity falls in the home, it returns to its previous state. Or I press the Shutdown button and turn it on.

Which version? The official stable 18.06.2 ? hopefully so.

I installed this version
openwrt-mvebu-cortexa9-linksys_wrt1900acs-squashfs-factory.img

Now I've installed this version.

http://downloads.openwrt.org/releases/18.06.2/targets/mvebu/cortexa9/openwrt-18.06.2-mvebu-cortexa9-linksys-wrt1900acs-squashfs-factory.img

From the following link:
https://openwrt.org/toh/hwdata/linksys/linksys_wrt1900acs_v1

Is this the latest version?

Yes, that is the latest release version as of your post.

And to be clear, you need to flash it twice on your device to have OpenWrt on both partitions.


It looked different from what he had installed.

Before that I had the option to make a default activation here and do not have it. Is it okay?

And to be clear, you need to flash it twice on your device to have OpenWrt on both partitions.

how do I do it? And will this allow me to return to the default?

if you are in openwrt and flash a sysupgrade image it goes to the opposite partition from where you are running. this overwrites the factory image on the other partition, so don't do that if you want to retain factory.

3 Likes