Turning OFF LAN LEDs

Hey,

I have a Zyxel Z1 router with OFW which is based on OpenWRT and I would lite to turn off all the LAN LEDs (WAN+LAN1-4)

I tried to edit /etc/config/network and rebooted the router, but it's not working.
This is how my network looks like now:

root@router:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option status '1'
        option ifname 'eth1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option stp '0'
        option vid '1'
        option vlanname 'lan'
        option priority '0'
        option dns1 'ISP,'
        option dns2 'ISP,'
        option dns3 'ISP,'
        option dnsv6_1 'ISP,'
        option dnsv6_2 'ISP,'
        option dnsv6_3 'ISP,'
        option mtu '1500'
        option hairpin '1'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'
        option v6_proto 'dhcp'
        option name 'Default'
        option default '1'
        option vid '1'
        option untag '1'
        option enable '1'
        option dhcp121 '0'
        option dhcp125 '0'
        option dhcp60 '0'
        option isp_gw '0.0.0.0'
        option dns1 'ISP,'
        option dns2 'ISP,'
        option dns3 'ISP,'
        option dnsv6_1 'ISP,'
        option dnsv6_2 'ISP,'
        option dnsv6_3 'ISP,'
        option v6_static '0'
        option eth_mtu '1500'
        option mtu '1500'
        option pptp_mtu '1454'
        option pppoe_mtu '1454'
        option pppoeNailedup '1'
        option ipv4 '1'
        option ipv6 '0'
        option ipv6Enable '0'
        option IP_version 'IPv4_Only'
        option wan_mac_status '0'
        option hostname 'router'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '6 1 2 3 4'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 5'


**config switch_port**
**option device 'switch0'**
**option port '1'**
**option led '0'**
**option port '2'**
**option led '0'**
**option port '3'**
**option led '0'**
**option port '4'**
**option led '0'**
**option port '6'**
**option led '0'**

config network 'general'
        option auto_ip_change '1'
        option dhcpv6pd '1'
        option backup_lan_ip '192.168.1.1'
        option backup_lan_mask '255.255.255.0'
        option backup_aplan_ip '192.168.1.2'
        option backup_aplan_mask '255.255.255.0'
        option config_section 'wan'
        option wan6rd_enable '0'
        option wan6to4_enable '0'
        option wan6in4_enable '0'
        option linkLocalOnly '0'

config interface 'vpn'
        option pptp_Nailedup '1'
        option pptp_Encryption 'Auto'

config interface 'wan6to4'
        option proto '6to4'
        option relayaddr '192.88.99.1'

config interface 'wan6in4'
        option proto '6in4'

it's based on this post

Can somebody help me what am I missing? Thanks

What do you see when you edit /etc/config/system

That's where LED configs are located.

What did you edit in the network config???

This is in system:

root@router:~# cat  /etc/config/system | grep -i "led" -A10
config LED 'led'
        option on '0'

I added this (and tried a few other combinations) to network config

**config switch_port**
**option device 'switch0'**
**option port '1'**
**option led '0'**
**option port '2'**
**option led '0'**
**option port '3'**
**option led '0'**
**option port '4'**
**option led '0'**
**option port '6'**
**option led '0'**

Why are you using invalid syntax and configs?
That won't work.

I think you may need to read: https://openwrt.org/docs/guide-user/base-system/led_configuration

You can also do this on the web GUI by browsing to System > LED Configuration:

Screenshot%20from%202019-01-04%2016-14-52

Hi,

Based on this, this and a few other pages syntax is ok. But I can't figure out what's wrong.

You're wrong I think. Led Configurator and shared link is regarding status leds (with white color on this image and not regarding LAN leds (example ). I already read it.

Btw, on GUI status leds can be turned off, but LINK leds can't (picture ). This router have a luci gui.

Sorry, only 2 links for new users, that's the reason for flooding.

Neither of the pages linked that I looked at discussed an led option for the switch.

If the OpenWrt can control the LEDs (which, in many cases, it cannot), configuring them as described above with LuCI or in /etc/config/system is the most straightforward way of accomplishing the task.

The names of the LEDs will be specific to your router and the firmware build.

In some cases, the wiring of the LED is not through the OS, so the OS can't control them. Black tape is a reversible alternative to wire cutters.

3 Likes
2 Likes