Turn off SSID, but not the radio

I'm looking to schedule a cron job to turn off my guest network on a schedule. I found a solution on this forum which I tried. The change worked but I got an error message.

 root@OpenWrt:~# uci set wireless.wifinet3.disabled="1"; uci commit; wifi reload wifinet3
 uci: Entry not found
 'radio0' is disabled
 'radio0' is disabled

What did I do wrong?

Check out the wifi scheduler packages:

1 Like

These packages appear to turn off all WiFi. I only want to turn off/on specific SSID(ie. my guest network). I don't know if those scripts can be modified to target a specific SSID.(Probably beyond my capability).

This will disable only the one interface as you want, but you must have a matching name in the /etc/config/wireless file:

config wifi-iface 'wifinet3'
    option device 'radio0'
    option mode 'ap'
    option network 'guest'

Naming it guest would make more sense.


This may be an indication of corrupt uci config. You may want to run

for i in /etc/config/*; do if ! uci show ${i##*/} > /dev/null 2>&1; then echo -e -n "$i: "; uci show ${i##*/} > /dev/null; fi; done;

to find the offending config file.

The original command was missing the filename after the commit statement.

AFAIR, not required, if no filename specified, uci commit commits all changes in memory for all affected files.

Not to mention it has nothing to do with the uci error I quoted and provided a solution for.

If your problem is solved then please consider putting [SOLVED] in the title of this thread.

You are right about the commit. I inadvertently fixed my error while adding network to the commit. So I assumed that fixed the problem. My error was that the disabled statement was not in the wireless file yet.

A noob. I tried to edit the title.no luck

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.