Turn off firewall and open all port's

And I thought "full cone" was a strange way to describe NAT many years ago :wink:

At least from what I understand, once you've got only one NAT running, you should be able to manually open a couple ports directly to your XBox without having to risk your network security to UPnP or the like.

I never heard of full cone NAT I Googled it from what I read if there is a way to enable it on router 1 with openwrt wouldn't it give my router 2 connected on wan a public ip address? Just a thought that be what I need. Router 2 has NAT and firewall running on it and worked fine with my old isp.

"In a former life" I was involved in some of the early work around connecting peer-to-peer clients behind NAT with what became known as STUN servers. In some OSes, there are flags that can be given to the NAT engine to suggest some of the behavior ("keep same ports" or the like), but, in general, you've got what you've got ...

... and with typical home-user service, you've only got one public IP at your disposal. Yes, if you had a block of IP addresses assigned, "full cone" or "one-to-one" NAT would let you map all traffic to, for example 203.0.113.17 (public) to 192.168.12.12 (private).

One-to-one NAT can be useful in a situation where you have bridged service rather than routed service (all traffic is "dumped" onto the network segment, rather than routed through a single IP address). In that situation you'd assign each of the block's public addresses to your "WAN" interface, then NAT them to each of the corresponding hosts' private addresses.

1 Like

Well I tried what you suggested last night it worked on some devices but my directv dvr and two of my tablets wouldn't connect to Internet it show network not secure and blocked access. I did a hard reset on both routers tried it again. Same results. But on the game consoles it did fix double nat but still had strict nat. I might just give up at this point and buy a new cellular modem of some kind. Unless there is a way to maybe forward my public ip to one of the lan ports from router 1 openwrt and connect that to wan on router 2 netgear.

If you've only got one public IP, then doing that in bulk would remove connectivity from all your other devices connected to Router 1.

A clear "picture" of your setup would help.

If you've lost connectivity on other devices, then the problem is likely in the configuration of the Netgear device with it's unstated OS.

You shouldn't have to buy an new cellular modem if what you've got is giving you connectivity.

I do have a linksys router and a belkin router that I can try instead of the netgear they all have stock firmware on them. I think the linksys is probably the better choice. I like the netgear because it has 2.4 and 5g WiFi and it has excellent WiFi range about 100 feet. But I will try other routers out. I will see if I can find out what os and version for all my routers I have. I'm not using them all on my network just to be clear.

Can someone walk me thru the upgrade process using ssh to upgrade openwrt to the latest release? The router I have has a custom build of openert on it and has the bare minimum options in luci and it sucks I managed to get a better luci interface on it but lacking lte tab to configure the lte modem. I tried the user interface to flash new firmware. I downloaded the firmware specific to my device and I get a message telling me "the uploaded image file does not contain a supported format. Make sure that you chose the generic image format for your platform" what am I doing wrong?

I'm just going to buy a new modem I don't have time to mess with it. Thanks for all the help sorry if I wasted your time.