Trying to use 2x TL-WN722N. Because Built-in wifi in Raspberry pi3B is very slow

Hello.
I want to use 2x TL-WN722N, but when i try to one of them to connect to wifi and the second one to broadcast the wifi it works for few seconds but then crashes and there is no broadcast.

Thanks for help.
Maren

Can you elaborate on your setup? You haven't given any specifics, so we can't help.

A diagram on your network setup would be a good starting point as well as the firmware versions on all of the relevant devices (WN722N, RPi3B), and the configuration files per below (for each of these devices)

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

I dont know much about wireless networking. But there is maybe all you asked for:

I use Tp link WN722N V1. Also downloaded drivers for it with command "opkg install kmod-ath9k-htc"

This is network:

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fda4:feb1:410b::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.69.69'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option force_link '1'

config interface 'wwan'
        option proto 'dhcp'
        option peerdns '0'
        option dns '1.1.1.1 8.8.8.8'

This is wireless:

config wifi-device 'radio0'
        option type 'cant show'
        option channel '7'
        option hwmode '11g'
        option path 'platform/soc/3f300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
        option htmode 'HT20'
        option disabled '1'
        option short_gi_40 '0'
        option cell_density '0'

config wifi-device 'radio1'
        option type 'cant show'
        option channel '7'
        option hwmode '11g'
        option path 'platform/soc/3f980000.usb/usb1/1-1/1-1.3/1-1.3:1.0'
        option htmode 'HT20'
        option disabled '0'
        option short_gi_40 '0'
        option cell_density '0'

config wifi-device 'radio2'
        option type 'cant show'
        option channel '11'
        option hwmode '11g'
        option path 'platform/soc/3f980000.usb/usb1/1-1/1-1.2/1-1.2:1.0'
        option htmode 'HT20'
        option disabled '0'

config wifi-iface 'default_radio2'
        option device 'radio2'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-iface 'wifinet2'
        option device 'radio1'
        option mode 'sta'
        option network 'wwan'
        option ssid 'cant show'
        option encryption 'psk2'
        option key 'cant show'

This is dhcp:

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

This is firewall:

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'
        list network 'wan6'
        list network 'wwan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config rule
        option name 'Support-UDP-Traceroute'
        option src 'wan'
        option dest_port '33434:33689'
        option proto 'udp'
        option family 'ipv4'
        option target 'REJECT'
        option enabled 'false'

config include
        option path '/etc/firewall.user'

Set your country code for best wifi operation. An option country needs to be placed in each config wifi-device for all the radios.

Exactly what is the failure mode when it "crashes?" Anything in the logs?

Two radios on the same band physically next to each other tend to jam each other out (even if set on different channels) and you will get low performance.

Then how can i use one to connect to wifi and one to broadcast the wifi.

Ideally a real dual-band router, not something cobbled together with USB sticks. If wifi speed is vital to you, you're not going to get it the way you're trying.

If you only have one band, it works better to run both functions on the same radio, because they will share time better. But the hardware and driver must support combined operation.

OK. I will probably stick with the one usb adapter.

What is your goal with this setup? Are you looking to create a new wifi network, or extend an existing one (i.e. a simple repeater)?

I want to extend my existing wifi network.

Sorry that i wasnt active. I didnt have much time because school.

Thanks Marek.

Many USB wifi sticks cannot work in AP mode. And regardless, both the built-in Wifi on the Pi and the USB sticks will have poor performance since neither are designed to be APs.

You will be much better served with a device that is purpose built as a wifi extender, or a regular wifi router or mesh setup.

Alright this helped me alot.

Thanks Marek.

Hello psherman.

I was thinking. Do you think if i use the usb adapter to connect to wifi and the build in wifi in rpi3b to broadcast the wifi? Or is it going to be same speed as before?

Thanks Marek.

I don’t know. You could try it. But keep in mind that the built-in WiFi in the pi is not designed to be used as an ap and will have poor performance (no mimo, just a 1x1 setup, not great ranges, etc).

And do you have list of devices that support AP?

No, I don't have a list. You could search the forums for information about that.

The best wifi performance will almost always be from a device that is designed to function as an AP with multiple radios, mimo technology, and optimized antennas. If you use a proper all-in-one wifi router or a purpose built wifi AP, you will be much happier with the performance than you will be with any USB wifi adapter or the built-in wifi on the pi.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.