Trying to Unbrick KUWFI Router

Hi all,

I had acquired a cheap Chinese model-numberless router with the above name to play with. It is no longer marketed by the company on Aliexpress so no data is available.

It is Qualcomm Atheros QCA9533 motherboard and Longsung U9300C modem. No info about Longsung 9300 is available on the Net. It's original firmware is however OpenWRT based, as I found playing with it. If I remember the System Log output correctly, the first line showed the date to be circa 2017.

The original firmware was in Chinese so I could not make any head or tail of it. Luckily I had backed up the firmware image before I flashed it with <wirelesshaven.com> WiFiX NEXQ6GO-M Cellular Router firmware. The reason was that the NEXQ6GO router is a look alike for the KUWFI router that I have plus it also uses the same mother board. My reason for doing it was to introduce SMS send/receive capability into the KUWFI. The outcome was that the new WiFix firmware worked but the router stopped connecting to the GSM network. Now with hindsight, I surmise that this happened because the WiFix firmware wasn't meant for the LONGSHUN 9300 modem installed inside the router.

I then tried to reinstall the original Chinese firmware but ended up bricking the router. My last attempt was to install WinSCP and try to get into the router. Unfortunately this also didn't work as WinSCP could not proceed beyond the authentication stage because the password/username were not correct.

The above being the long story; I am now stuck and have no idea what to do next. So help and guidance in the matter is solicited please.

TIA.
azhaque

I suspect the advice is the same as given in this thread...

Marco,

Thanks a million for your response.

While physically the same in appearance, I don't think that these are the same. I attach some photos of the Kuwfi, which I opened up to check if there is a serial port available. Luckily there is.

Apparently there is no ARM processor. Just the 9531, the Winbond Flash memory chip and an un identified chip (Please see SOC and Chips pic after zooming in as I have marked the chips with MS-Paint.

Thanks again for the quick reply.

Regards
azhaque

9531 is supported - https://openwrt.org/toh/views/toh_extended_all?dataflt[CPU*~]=9531

but you'll probably need serial port access.

Just a supplemental post to my last one, to add a pic of the LongSung 9300.

The image you show of the motherboard is not the same as the NEXQ6GO. I checked. The NEXQ6GO is a rebadged ZBT WE826-Q running a custom ROOter firmware. The NEXR5GO is a rebadged SXTech RD05A01 also running a custom ROOter.

These are based on the Qualcomm AP047-010 reference board. There are numerous others out there using the same design and the firmware can be interchanged although the Leds will be altered somewhat.

No surprise that as that modem has zero support in OpenWrt or Linux. The manufacturer probably added whatever driver support was needed for this modem but never released any code. ROOter has support for a lot of modems but I've never heard of the Longshun 9300 before. Good luck finding third party firmware that will support it.

Have you tried the bootloader Recovery GUI? Most of the routers (but not all) use a bootloader that will allow flashing from it. This is much easier than serial cable.

Frollic,

Thanks for the response.

I think my nemesis in the KUWFI may not be 9531 but in fact the LONGSHUN 9300. I should have, but forgot to mention that the 9531 part works. When I connect the Ethernet port of the KUWFI to the D-Link Router's (the operational router) KUFWI acquires an IP address and connects to the internet and Wifi becomes alive, and accessible from other computers and phones. This leads me to believe that the 9531 part is alive and kicking.

Thanks for the response.

azhaque

The chip you have marked as unknown is the DRAM. It appears to be a re-labeled Micron 266Mb (32MB) DDR SDRAM.

Thanks for the response Ralph. It is my pleasure and honour to get a reply from Dairyman :saluting_face:. Infact I tried to register on the Whirlpool forum from but I never got the linkup email despite several attempts. I figured it might be restricted to Australians only.

My choice to use the NEXQ6GO firmware came from this page from the website, plus this page from which has NEXQ6 mentioned in the list of supported modems.

Secondly the NEXR5 is a dual band thing. That is the reason I did not consider it. Besides that, as I have mentioned in my response to FROLLIC, the KUWFI wifi part, which is primarily concerned with the motherboard (and as such the QCA9531) functions OK. It is only the GSM part, related to LONGSUNG 9300 that doesn't work. Anyway the clinching reason was my KUWFI and the NEXQ6 are look alikes :unamused:

Yes that is so. My efforts to get some info/design data about the LongSung9300 from the Internet, have not been fruitful. But I will continue to try. One thing that I found was that the 9300 talks to the cpu over the uart, which if true makes it real easy if I can find the list of AT commands. I can even link it to an ESP8266/ESP32 for the wifi functionality instead of these expensive Qualcomm and Sierra or Huwawi SOCs (something like the SIMM900 module for Arduino). But that's a long story.

Many thanks for this pointer Dairyman. Much appreciated. I am a noob in this field but like to attribute a steep learning curve capability to myself :blush:. Hopefully with help I will learn fast.
Shall read up further on the bootloader recovery method. I remember some mention of it on the ROOTer website.

In ending, it is my honour and pleasure to receive a response from you.

Regards and Good Wishes.

azhaque

Love u Ray.
Like the Eagles (if I remember correctly) say "you can run but you can't hide".

azhaque

Nope, open to any one. I'm Canadian and there are people there from all over the world.

That is the correct firmware for you although the only difference between the NEXQ6GO and NEXR5GO firmware is the extra Wifi driver. I've used the same firmware on about 5 different routers based on the QCA9531 with no problems.

I did find one site that gave some information on patching the Option serial driver for this modem. It needs to be built into the firmware and isn't something you can add to an existing firmware. I do this for ROOter regularly to add new modem support.

From that web page it appears that the modem only worked in PPP mode using the normal ttyUSB interfaces. But they also talk about serial to parallel conversion which isn't something I've heard of before with modems. This is the page

If it is supported it is dead simple. Give your computer a Static IP as the router will not have a DHCP server running. Unplug the router from power and hold in the reset button. Plug in power while holding the button in. Wait for about 10 seconds and release. Go to http://192.168.1.1/index.html and you'll find a web page that allows you to flash the router.

It is too bad you can't register with Whirlpool as I'm sure we could get something working by looking at information from the router and making new firmware for it. I'd rather not do that here as this is ROOter work and not OpenWrt.

It lives. Thanks Dairyman.

I tried and it worked first time. No soldering or connecting to serial ports and stuff.

It came back to the WiFix firmware though which means the LongSung9300 will again not work. No problems on that.

Before bricking it I had accessed the firmware. On the Backup Tab, unfortunately all the LUCI instructions were in Chinese, with some words in English. Backup was one of them. So I backed up. However, with hindsight, I now know that the only thing that got backed up was the config files and not the bin file. So when I tried restoring the .tar file it didn't work. Looking at the Rooter instructions on this I learned that it has to be a bin file. Since I had the NEXQ6 bin file, I flashed it and it worked.

Yeah. I am also looking around on the Chinese sites to see if I can dig up data about the 9300. However since everyone is now shooting for 5 GHz and 5G; even ready to start the next World War on this count :laughing:. So maybe the 9300 maybe ready to become a 'has been', since most SoC info I am seeing is 5G related.

About the Whirlpool I don't know what the issue is, related to me not receiving an email. Will keep trying. I have an excellent experience with <thebackshed.com>, another Aussie forum on Solar related stuff. I have learned tons of stuff from it.

Many thanks again Dairyman.

God Bless and regards.

azhaque