Trying to reset or log into TL-WR703N running 12.09

Hi folks,
Let me preface this with the fact that I know this is an old device and an old version, and the position of developers would almost certainly be that this is "not supported" and I should leave it alone. That being said, I have a use case for this hardware so I'm hoping to try to get it to cooperate.

I was recently given two TP-Link TL-WR703N mini portable wireless routers. IO consists of 1x USB micro-B for power, 1x 10/100 Ethernet to function either as WAN or LAN depending on configuration, 1x USB A female to accept a USB cellular modem, and integrated Atheros WiFi. These were configured by TP-Link with DD-WRT preinstalled, when new. The devices are used, but not by the person who gave them to me, and I figured my first step should be factory resetting them. They do not respond to the reset button when I try to follow the directions from the manual - e.g. hold button for 5-7 seconds - the device does not respond to this at all. I then considered the possibility they've been flashed with another firmware, and I've since been able to verify that at least one contains OpenWRT 12.09 Attitude Adjustment.

As the devices came to me, plugging them in to power gives a power LED that is briefly solid, then briefly off, then flashes for a minute or so, then goes solid. A host connected to Ethernet sees the port go up, but there is no DHCP response. No visible WiFi network seems to be broadcast. No type of interaction with the reset button seems to cause anything to happen at all; not a brief click, holding for 5, 7, 10, 15, 30, 60 seconds, rapidly pushing it repeatedly, absolutely nothing.

I have found that if I hold the reset button while powering on the device, depending on the exact timing of when I release it, I can get two different results:

  1. The power LED is solid or blinks slowly. A host device will lease an IP address in The gateway is The device does not respond to Telnet. Nagivating to this IP in a browser brings me to the LuCI web interface with a login prompt. The pre-filled username is root. I have tried many possible default passwords, including leaving it blank, but none are accepted. I believe the device is not in a reset state and the password is set by a previous user, but, does anyone have any suggestions for an unusual but possible default password? Maybe 12.09 didn't use a blank password by default?

  2. The power LED blinks very rapidly. A host device will lease an IP address in The gateway is The device does not provide the web interface. Telnetting to this IP brings me to a BusyBox shell on the device displaying OpenWrt information, such as the version. It tells me to use the passwd command to set my login password which will disable telnet and enable SSH. I have an elevated prompt (root@(none):/#). I tried to set a secure password but am informed the file system is read-only.

I'm a little perplexed here. I'd very much appreciate any pointers that might help me get into this device. The second one is more challenging as I cannot seem to get either of the results above, it acts more like it may just be bricked. But if I can get one of these reset to some sort of defaults that let me in, I'd certainly like to do that.

Thank you.

It did. Password has been blank pretty much always.

Sounds like the expected "failsafe" mode in OpenWrt.
Read advice in wiki. (You need to e.g. mount the root file system with "mount_root")

The failsafe mode is your best bet.
Instead of trying to set password etc., you might just try to reset the device with "firstboot" command.

It is possible that the previous owner has filled the flash overlay so much that it only mounts as read-only as there is not enough free space for overlayfs to work.

1 Like

So close. I was so close. All I had to do was read the documentation.

Thank you very much for this pointer. I opted to just set the password and log in to try to sort out how the device is configured as it sits now, and may opt to set defaults later.

The second device remains unknown at this point but that seems to be a different problem with a likely different solution required.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.