Trying to mount NTFS external HDD with Samba

Good Afternoon,

After some wonderful help, I'm almost done. I have a Linksys EA6350 with Samba and an external HDD 4tb formatted NTFS. I can't get the drive to mount (although I may not know what I'm doing) and although I would GREATLY prefer using the Luci interface, I tried a few commands I found in the forums and some either didn't work (error 255 trying to download software) or when trying to mount the drive, it either didn't exist or gave me a permission denied. The drive has a few thousand movies on it.

Can someone help?


due to the risk of data loss, need for command line configuration / use... and resultant performance...

it's not advised to use ntfs.

if you want to try... play with a dummy drive.... sort out your package issues and verify you have what is needed. proceeding past there without certainty is futile.


What is the error message when you try to mount it manually?
Perform the file system check from Windows.
Make sure the system reports that the drive is ready to detach before detaching it.
Verify the drive SMART is not failing.
Sometimes you need an explicit power cord to attach the drive properly.

I don't see the drive. So then I tried to download the various kmod usb drivers (storage, etc) and all produce a 255 error or say kernal is incompatible and that it wants a xxx.19 when my current is xxx.18.xxxx etc but I had already run the opkg it should be as update to date as it would get, correct?

Drive is fine and has been working like a champ everywhere else. It's formatted NTFS and has about 2terabytes of the 4 available....full of movies.

ubus call system board

What does it say?

says the kernal piece....about current version is xxxx18xxxx and it requires xxxx19xxxxx

Perhaps you should install the latest stable OpenWrt release.

Does that happen when you run opkg update and install? Further, I didn’t seem a newer, stable version for the ea6350 but maybe I missed it....

so maybe the best avenue of approach here is for me to somehow try to run a virtual machine version of this (of which I have no idea how to do yet) and then when I have a working image, back it up and go to the router and install. I can't afford to run an "update" and wipe the linksys image off the router because the system is actively being used and i don't want it possibly going down (and me being reamed a new one....). Yes?

According to the ea6350 device page, the 19.07 snapshot is available. As @anon50098793 suggested, it would be better to use ext4, but if you can't the easiest way to mount ntfs in Openwrt is with ntfs-3g.

edit - if you want to keep linksys on one partition, the best way is to follow the instructions for Recovery (Automatic) from the ea6350 device page and then once back on linksys firmware install the 19.07 snapshot xxxxx-factory.bin file for the ea6350.

So I guess I would think and then ask- the best way to approach this, I think, would be to somehow build an image that's complete and setup as I want it, and then flash one of the partitions such that the router should be down for a minimal amount of time and go unnoticed by the users.

Is there a way I can go about building a virtual image (having never done it before)? My setup on the router should be fairly simple.....

Actually your problem of not being able to install packages is because of the fact that you're uaing a snapshot version. The system creates a newer build every 24 hours or so AFAIK so it also upgrades the packages. This is why you need to download the packages with the same build you flashed which may not be possible if you flashed it a few days ago so you should create a custom firmware through image builder and add all the necessary packages to it to make it work.
Also please note that in order to successfully use ntfs in your router DO NOT add kmod-fs-ntfs and only add ntfs-3g. The kmod package creates incompatibility with ntfs-3g and drive won't mount at boot through fstab. Furthermore kmod package only mounts the drive as read-only so is not recommended.

Edit: You need to have kmod-usb-storage installed and also kmod-usb-ohci kmod-usb-uhci because they may be required for some devices.


Thank you very much for that info!