Trying to install openwrt on Totolink EX1800l

Recently I got a totolink ex1800l range extender

I imidiately took it apart and installed breed bootloader on it and I found a device with exact same hardware

So I tried to install the firmware for that device while one initramfs version bored just fine but because of only having one Ethernet port I can't access luci I can only access it via serial
But the normal sysupgrade image failed to boot error can't mount root because it failed to create partitions
OF: Bad cell count for /palmbus@1e000000/spi@b00/flash@0/partitions

I've also tried the totolink x5000r firmware which have the same cpu but different wlan (mt7915) and it booted just fine I can access luci with the only Ethernet port but ofcourse wifi won't work so with only one port it's not very useful

It seems like the x5000r firmware have some special driver for the spi flash chip as mentioned in this post

So is it possible to get the best of both worlds and end up with a working router because this is my very first post and I'm new to openwrt and Linux compiling a custom firmware seems too much for me to do is it possible to install the driver afterwards or something like that

Any help is appreciated
Sorry for my bad English

Yes. It's not too hard if you read the guides in the Wiki:

However, I hope you have taken a backup before messing around with random firmware versions. If you want your device to be supported by OpenWrt, you need to get it working with the stock bootloader (which is usually not a big deal on MT7621 devices). Flashing random firmware versions, even if they support the same ICs, can potentially kill required data on the flash (for example, WiFi calibration data).

ok i will check the add new device wiki
but unfortunately i dont have the original firmware now i ofcourse did try to back it up before doing anything but the flash voltage is too low and ch341a killed it so the backup dont boot and totolink dont even have the device original firmware on their website
i have replaced the flash with windbond w25q128fv and i have also tried to use uboot but its same issue as breed

That's going to be difficult, since you probably lost your WiFi calibration data. IMHO, your best bet is to find someone with the same device who can send you a full flash dump to restore it back to its original state.

how can i know wireless tab missing is because of no driver or art missing
if i managed to get a full dump from another device where is the art located
ive never build a custom firmware before now i have set up the image builder with the guide in vm but im still trying to figure out how to use it
this device also have a display which seems to be directly connected to the cpu with spi is there any chance to make it work

Check the log files: OpenWrt's regarding the wireless driver and that of the stock firmware regarding the partition layout. You can also try to extract the DTS from the stock firmware (or from an upgrade file), that should containt the partition map as well.

i think yes its detected just because lack of eeprom/art so it cant enable the radio
i also found something intresting
the yuncore ax820 which have mt7908/mt7975 but the bootlog also says mt7915 so i think its actually using same driver so only problem i have is missing art
heres the bootlog just to be sure

heres the firmware i got after i modded the ch341a programmer
it still dosent boot i mind you the uboot dont load at all the cpu only draw 70ma@12v while running normal uboot or breed it draws 150ma@12v but i think not all content is destroyed the art might still be fine so i shared it just in case
if it didnt work i know someone have a x5000r that is running openwrt i can ask him to dump the flash for me even though it may not be fully compatiable