Trying to install OpenWrt on a Velocloud 520-AC

if [ $# -lt 1 ]; then
	echo "usage: $0 [-d dev] [-p] [-grub] root-id [...]"
	echo "  -d dsk    install to disk other than sda"
	echo "  -vga      force use of vga console for grub and kernel"
	echo "  -r dev    force root device for runtime (if different from install time)"
	echo "  -p        force new partition layout, implies -grub"
	echo "  -grub     force grub installation"
	echo "  root-id   0=factory 1=first 2=second partition"
	echo "  at least one of -p, -grub or root-id must be given"
	exit 1
fi

./installer -d sdb -p then ? let's try

No errors this time !

root@vc:/# /root/installer -d sdb -p
[   51.737117] EXT4-fs (sda4): mounted filesystem with ordered data mode. Opts: (null)
images in /tmp/mnt-inst/images
disk /dev/sdb is 7456MB
creating new partition layout on /dev/sdb, root size 1024MB ...
Model: Generic Ultra HS-COMBO (scsi)
Disk /dev/sdb: 7456MiB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags:

Number  Start    End      Size     File system  Name   Flags
 1      1.00MiB  2.00MiB  1.00MiB               grub   bios_grub
 2      2.00MiB  20.0MiB  18.0MiB               boot   boot, esp
 3      20.0MiB  1044MiB  1024MiB               root0
 4      1044MiB  2068MiB  1024MiB               root1
 5      2068MiB  3092MiB  1024MiB               root2
 6      3092MiB  7446MiB  4354MiB               user

/dev/sda: gpt partitions 1 2 3 4
/dev/sdb: gpt partitions 1 2 3 4 5 6
making boot filesystem on /dev/sdb2 ...
/dev/sdb2 contains a ext4 file system
        last mounted on /tmp/mnt-root on Mon Nov 15 09:54:53 2021
Proceed anyway? (y,n) y
making user filesystem on /dev/sdb6 ...
installing grub to /dev/sdb ...
making empty grub environment block ...
making grub core image ...
setting up grub MBR on /dev/sdb ...
install to /dev/sdb, runtime on /dev/sdb
installing grub modules/configs in boot partition /dev/sdb2 ...
[   68.403429] EXT4-fs (sdb2): mounted filesystem with ordered data mode. Opts: (null)
root@vc:/#

Bingo !
it boots without the usb key now :star_struck: :heart_eyes:

So to unbrick the device, i flashed this image : on an usb stick with Rufus.
inserted it in one of the usb port, and pluged in the power cable.
at the F12 prompt, selected my usb key. and then it booted.
after a few seconds, once the text is no longer scrolling on the screen. just push enter.
and run the command :
./installer -d sdb -p
once finished, type reboot, and remove the usbkey.

now i'm with the unofficial OpenWrt...at least.

2 Likes

my method was slightly less invasive :slight_smile:

image

1 Like

yes but you are not as crazy as me, you did not start by deleting all the partitions :rofl:

well, so now that i can access to the shell, how did you do ? can you show us step by step how to do the same ?

btw you have twice : Force velocloud Root2

did what ? as my screen shot ?

I did pretty much Sysupgrade help for x86_64 - #14 by frollic , but wiped one of the Velocloud partitions, to fit openwrt.

it's just an entry in Grub, no big deal.

My problem is Tips for getting cheap used x86-based firewall with full Gbit NAT (a PC Engines APU) if you are in the US - #320 by frollic

yes.

actualy all the ports seems to work and are recognized :

i can connect to internet and receive mys ISP ipv4 address. but for some reason i can't browse internet, nor ping anything on internet.

1 Like

looks like your WAN0 isn't in the wan zone (should be red)

how can i verify that ?
seems to be ok for me...


config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option disable_ipv6 '1'

config zone
	option name 'lan'
	option network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'

config zone
	option name 'wan0'
	option network 'wan0'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'

config zone
	option name 'wan1'
	option network 'wan1'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'

config zone
	option name 'sta'
	option network 'sta'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'

config zone
	option name 'cell0'
	option network 'cell0'
	option input 'REJECT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'

config forwarding
	option src 'lan'
	option dest 'wan0'

config forwarding
	option src 'lan'
	option dest 'wan1'

config forwarding
	option src 'lan'
	option dest 'sta'

config forwarding
	option src 'lan'
	option dest 'cell0'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan0'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan1'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'sta'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-Ping'
	option src 'wan0'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-Ping'
	option src 'wan1'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-Ping'
	option src 'sta'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-Ping'
	option src 'cell0'
	option proto 'icmp'
	option icmp_type 'echo-request'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'wan-icmp-rate-limit'
	option src 'cell0'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbor-solicitation'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config include
	option path '/etc/firewall.user'

config include 'miniupnpd'
	option type 'script'
	option path '/usr/share/miniupnpd/firewall.include'
	option family 'IPv4'
	option reload '1'

remember, i'm still with the old OpenWrt

what does /etc/config/firewall look like ?

esp the the zone below

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

IIRC colors for interfaces and firewall zones are independent, with some strings hardcoded to a color ("WAN" is red, "LAN" is green), and since he's using "WAN0" it will get a random color.

i posted my FW config here

ah!

That I didn't know.

in that case double check the default GW and DNSes on the clients, @shdf

@frollic with the recent OpenWrt you flashed on your 500, all your ports are recognized ? you can browse internet with it ?

nope, but that was expected, there's some kind of hw quirk implemented, not in mainline kernel.

as described here

here is my /etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config interface 'lan'
	option ifname 'sw0p0 sw0p1 sw0p2 sw0p3 sw1p0 sw1p1 sw1p2 sw1p3'
	option proto 'static'
	option type 'bridge'
	option netmask '255.255.255.0'
	option ipaddr '192.168.1.1'
	option gateway '192.168.1.1'
	option broadcast '192.168.1.255'

config interface 'wan0'
	option ifname 'eth2'
	option proto 'dhcp'
	option hostname 'vc-wan0'
	option vendorid 'neufbox_Velocloud_520'

config interface 'wan1'
	option ifname 'eth3'
	option proto 'dhcp'
	option hostname 'vc-wan1'
	option vendorid 'neufbox_Velocloud_520'

config interface 'sfp0'
	option ifname 'eth4'
	option proto 'dhcp'
	option hostname 'vc-sfp0'

config interface 'sfp1'
	option ifname 'eth5'
	option proto 'dhcp'
	option hostname 'vc-sfp1'

config interface 'sta'
	option ifname 'wlan0-1'
	option proto 'dhcp'
	option hostname 'vc-sta'

that vendorid is necessary to connect to my isp

maybe i can create just one wan and add eth2/3/4/5 in it ?

I’ve got an Edge 5x0/520. Do y’all think there’s any hope of getting a new image running on here? I’m running the old modified version that was released on the netgate forum.

500/510/520/540 are all x86 but with different networking chips, so i think they will all need their own image. So for each device we need an involved openWrt guru :sweat:

btw if you're using a 520, didn't you had the same problem as me ? i can get my WAN IP from my ISP, but i can't browse internet, even a ping 8.8.8.8 from the router doesn't work...