Trying to debrick my FritzBox 4040

Hello, I have been using openWRT for quite a time now, and I am very happy with it, it seemed to me a marvellous product (sometimes a bit complicated for me as it has lots of functions).

I have it installed in a Fritz!Box 4040 router.

I was trying to create now a second wifi and a VLAN to separate traffic for my IOT devices.

The problem is that when I created the VLAN it disconnected it does not work anymore.

When I added the VLAN it assigned it the ID 2 and as I only wanted to assign to that VLAN the WIFI devices, I set to off all switch ports.

When I saved it there appered a quick message saying somethin that eth0 has been reassigned and then I could not access router anymore.

I have tried to reset it but there is no reset button.
Tried to debrick using failsave mode, but in the device page there is no information about debricking just sends you to the general debrick page.
But you don't know which is the button you should use to enter failsafe.

I have tried both, pressing WPS or WLAN buttons when the router boots, after a while, when the power light blinks quick after the initial flashing.

When I press WPS the info light begins blinking quick, so I suppose that it enter failsafe mode.

But then I connected an ethernet cable to LAN1 or WAN ports, but no DHCP IP is provided to my computer.

How do yo enter failsafe mode in this devices?

Thanks a lot for any help. I am in a real mess, now.

Yup, that is failsafe mode.

DHCP server is not enabled in failsafe mode. You need to set your computer's IP address manually:

  • IP: 192.168.1.2 (the last digit can be really anything from 2-254)
  • Subnet mask: 255.255.255.0

You will need to ssh into the router, since LuCI (the web interface) will also not be active when using failsafe (username: root, password: [blank]). You can either try to fix the configuration using the command line interface (UCI commands or editing the files directly), or you can simply reset to defaults and reboot the system.

VLAN 2 is reserved for the WAN in many situations, which may be why you got into trouble. That can be changed, of course, but you generally that is the default configuration (VLAN 1 = LAN, VLAN 2 = WAN). Next time, though, try another number like VLAN 3.

1 Like

Thanks a lot, you have safe my life (my sons are going to kill mi xD ).

I had tried assigning 192.168.1.2 but was trying to access it via htpp.

ssh works, thanks a lot (in the lan1 port at least).

Now I have to study where in the config files are the vlans and delete the vlan i had created.

Thanks a lot.

Well thank, I could debrick my router and return to previous configuration using failsafe mode without having to reset.

I have upgraded to last openWRT version.

I could not configured my vlan yet, I don't understand how it works.

But that is another question. I will ask about it after stuying about vlan configs a littel more.
This has been solved.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.