Troubleshooting: Router won't connect to specific device via ethernet, others ok

I've discovered a bizarre problem where if I connect a laptop directly via ethernet to my OpenWrt router, the connection doesn't work. Wirelessly, the connection is fine. Wired to a different router, the connection is fine.

Offending Laptop: 2009 Macbook Pro 5,5
OpenWrt 19.07.6 device: Newifi D2 MT7621

When plugged. the `logread` from the OpenWrt device looks like this (repeating):
mtk_soc_eth 1e100000.ethernet eth0 port 0 link up
mtk_soc_eth 1e100000.ethernet eth0 port 0 link down
mtk_soc_eth 1e100000.ethernet eth0 port 0 link up
mtk_soc_eth 1e100000.ethernet eth0 port 0 link down
relevant JournalD log entries on the laptop
NetworkManager manager: (enp0s10): new Ethernet device (/org/freedesktop/NetworkManager/Devices/2)
NetworkManager device (enp0s10): state change: unmanaged -> unavailable (reason 'managed', sys-iface-state: 'external')
relevant Kernel Log entries on the laptop
forcedeth 0000|0:0a.0 enp0s10: renamed from eth0|
forcedeth 0000|0:0a.0 enp0s10: MSI enabled|
forcedeth 0000|0:0a.0 enp0s10: no link during initialization|

Now my first thought was "bad cable" or "broken ethernet port". But I've eliminated these. I am fortunate to have enough hardware to test every combination:
2 computers, 2 routers, 2 ethernet cables, 2 ISPs, 1 USB ethernet adapter, 2 operating systems,
5 sheets of high-powered blotter acid.

The suspect laptop connects fine via the Ethernet port to the 2nd router (GL.iNet). It also connects fine to the OpenWRT router using a USB Ethernet dongle. All possible connections are ok except for when I connect the Macbook Pro to the OpenWRT box via the ethernet port. This computer has a dual boot, and the SAME results are encountered both on Linux and on MacOS, so this eliminates even a software or network driver issue. The only common denominator is the physical ethernet port connected to the OpenWRT router.

I've given up trying to figure out what is going on. I've already reflashed the router, etc. Any idea's on next steps to troubleshoot exactly why this connection is not successful?

1 Like

Try ethtool on the router side, and play with the port settings.

1 Like

Seems most of the functions of ethtool I tried were not supported on the router. Also tried on the laptop but did not find any revealing information. Not sure what to do with the port settings.

try a different port on the router? It sounds like the router port is physically borked. Do other devices connect via this port just fine?

1 Like

The router has 4 LAN ports. All ports connect fine to other devices. All ports will not connect to the problem device. The problem device will connect fine to all other devices.

1 Like

Force link speed, disable auto negotiation..

Problem fixed itself.

I could never determine the cause nor the solution, but now it works. I would always restore the configuration to the prior settings after changing config to troubleshoot.

Then magically, it all just worked.

At the same time I was having this issue, I also noticed that other devices had really slow eth0 transfer speeds compared to connected via WiFi5. (ie, 30M wired / 80M Wireless) Currently, that issue resolved itself as well. I'm now getting beyond the maximum speeds I would expect from my ISP even while going through a Wireguard tunnel. (~150M)


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.