Troubleshooting connection - Netgear R7800


Yesterday I managed to install OpenWrt 21.02 on my Netgear R7800 without problems. Trying to surf the net with default settings, I immediately noticed that sometimes the browser wouldn't resolve site URLs.

Did some research, tried to clean flash the firmware again, turning on software/hardware offload, turning off ipv6, flush DNS with various results: sometimes I could navigate smoothly but the issue soon came back.

I tried to downgrade to OpenWrt 19.07. Maybe it was placebo, it seemed a little better but I still had problems with simple web surfing as before.

Tried to ping both from CMD and from LUCI diagnostic tool, no ping back from ipv6. Tried DSL reports, minimal data loss and average speed, but I managed to complete the test without errors just 2 or 3 times out dozens (lot of errors from start to finish).

For now I reverted to stock firmware, but I'd really like to troubleshoot this and try OpenWrt.

My network is composed by a modem/router from my ISP currently acting only as modem (wifi turned off) with a lan/lan connection to the R7800. Maybe the issue is here, but on the wiki for my country (Italy) I only found some workarounds for a different ISP.

Let me know if I should provide more info.

Thanks for your time.

If your modem is only a modem, it shouldn't be connected via LAN-LAN to your router, if it is, you're bypassing the R7800 altogether.

1 Like

I read that a wan/lan connection would create issues with double-nat, that's why I opted for the lan/lan.

So you think that was the problem? If I go the wan/lan route, won't I get problems related to port forwarding, etc?


If you want to avoid double nat then you have to configure it as a dumb ap.

I personally have never had any problems with double nat except added latency. Its usually improved or fixed by disabling firewall and any packet filtering on the upstream nat device. I think it also helps when the downstream router is the only device the upstream router is serving to (no other clients).

But if you're already NATed, then your ISPs device isn't just a modem. Something doesn't add up....

1 Like

Ok, I switched the mode to AP. Could it be worth to try flashing OpenWrt again or that may have not been the issue?

@frollic it's a modem/router from the ISP which is mandatory to use their connection, I just disabled the wifi antenna and cascaded my old R7800. Can I give you more info maybe?

Did it solve the issue?

Sorry for the late reply, couldn't test it sooner. Unfortunately, it didn't work out. What else could it be?

You need to provide additional info regarding the issue.

I assume you followed when you switched to dumb AP?

Guys, I decided to start from scratch (factory reset, etc) and did everything over again. Now it seems like it's working from the get-go.

Tested the connection on DSLreports, I got better results compared to stock, especially bufferbloat (went from D/E to B, just got some during upload, but I guess I can live with it).

Thank you very much for your time and patience.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.