Troubles with NAT Loopback

OMG...I honestly think you're not looking at the screenshot or something...

From what you pasted, you did have destination zone..what you don't have is src_dport...which is why I asked if you removed it...

So, I'll edit your rule to precisely what I'm suggesting - do not alter the rule:

config redirect                            
       option enabled '1'                  
       option target 'DNAT'                    
       option src 'wan'                    
       option dest 'lan'                      
       option proto 'tcp udp'          
       option dest_ip ''      
       option dest_port '25565'
       option src_dport '25565'            
       option name 'Loopback'                             
       option src_ip ''

Ignore this - again, doesn't matter!

Hey, if one still has this issue, I had the same, while I recently upgraded and changed my Openwrt setup. For me the MTU values were at fault as it seems, and prevented NAT loopback to properly work, even though my firewall forwarding rules were correct (as above).

So please do check your MTU values for your network interfaces: if not the default (1500) set back everything, to 1500 or clear the value to default (1500).