Troubles setting up SIM

I'm trying to setup travel router for my quectel eg25-g USB dongle but I keep failing to setup it in Openwrt for a specific SIM card (Bulgarian A1). It worked fine with another country SIM. All needed packages are installed according to documentation, but this specific card is just impossible to set up :frowning: Here are the most important logs:

root@OpenWrt:~# uqmi -d /dev/cdc-wdm0 --uim-get-sim-state

root@OpenWrt:~# uqmi -d /dev/cdc-wdm0 --get-pin-status
"Not supported"

I'm seeing Error: Unknown error (PIN_STATUS_FAILED) in interface wwan I've set up.
The SIM card is without PIN code, I've tried with PIN set to 0000 but the error is the same.

Any suggestions what might be wrong?
It seems signal is OK:

root@OpenWrt:~# uqmi -d /dev/cdc-wdm0 --get-signal-info
        "type": "lte",
        "rssi": -60,
        "rsrq": -9,
        "rsrp": -83,
        "snr": 6.000000

I'm using OpenWrt on raspberrypi 3:

root@OpenWrt:~# cat /etc/openwrt_version

it says not supported type of SIM i guess, maybe your USB device loked for sertain operators , they can do that

Does the modem loaded with that SIM work in a desktop or laptop computer?


It seems I was just too tired, setting up the modem. The problem was that I put the SIM card incorrectly :open_mouth:
Anyway for future reference it would be nice to update the wiki page with information that "PIN_STATUS_FAILED" might suggest that SIM card is not inserted correctly.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.